当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 升级2.6.31失败,貌似和GDM有关(求助)
帖子发表于 : 2009-09-19 21:06 

注册: 2009-04-03 15:10
帖子: 1831
送出感谢: 0 次
接收感谢: 0 次
今天升级2.6.31的内核,但是没有成功,我的情况有些特殊:
以前用的是8.10,我用8.10编译过2.6.31-rc6的内核,现在换了9.04,另外硬盘换成ext4文件系统的了(8.10是ext3),我还是用8.10编译rc6的配置文件来编译2.6.31的稳定版(当然文件系统换成ext4了,其他没变!),以前用这个配置文件是可以编译成功的,但是这次编译并且打包为deb安装以后,重启却蓝屏,提示如下:
代码:
Server Authorization directory (daemon.servAuthDir) is set to /var/lib/gdm but this does not exist. Please correct GDM configuration and restart GDM.

底下一个OK选项,然后就无法正常启动X了,只能在文本界面登录,而且我还发现一些怪事:无法mount /home分区了,但是根分区还能mount上,此外这个时候如果使用sudo shutdown -r 0重启会宕掉,只能强关。
这是为什么?谁能帮帮忙解释一下,我放狗搜了半天没有一个人遇到这种情况的。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级2.6.31失败,貌似和GDM有关(求助)
帖子发表于 : 2009-09-19 22:31 

注册: 2009-04-03 15:10
帖子: 1831
送出感谢: 0 次
接收感谢: 0 次
我晕,终于找到问题症结所在了,原来除了根分区外根本没有挂载任何其他的分区,原因是如果要用ext4,那么前面块设备里面的2TB块设备支持必须打开!!!
不过我觉得这不是搞笑么……为什么会有这么奇怪的一个问题!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译