当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 求助 升级源出现错误
帖子发表于 : 2009-09-21 12:55 

注册: 2009-08-24 22:30
帖子: 66
送出感谢: 0 次
接收感谢: 0 次
命中 http://tw.archive.Ubuntu.com jaunty-proposed/restricted Packages
命中 http://tw.archive.Ubuntu.com jaunty-proposed/universe Packages
命中 http://tw.archive.Ubuntu.com jaunty-proposed/multiverse Packages
命中 http://tw.archive.Ubuntu.com jaunty-proposed/main Sources
命中 http://tw.archive.Ubuntu.com jaunty-proposed/restricted Sources
命中 http://tw.archive.Ubuntu.com jaunty-proposed/universe Sources
命中 http://tw.archive.Ubuntu.com jaunty-proposed/multiverse Sources
正在读取软件包列表... 完成
atx@atx-desktop:~/桌面$ followed by
bash: followed:找不到命令
atx@atx-desktop:~/桌面$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列的软件包的版本将保持不变:
linux-generic linux-headers-generic linux-image-generic
linux-restricted-modules-generic
下列的软件包将被升级:
app-install-data app-install-data-partner bind9-host dbus dbus-x11
dhcp3-client dhcp3-common dnsmasq-base dnsutils firefox firefox-3.0
firefox-3.0-branding firefox-3.0-gnome-support firefox-gnome-support
flashplugin-installer flashplugin-nonfree gnome-terminal gnome-terminal-data
language-pack-en language-pack-gnome-en language-pack-gnome-zh libbind9-40
libc6 libc6-dev libc6-i686 libcurl3-gnutls libdbus-1-3 libdns45
libgl1-mesa-dri libgl1-mesa-glx libglu1-mesa libgnutls26 libisc45 libisccc40
libisccfg40 liblwres40 libmono-cairo2.0-cil libmono-corlib2.0-cil
libmono-data-tds2.0-cil libmono-data2.0-cil libmono-getoptions2.0-cil
libmono-i18n2.0-cil libmono-posix2.0-cil libmono-security2.0-cil
libmono-sharpzip2.84-cil libmono-system-data2.0-cil libmono-system2.0-cil
libmono0 libnspr4-0d libnss3-1d libopenexr6 libpam-modules libpam-runtime
libpam0g libprotobuf3 libpulse-browse0 libpulse0 libpulsecore9 libpurple-bin
libqtcore4 libqtgui4 libsmbclient libssl0.9.8 libtiff4 libudev0
libvolume-id1 libvorbis0a libvorbisenc2 libvorbisfile3 libwbclient0
libxcb-render0 libxcb1 libxklavier12 libxml2 libxml2-utils linux-libc-dev
linux-restricted-modules-common mesa-utils mono-2.0-gac mono-2.0-runtime
mono-common mono-gac mono-jit mono-runtime openssl pm-utils pulseaudio
pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-hal
pulseaudio-module-x11 pulseaudio-utils python-gobject python-libxml2 samba
samba-common smbclient smbfs thunderbird thunderbird-gnome-support tzdata
udev update-notifier update-notifier-common xulrunner-1.9
xulrunner-1.9-gnome-support
共升级了 106 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 4 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/87.1MB 的软件包。
解压缩后会消耗掉 10.3MB 的额外空间。
您希望继续执行吗?[Y/n]Y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: 资源临时不可用
(正在读取数据库 ... 系统当前总共安装有 100272 个文件和目录。)
正预备替换 libpam-modules 1.0.1-9ubuntu1 (使用 .../libpam-modules_1.0.1-9ubuntu1.1_i386.deb) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: 资源临时不可用
dpkg:处理 /var/cache/apt/archives/libpam-modules_1.0.1-9ubuntu1.1_i386.deb (--unpack)时出错:
子进程 pre-installation script 返回了错误号 1
在处理时有错误发生:
/var/cache/apt/archives/libpam-modules_1.0.1-9ubuntu1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
就是这样
显示了正在刷新.......完成 出现软件更新管理器 更新到一半就出现
dpkg:处理 /var/cache/apt/archives/libpam-modules_1.0.1-9ubuntu1.1_i386.deb (--unpack)时出错:
子进程 pre-installation script 返回了错误号 1
还有一些代码和这差不多
怎么办啊~~~
这还有张图片http://zhidao.baidu.com/question/118029469.html
怎么办阿先谢谢高手了 我换过cn99的源但还是这个错误


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 13:15 
头像

注册: 2009-04-29 13:53
帖子: 1487
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
换骨头源试试:http://forum.ubuntu.org.cn/viewtopic.php?f=1&t=227467


_________________
UbuntuABC


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 17:57 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
这种错误,换100000000000次源都是一样的。

楼上是骨头的马甲?


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 18:00 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: 资源临时不可用

/var/cache/debconf/目录下是否有lock文件,有的话就删除。


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 18:36 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
/var/cache/debconf

里面包含的文件是由那些具有debconf的软件包生成的。(这种软件包包含一个叫template的文件。完全删除这个软件包必须要用purge)

为了避免冲突,同时写入,就应该有锁文件。就和apt-get的锁文件一样。

没有更多资料自能写这么多!


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 18:38 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
百度的回答都比2楼专业!


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 19:27 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
3L到6L,您别激动


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 21:05 

注册: 2009-08-24 22:30
帖子: 66
送出感谢: 0 次
接收感谢: 0 次
是把纳两个文件删了吗?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 21:12 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
我怀疑/var/cache/debconf下面有个lock文件,把那个删了就可以了。
然后


sudo apt-get -f install


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 21:22 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
激动了。。。。。

我今天看到了太多推广这个源的帖子。

推广快速的源是个好事,但是如果不经考虑就把这个当作问题的解我看不好!


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 21:25 

注册: 2009-08-24 22:30
帖子: 66
送出感谢: 0 次
接收感谢: 0 次
atx@atx-desktop:~/桌面$ aptitude
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: 资源临时不可用
dpkg: 另外一个进程已经为状态数据库加了锁
E: Sub-process /usr/bin/dpkg returned an error code (2)
软件包安装失败。正在试图恢复:
dpkg: 另外一个进程已经为状态数据库加了锁
按回车继续。

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: 资源临时不可用
E: Sub-process /usr/bin/dpkg returned an error code (2)
软件包安装失败。正在试图恢复:
dpkg: 另外一个进程已经为状态数据库加了锁
按回车继续。

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: 资源临时不可用
正在设置 xinyang-grub-splashimages (9.04) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: 资源临时不可用
dpkg:处理 xinyang-grub-splashimages (--configure)时出错:
子进程 post-installation script 返回了错误号 1
在处理时有错误发生:
xinyang-grub-splashimages
E: Sub-process /usr/bin/dpkg returned an error code (1)
软件包安装失败。正在试图恢复:
正在设置 xinyang-grub-splashimages (9.04) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: 资源临时不可用
dpkg:处理 xinyang-grub-splashimages (--configure)时出错:
子进程 post-installation script 返回了错误号 1
在处理时有错误发生:
xinyang-grub-splashimages
删除了也不行


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 21:28 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
代码:
lsof /var/cache/debconf/config.dat


打印结果!


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 21:29 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
某进来是向cnkillor这个杀生的佛太学习怎么处理这类dpkg报错问题的。 :em02


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 21:30 
头像

注册: 2007-08-05 17:40
帖子: 4968
送出感谢: 0 次
接收感谢: 4
里面肯定有个程序在使用这个文件的,杀掉这个程序就可以了。如果你不敢杀掉这个程序就重启。


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 求助 升级源出现错误
帖子发表于 : 2009-09-21 21:36 

注册: 2009-08-24 22:30
帖子: 66
送出感谢: 0 次
接收感谢: 0 次
E: /var/cache/apt/archives/libpam-modules_1.0.1-9ubuntu1.1_i386.deb: 子进程 pre-installation script 返回了错误号 1
还是不行


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:MSNbot Media, peteryeh64 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译