当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 奇怪问题
帖子发表于 : 2009-09-23 10:57 
头像

注册: 2006-01-02 0:12
帖子: 368
送出感谢: 0 次
接收感谢: 0 次
小弟T61p笔记本,装了64位的Win7和64位9.04。之前一直没有问题,最近开机老是找不到操作系统,就是开机后就一个黑屏上一个闪烁的光标,就不动了。不会启动Win也不启动Grub。用win的安装盘修复mbr无效,用ubuntu的live-cd修复grub后,可以成功修复,而且可以进入win和ubuntu。进入ubuntu后重启没问题,进win7后重启引导信息又丢失。重复数次,依然这样。进win杀毒能查到3个病毒,删除后重启仍然没有引导信息。在Google上搜了半天也没见到和我一样的情况。请高人指点。先谢谢了。


附件:
文件注释: 查到的病毒
.PNG
.PNG [ 133.54 KiB | 被浏览 491 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 10:59 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
啊,win下有帮手嘛。专门修改mbr。多半是。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 11:05 
头像

注册: 2006-01-02 0:12
帖子: 368
送出感谢: 0 次
接收感谢: 0 次
ee的意思是有病毒?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 11:12 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
应该是


_________________
Grub2 基础教程


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 11:16 
头像

注册: 2006-01-02 0:12
帖子: 368
送出感谢: 0 次
接收感谢: 0 次
正在下64位的专业杀毒软件。微软这个MSE还是beta状态,不太放心。原来以为64位系统+一般的杀软就没问题了,现在看来还的弄个专业点的杀软啊。先装个杀软试试吧,是病毒就好办了,只要别是硬件问题就行。呵呵。 :em01


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 11:18 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
是药三分毒

楼主以后有得罪受


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 12:42 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
我有一次插上了华为et128,就出现lz状况了

所以,只要是cdfs的移动设备,启动时都拔下来


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 12:44 
头像

注册: 2006-01-02 0:12
帖子: 368
送出感谢: 0 次
接收感谢: 0 次
用nod32查完毒,查到威胁, :em20 删除后重启仍然不能引导。继续求解。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 12:47 
头像

注册: 2007-11-14 17:39
帖子: 441
送出感谢: 0 次
接收感谢: 0 次
ubuntu和win分别装在那个分区?
把分区表post出来看看


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 12:49 
头像

注册: 2006-01-02 0:12
帖子: 368
送出感谢: 0 次
接收感谢: 0 次
我这里也没接啥移动硬盘,U盘之类的啊。就接了键盘,鼠标,显示器。以前也是这些东西啊。倒是前几天为了玩极品飞车13,装了个破虚拟光驱,对Win7兼容不好,用兼容模式装的,后来怎么也删不掉。已经在启动项里禁用了啊。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 12:54 
头像

注册: 2006-01-02 0:12
帖子: 368
送出感谢: 0 次
接收感谢: 0 次
kunkun0217 写道:
ubuntu和win分别装在那个分区?
把分区表post出来看看

如图,E盘是Win的系统分区,I盘是win的应用软件分区。剩下三个是ubuntu的分区。7G的是/,4G的是swap,最大的是/home


附件:
.PNG
.PNG [ 143.09 KiB | 被浏览 451 次 ]

页首
 用户资料  
 
12 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 13:01 
头像

注册: 2006-01-02 0:12
帖子: 368
送出感谢: 0 次
接收感谢: 0 次
为什么我有5个主分区?我记得一个硬盘最多只能有4个主分区不是?


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 13:01 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
或者换哥伦布4dos来引导下试试,把哥伦布4dos的迷你引导代码直接写入MBR。有时主板Bios有问题,会引导硬盘有问题。或是硬盘本身连接不良。
viewtopic.php?f=139&t=150541#grub4dos简介和使用方法
http://download.gna.org/grub4dos/#下载grub4dos的最近支持ext4的正式版本0.4.4正式版
viewtopic.php?f=139&t=225669&p=1448778#p1448778#smallapple的哥伦布2代基础教程和故障修复。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-23 14:14 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
Jeff-cao 写道:
为什么我有5个主分区?我记得一个硬盘最多只能有4个主分区不是?


别管win7的SB磁盘管理器,把不认识的分区都当主分区。 :em20 :em20

看看ub 下的sudo fdisk -l和sudo parted /dev/sda print


_________________
Grub2 基础教程


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 奇怪问题
帖子发表于 : 2009-09-24 0:11 
头像

注册: 2006-01-02 0:12
帖子: 368
送出感谢: 0 次
接收感谢: 0 次
感谢各位的热心帮忙,最后还是用了最极端的方法搞定了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译