当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : gcc-2.95.3的安装问题(系统的gcc版本是4.4.1)
帖子发表于 : 2009-09-26 8:40 

注册: 2009-08-27 6:46
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
因为要做uCLinux的内核编译,我用的Ubuntu9.10的gcc编译器版本太高,编译出错,所以必须换个低版本的gcc,就找了这个2.95。下载了gcc-2.95.3.tar.gz,解压后,执行如下命令:
../gcc-2.95.3/configure --host=i686-pc-linux-gnu --prefix=/usr/local --enable-shared --enable-languages=c --enable-threads=posix
出现的信息是:
Configuring libiberty...
loading cache ../config.cache
checking host system type... i486-pc-linux-gnu
checking build system type... i486-pc-linux-gnu
checking for ar... (cached) ar
checking for ranlib... (cached) ranlib
checking for gcc... (cached) gcc
...(省略了)
creating po/Makefile.in
creating fixinc/Makefile
creating auto-host.h
auto-host.h is unchanged
linking .././gcc-2.95.3/gcc/intl/libgettext.h to intl/libintl.h
creating libintl.h
Configuring etc...
loading cache ../config.cache
checking for a BSD compatible install... (cached) /usr/bin/install -c
creating ./config.status
creating Makefile
请问这说明我安装2.95成功了么?如果我想在以后使用2.95作为默认的gcc编译器来使用,该怎么做呢? :em01


页首
 用户资料  
 
2 楼 
 文章标题 : Re: gcc-2.95.3的安装问题(系统的gcc版本是4.4.1)
帖子发表于 : 2009-09-26 8:42 

注册: 2009-08-27 6:46
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
我用gcc -v查看gcc版本,显示的还是4.4.1


页首
 用户资料  
 
3 楼 
 文章标题 : Re: gcc-2.95.3的安装问题(系统的gcc版本是4.4.1)
帖子发表于 : 2009-09-26 21:27 

注册: 2008-03-24 19:06
帖子: 208
送出感谢: 0 次
接收感谢: 1
你这个自然是没有安装成功的,还需要make啊!!
建议路径不要选/usr/local,建议装在自己的主目录中,然后写一个sh文件,每次运行时先运行一下,就好,还不影响你的系统使用啊。
你是做嵌入式开发吗,--host=i686-pc-linux-gnu这个参数也不对
我的经验是要加上参数--without-newlib才能编译过的,你可以试试,我是试过很多次后得出的结论


页首
 用户资料  
 
4 楼 
 文章标题 : Re: gcc-2.95.3的安装问题(系统的gcc版本是4.4.1)
帖子发表于 : 2009-09-26 21:42 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
把原来gcc4.4.1的链接文件改名,自己用ln把gcc2.95.3链接到默认的gcc就行了。 :em03


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: gcc-2.95.3的安装问题(系统的gcc版本是4.4.1)
帖子发表于 : 2009-09-27 17:51 

注册: 2008-03-24 19:06
帖子: 208
送出感谢: 0 次
接收感谢: 1
[quote="wangdu2002"]把原来gcc4.4.1的链接文件改名,自己用ln把gcc2.95.3链接到默认的gcc就行了。 :em03[/quote]
这样系统软件装不上了,不方便啊


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译