当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : dict-xdict: 子进程 已安装的 post-removal 脚本 返回了错误号 100
帖子发表于 : 2009-10-07 10:27 

注册: 2009-07-24 8:35
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
dict-xdict: 子进程 已安装的 post-removal 脚本 返回了错误号 100,请高手指招


页首
 用户资料  
 
2 楼 
 文章标题 : Re: dict-xdict: 子进程 已安装的 post-removal 脚本 返回了错误号 100
帖子发表于 : 2009-10-07 19:50 

注册: 2009-09-18 18:35
帖子: 53
送出感谢: 0 次
接收感谢: 0 次
ooopp01 写道:
dict-xdict: 子进程 已安装的 post-removal 脚本 返回了错误号 100,请高手指招

我的也是!不知道怎么解决那!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: dict-xdict: 子进程 已安装的 post-removal 脚本 返回了错误号 100
帖子发表于 : 2009-10-15 8:56 

注册: 2009-07-24 8:35
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
今天终于找到问题所在了。原来是因为sun-java6-doc未安装成功导致的。所以重新到网上找了个sun-java6-doc安装后可以了。sun-java6-doc安装可以参考这个帖子:http://hi.baidu.com/mxfyang/blog/item/30a72d912ee43487a877a4fe.html


页首
 用户资料  
 
4 楼 
 文章标题 : Re: dict-xdict: 子进程 已安装的 post-removal 脚本 返回了错误号 100
帖子发表于 : 2009-10-31 13:04 

注册: 2008-10-29 14:53
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我也遇到类似的问题。我是升级到ubuntu9.10时,发生dict-xdict升级不成功导致的,后来仔细研究发现是依赖关系有问题,安装了dictd就可以了,命令如下:sudo apt-get install dictd
然后问题解决了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: dict-xdict: 子进程 已安装的 post-removal 脚本 返回了错误号 100
帖子发表于 : 2009-12-09 16:19 
头像

注册: 2009-08-14 16:24
帖子: 314
送出感谢: 0 次
接收感谢: 0 次
不行阿~




lucifer@lucifer-laptop:~$ sudo apt-get install dictd
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
dictzip libmaa1
建议安装的软件包:
dict-wn dict-jargon dict-foldoc
下列软件包将被【卸载】:
dict-xdict
下列【新】软件包将被安装:
dictd dictzip libmaa1
共升级了 0 个软件包,新安装了 3 个软件包,要卸载 1 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 258kB 的软件包。
解压缩后将会空出 4,788kB 的空间。
您希望继续执行吗?[Y/n]y
获取:1 http://ubuntu.cn99.com karmic/main libmaa1 1.1.1-1 [63.2kB]
获取:2 http://ubuntu.cn99.com karmic/main dictzip 1.11.1+dfsg-2 [53.2kB]
获取:3 http://ubuntu.cn99.com karmic/main dictd 1.11.1+dfsg-2 [141kB]
下载 258kB,耗时 10 秒 (23.8kB/s)
正在预设定软件包 ...
(正在读取数据库 ... 系统当前总共安装有 139858 个文件和目录。)
正在删除 dict-xdict ...
invoke-rc.d: unknown initscript, /etc/init.d/dictd not found.
dpkg:处理 dict-xdict (--remove)时出错:
子进程 已安装的 post-removal 脚本 返回了错误号 100
在处理时有错误发生:
dict-xdict
E: Sub-process /usr/bin/dpkg returned an error code (1)
lucifer@lucifer-laptop:~$


_________________
我很乖的。。。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: dict-xdict: 子进程 已安装的 post-removal 脚本 返回了错误号 100
帖子发表于 : 2010-07-08 22:51 

注册: 2009-07-20 16:39
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
在/etc/init.d/下建个dictd,然后执行apt-get remove --purge dict-xdict就可以了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译