当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : gpg密钥验证错误,提示所有权不安全。
帖子发表于 : 2009-10-10 17:45 
头像

注册: 2007-11-02 13:46
帖子: 970
送出感谢: 0 次
接收感谢: 1
我运行命令
代码:
sudo apt-get update

后出现gpg签名验证错误:
引用:
W: GPG签名验证错误: http://ppa.launchpad.net jaunty Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY 3B22AB97AF1CDFA9
W: 您可能需要运行 apt-get update 来解决这些问题

又运行
代码:
sudo gpg --keyserver subkeys.pgp.net --recv 3B22AB97AF1CDFA9

结果出现问题提示所有权不安全
引用:
gpg: 警告:配置文件‘/home/gleerat/.gnupg/gpg.conf’所有权不安全
gpg: 钥匙环‘/home/gleerat/.gnupg/secring.gpg’已建立
gpg: 钥匙环‘/home/gleerat/.gnupg/pubring.gpg’已建立
gpg: 由于配置文件权限不安全,外部程序调用被禁用
gpg: 公钥服务器通讯错误:常规错误
gpg: 从公钥服务器接收失败:常规错误

请问,该怎么解决?


_________________
明察,慎思,笃行


页首
 用户资料  
 
2 楼 
 文章标题 : Re: gpg密钥验证错误,提示所有权不安全。
帖子发表于 : 2009-10-10 17:57 
头像

注册: 2007-06-13 15:57
帖子: 12567
地址: 在他乡
送出感谢: 50
接收感谢: 87
没遇到过,学习的沙发
你这个文件的权限是什么?

引用:
.gnupg/gpg.conf
12K -rw------- 1 daf daf 9.3K 2009-04-28 18:18 .gnupg/gpg.conf


页首
 用户资料  
 
3 楼 
 文章标题 : Re: gpg密钥验证错误,提示所有权不安全。
帖子发表于 : 2009-10-10 19:44 
头像

注册: 2007-11-02 13:46
帖子: 970
送出感谢: 0 次
接收感谢: 1
daf3707 写道:
没遇到过,学习的沙发
你这个文件的权限是什么?

引用:
.gnupg/gpg.conf
12K -rw------- 1 daf daf 9.3K 2009-04-28 18:18 .gnupg/gpg.conf

不知道啊,找不到文件啊!


_________________
明察,慎思,笃行


页首
 用户资料  
 
4 楼 
 文章标题 : Re: gpg密钥验证错误,提示所有权不安全。
帖子发表于 : 2009-10-22 16:44 

注册: 2009-10-22 16:42
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
请问楼主解决这个问题了吗?我也遇到了这样的问题。。。
求解


页首
 用户资料  
 
5 楼 
 文章标题 : Re: gpg密钥验证错误,提示所有权不安全。
帖子发表于 : 2009-10-23 21:03 
头像

注册: 2007-03-23 18:06
帖子: 269
送出感谢: 0 次
接收感谢: 0 次
引用:
代码:
代码:
sudo gpg --keyserver subkeys.pgp.net --recv 3B22AB97AF1CDFA9

不应该用sudo,这样是给root的密匙.


_________________
[i]Ubuntu 9.10RC@Dell 710M
/Intel(R) Pentium(R) M processor 1.60GHz
/2048MB Memory/
60G IDE HD
/855GM Integrated Graphics Device
http://blog.chinaunix.net/u3/104343/


页首
 用户资料  
 
6 楼 
 文章标题 : Re: gpg密钥验证错误,提示所有权不安全。
帖子发表于 : 2010-01-20 20:24 

注册: 2010-01-12 7:41
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
感谢楼上,也碰见同样问题。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: gpg密钥验证错误,提示所有权不安全。
帖子发表于 : 2012-10-27 19:07 

注册: 2011-12-23 19:38
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
GPG 错误:http:/.gnupg/gpg.conf’所有权不安全
  又再查资料,最终得出如下解决方案:需要在打开终端后,用root用户登录后,删除问题签名,然后重新导入该签名。退出root用户并清除缓存后,重启更新。
  具体操作如下:
进入终端
sudo su
gpg --delete-key --armor ********
sudo apt-key del ********

gpg --keyserver-options http-proxy --keyserver keyserver.ubuntu.com --recv ********
gpg --export --armor ******** | sudo apt-key add -
exit
上面“********”代表有问题的签名。上面操作主要作用是,用root用户登录后,删除问题签名,然后重新导入该签名,并退出root用户

下面的操作,则是用来清缓存并用sudo apt-get update进行更新
sudo apt-get clean
cd /var/lib/apt
sudo rm -rf lists.old
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

问题到此解决。
不求经典,但救实用。平湖作品


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译