当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-10-18 12:57 
头像

注册: 2009-10-18 12:20
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我在VMware虚拟机上安装了Kubuntu 9.10,然后再在上面安装WMware-tools,
运行/usr/bin/vmware-config-tool.pl时提示没有支持当前Linux内核的模块,
问是不是编译一个,让它编译,发现编译不过(参见下图),请问有什么样的解决办法?没搜索到VMware-tools的新版本。

安装一个不成功的vmware-tools可麻烦了,连网络也不能用了


附件:
vmware编译不过90.jpg
vmware编译不过90.jpg [ 103.21 KiB | 被浏览 4544 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-10-19 11:06 
头像

注册: 2007-03-23 18:06
帖子: 269
送出感谢: 0 次
接收感谢: 0 次
安装vmtools前首先应该安装编译环境和kernel头文件
你有没有安装linux-headers-2.6.31-??-generic


_________________
[i]Ubuntu 9.10RC@Dell 710M
/Intel(R) Pentium(R) M processor 1.60GHz
/2048MB Memory/
60G IDE HD
/855GM Integrated Graphics Device
http://blog.chinaunix.net/u3/104343/


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-10-19 13:26 

注册: 2009-10-04 18:33
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
同问,可以说详细点吗?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-10-20 0:35 
头像

注册: 2009-10-18 12:20
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我的电脑里有linux headers,应该是默认就安装了,有这个够用了不?还需要安装什么呢?谢谢!


附件:
linux_headers.jpg
linux_headers.jpg [ 20.16 KiB | 被浏览 4515 次 ]

页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-10-20 8:59 
头像

注册: 2007-03-23 18:06
帖子: 269
送出感谢: 0 次
接收感谢: 0 次
首先
代码:
sudo apt-get install build-essential linux-hearder-`uname -r`

然后,安装vmware-tools


_________________
[i]Ubuntu 9.10RC@Dell 710M
/Intel(R) Pentium(R) M processor 1.60GHz
/2048MB Memory/
60G IDE HD
/855GM Integrated Graphics Device
http://blog.chinaunix.net/u3/104343/


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-10-21 0:41 
头像

注册: 2009-10-18 12:20
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我运行下面命令,安装了头文件,也还是不行呢。
代码:
sudo apt-get install linux-headers-generic


安装头文件的目的,是不是生成这些头文件?
我安装头文件之前,它们也存在呢。
这些出错信息感觉是不满足C语法,似乎要么改内核头文件,要么改vmware代码才能解决了?

现在的出错信息:
代码:
Using 2.6.x kernel build system.
make:进入目录'/tmp/vmware-config0/vmmemctl-only'
make -C /lib/modules/2.6.31-11-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules                                                                     
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.31-11-generic'               
  CC [M]  /tmp/vmware-config0/vmmemctl-only/os.o                               
In file included from /tmp/vmware-config0/vmmemctl-only/os.c:40:
/tmp/vmware-config0/vmmemctl-only/compat_wait.h:37:5: warning: "VMW_HAVE_EPOLL" is not defined
/tmp/vmware-config0/vmmemctl-only/compat_wait.h:43:5: warning: "VMW_HAVE_EPOLL" is not defined
In file included from /tmp/vmware-config0/vmmemctl-only/os.c:40:
/tmp/vmware-config0/vmmemctl-only/compat_wait.h:60: error: conflicting types for ‘poll_initwait’
include/linux/poll.h:70: note: previous declaration of ‘poll_initwait’ was here
/tmp/vmware-config0/vmmemctl-only/os.c: In function ‘os_init’:
/tmp/vmware-config0/vmmemctl-only/os.c:567: error: ‘struct proc_dir_entry’ has no member named ‘get_info’
make[2]: *** [/tmp/vmware-config0/vmmemctl-only/os.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config0/vmmemctl-only] 错误 2
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.31-11-generic'
make: *** [vmmemctl.ko] 错误 2
make:离开目录“/tmp/vmware-config0/vmmemctl-only”
Unable to build the vmmemctl module.

The memory manager driver (vmmemctl module) is used by VMware host software to
efficiently reclaim memory from a virtual machine.
If the driver is not available, VMware host software may instead need to swap
guest memory to disk, which may reduce performance.
The rest of the software provided by VMware Tools is designed to work
independently of this feature.
If you want the memory management feature, you can install the driver by
running vmware-config-tools.pl again after making sure that gcc, binutils, make
and the kernel sources for your running kernel are installed on your machine.
These packages are available on your distribution's installation CD.
[ Press Enter key to continue ]


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-10-23 11:35 
头像

注册: 2008-08-25 20:43
帖子: 18
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
我昨天在VM6.5中安装Ubuntu9.10和以前安装9.04的时候也遇到这个问题了。。Google了一下。找到一篇


[url]http://blog.sina.com.cn/s/blog_409dd2540100f1ku.html###[/url]

我看报出来的错误信息和这上面写得也是很像的。现在正在做测试。看安装这种方法改了源码后还能行不。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-10-23 20:20 
头像

注册: 2009-10-18 12:20
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我用VMWare 6.0版本,安装9.04的时候没有出现问题呢:)
不过,是好久之前的事了。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-11-22 23:02 
头像

注册: 2007-12-27 11:31
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
今天在安装VMTools时,我也碰到此问题了。已解决!

安装环境:
VMWare 5.5.1 + Ubuntu8.10

----------------问题及解决-----------------------
What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include]

The path "/usr/src/linux/include" is not an existing directory.

这一步是让你指定c头文件所在的位置,我们进入/usr/src目录,应该这里有两个目录linux-headers-2.6.31-14和 linux- headers-2.6.31-14-generic,现在我们要做的就是新建一个软链接linux,让它指向linux-headers-2.6.31 -14-generic,命令如下

ln -s linux-headers-2.6.31-14-generic linux

现在我们就有了linux这个目录,包含了c头文件,但我们继续配置,还可能会出现以下错误:

What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include]

The directory of kernel headers (version @@VMWARE@@ UTS_RELEASE) does not match your running kernel (version 2.6.31-14-generic). Even if the module were to compile successfully, it would not load into the running kernel.

What is the location of the directory of C header files that match your running kernel? [/usr/src/linux/include]

我们明明以及指向了正确的linux内核头文件夹了,但还是报错了,我们可以这样修改:

进入/usr/src/linux/include/linux目录,修改下面的version.h文件

增加下面一行:

#define UTS_RELEASE "2.6.31-14-generic"

保存退出,继续配置vmware, 安装成功! :em11

友情提示:出现此问题时,不需要中断VMWare Tools的安装,新启动个 Terminal 操作即可!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2009-12-07 12:57 

注册: 2008-06-08 21:21
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
需要打补丁,vm有提供新内核的补丁
http://communities.vmware.com/thread/221724?tstart=0


页首
 用户资料  
 
11 楼 
 文章标题 : Re: Ubuntu9.10编译vmware-tools出错,请问有什么解决办法?谢谢!
帖子发表于 : 2010-03-08 18:07 

注册: 2010-03-08 18:05
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我试验了不少次了,9.10现在vmware tools不是很好用,最多也就是鼠标可以自动出去,至于拷贝,还有共享文档,自动锁屏啥的都不行啊。如果没必要,还是用老版本吧,9.04就完全没问题。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译