当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装phpmyadmin时报错
帖子发表于 : 2009-10-27 14:55 

注册: 2009-10-22 20:32
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我用ubuntu9.04-server安装phpmyadmin报错,好像缺少php5-mcrypt 安装时又报错,我下面该怎么办,以前装过是好的。
root@ubuntu:/# sudo apt-get install phpmyadmin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
phpmyadmin: Depends: php5-mcrypt but it is not installable
E: Broken packages

root@ubuntu:/# sudo apt-get install php5-mcrypt
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-mcrypt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package php5-mcrypt has no installation candidate
root@ubuntu:/#


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装phpmyadmin时报错
帖子发表于 : 2009-10-27 14:56 
头像

注册: 2009-05-20 19:32
帖子: 2462
送出感谢: 0 次
接收感谢: 2
irc <fvw> say: apt-cache search and apt-get it


_________________
irc 聊天室
ubuntu-cn 的irc 频道为
irc.ubuntu.com 8001 #ubuntu-cn
UTF8编码 可用 irssi xchat pidgin weechat 登录

http://webchat.freenode.net/?channels=ubuntu-cn
irc://irc.freenode.net/ubuntu-cn


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装phpmyadmin时报错
帖子发表于 : 2009-10-27 14:59 

注册: 2009-10-22 20:32
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
提示如下:
root@ubuntu:/# apt-cache search and apt-get it
apt - Advanced front-end for dpkg
aptitude - terminal-based package manager
aptitude-dbg - Debug symbols for the aptitude package manager
ttf-sil-padauk - smart Unicode font for languages in Myanmar
root@ubuntu:/#


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装phpmyadmin时报错
帖子发表于 : 2009-10-28 8:35 

注册: 2009-10-22 20:32
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
怎么没人回复?看来我只有从装了。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装phpmyadmin时报错
帖子发表于 : 2009-10-28 8:51 

注册: 2009-10-11 0:18
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
phpmyadmin: Depends: php5-mcrypt but it is not installable

php5-mcrypt 这个包没有安装。


sudo apt-get install php5-mcrypt

试一下。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装phpmyadmin时报错
帖子发表于 : 2009-10-28 19:28 

注册: 2009-10-22 20:32
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
安装时如下提示:
root@ubuntu:/# sudo apt-get install php5-mcrypt
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-mcrypt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package php5-mcrypt has no installation candidate
root@ubuntu:/#


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装phpmyadmin时报错
帖子发表于 : 2009-11-21 14:59 
头像

注册: 2008-01-12 13:07
帖子: 137
送出感谢: 0 次
接收感谢: 0 次
I have the same problem……


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译