当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 9.04升级到9.10 不完整,系统有问题...寻求解决
帖子发表于 : 2009-10-30 23:53 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
从9.04升级到9.10 ,
升级过程中提示mono出错,
重启后系统可以进入桌面,查看系统版本是9.10,但是:
1没有声音,
2.启动时画面很奇怪,接近花屏....




求修复系统的方法,如何恢复声音?那个mono是什么东西???


最后由 xhxiang 编辑于 2009-10-31 0:19,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 9.04升级到9.10 失败,系统有问题...寻求解决
帖子发表于 : 2009-10-31 0:01 
头像

注册: 2008-03-25 15:49
帖子: 25876
地址: 谁知道?
送出感谢: 8
接收感谢: 10
烦烦烦,怎么问题这么多? :em20 :em20 :em20 :em20


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 9.04升级到9.10 失败,系统有问题...寻求解决
帖子发表于 : 2009-10-31 0:02 
头像

注册: 2007-06-27 17:11
帖子: 205
送出感谢: 0 次
接收感谢: 0 次
:em20 我的也没声音了.`.`
`


_________________
代码:
哥不在江湖,江湖却有哥的传说


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 9.04升级到9.10 失败,系统有问题...寻求解决
帖子发表于 : 2009-10-31 0:05 
头像

注册: 2007-01-16 12:41
帖子: 171
送出感谢: 0 次
接收感谢: 0 次
mono是linux中微软.NET的一个实现,开源的。不过没啥用。我装完系统就删除掉了。但是你如果用tomboy或者fshot就要保留了。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 9.04升级到9.10 失败,系统有问题...寻求解决
帖子发表于 : 2009-10-31 0:07 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
修正一下,用新内核重启后声音正常了,启动画面也正常了,
但是mono配置失败,不知道是什么东西....
有人教教我吗?
升级安装结束系统有这样的提示:
"系统处于不可用状态....请运行 dpkg --configure -a"
我运行了那个命令,但出来一大堆,

贴出来:
Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 113.
**
ERROR:metadata.c:1003:mono_metadata_decode_row: assertion failed: (idx < t->rows)

** (/usr/lib/mono/2.0/gacutil.exe:2807): WARNING **: Thread (nil) may have been prematurely finalized
Stacktrace:


** (/usr/lib/mono/2.0/gacutil.exe:2807): WARNING **: Thread (nil) may have been prematurely finalized

** (/usr/lib/mono/2.0/gacutil.exe:2807): WARNING **: Thread (nil) may have been prematurely finalized

Native stacktrace:

/usr/bin/mono [0x80c8824]
[0x30d410]
[0x30d422]
/lib/tls/i686/cmov/libc.so.6(gsignal+0x51) [0xa794d1]
/lib/tls/i686/cmov/libc.so.6(abort+0x182) [0xa7c932]
/lib/libglib-2.0.so.0(g_assertion_message+0x13c) [0x170ddc]
/lib/libglib-2.0.so.0 [0x17143d]
/usr/bin/mono(mono_metadata_decode_row+0x106) [0x8175d06]
/usr/bin/mono(mono_type_create_from_typespec+0x73) [0x817a4e3]
/usr/bin/mono [0x81985b6]
/usr/bin/mono(mono_class_get_full+0x160) [0x81987f0]
/usr/bin/mono(mono_class_get+0x20) [0x8198840]
/usr/bin/mono [0x817a19e]
/usr/bin/mono(mono_metadata_parse_type_full+0xe6) [0x8179446]
/usr/bin/mono [0x8197bcc]
/usr/bin/mono(mono_class_init+0x744) [0x8194ba4]
/usr/bin/mono(mono_class_vtable+0xc5) [0x8110445]
/usr/bin/mono(mono_object_new+0x18) [0x8113938]
/usr/bin/mono(mono_thread_attach+0x67) [0x8151077]
/usr/bin/mono(mono_runtime_init+0x140) [0x815bfe0]
/usr/bin/mono [0x805d041]
/usr/bin/mono(mono_main+0x285) [0x80b0195]
/usr/bin/mono [0x805aba5]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0xa65b56]
/usr/bin/mono [0x805aae1]

Debug info from gdb:

[Thread debugging using libthread_db enabled]
[New Thread 0x24cb70 (LWP 2810)]
0x0030d422 in __kernel_vsyscall ()
2 Thread 0x24cb70 (LWP 2810) 0x0030d422 in __kernel_vsyscall ()
* 1 Thread 0x8fa9e0 (LWP 2807) 0x0030d422 in __kernel_vsyscall ()

Thread 2 (Thread 0x24cb70 (LWP 2810)):
#0 0x0030d422 in __kernel_vsyscall ()
#1 0x006f4466 in nanosleep () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x081a3658 in ?? ()
#3 0x006ec80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#4 0x00b1b7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0x8fa9e0 (LWP 2807)):
#0 0x0030d422 in __kernel_vsyscall ()
#1 0x006f3c8b in read () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x080c89be in ?? ()
#3 <signal handler called>
#4 0x0030d422 in __kernel_vsyscall ()
#5 0x00a794d1 in raise () from /lib/tls/i686/cmov/libc.so.6
#6 0x00a7c932 in abort () from /lib/tls/i686/cmov/libc.so.6
#7 0x00170ddc in g_assertion_message () from /lib/libglib-2.0.so.0
#8 0x0017143d in g_assertion_message_expr () from /lib/libglib-2.0.so.0
#9 0x08175d06 in mono_metadata_decode_row ()
#10 0x0817a4e3 in mono_type_create_from_typespec ()
#11 0x081985b6 in ?? ()
#12 0x081987f0 in mono_class_get_full ()
#13 0x08198840 in mono_class_get ()
#14 0x0817a19e in ?? ()
#15 0x08179446 in mono_metadata_parse_type_full ()
#16 0x08197bcc in ?? ()
#17 0x08194ba4 in mono_class_init ()
#18 0x08110445 in mono_class_vtable ()
#19 0x08113938 in mono_object_new ()
#20 0x08151077 in mono_thread_attach ()
#21 0x0815bfe0 in mono_runtime_init ()
#22 0x0805d041 in ?? ()
#23 0x080b0195 in mono_main ()
#24 0x0805aba5 in ?? ()
#25 0x00a65b56 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#26 0x0805aae1 in ?? ()

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted (core dumped)
E: installing Assembly /usr/lib/cli/ndesk-dbus-glib-1.0/NDesk.DBus.GLib.dll failed
E: Installation of libndesk-dbus-glib1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
* Installing 1 assembly from policy.2.1.FlickrNet into Mono
**
ERROR:metadata.c:1003:mono_metadata_decode_row: assertion failed: (idx < t->rows)

** (/usr/share/mono/MonoGetAssemblyName.exe:2821): WARNING **: Thread (nil) may have been prematurely finalized
Stacktrace:


** (/usr/share/mono/MonoGetAssemblyName.exe:2821): WARNING **: Thread (nil) may have been prematurely finalized

** (/usr/share/mono/MonoGetAssemblyName.exe:2821): WARNING **: Thread (nil) may have been prematurely finalized

Native stacktrace:

/usr/bin/mono [0x80c8824]
[0x15a410]
[0x15a422]
/lib/tls/i686/cmov/libc.so.6(gsignal+0x51) [0x5ca4d1]
/lib/tls/i686/cmov/libc.so.6(abort+0x182) [0x5cd932]
/lib/libglib-2.0.so.0(g_assertion_message+0x13c) [0x1baddc]
/lib/libglib-2.0.so.0 [0x1bb43d]
/usr/bin/mono(mono_metadata_decode_row+0x106) [0x8175d06]
/usr/bin/mono(mono_type_create_from_typespec+0x73) [0x817a4e3]
/usr/bin/mono [0x81985b6]
/usr/bin/mono(mono_class_get_full+0x160) [0x81987f0]
/usr/bin/mono(mono_class_get+0x20) [0x8198840]
/usr/bin/mono [0x817a19e]
/usr/bin/mono(mono_metadata_parse_type_full+0xe6) [0x8179446]
/usr/bin/mono [0x8197bcc]
/usr/bin/mono(mono_class_init+0x744) [0x8194ba4]
/usr/bin/mono(mono_class_vtable+0xc5) [0x8110445]
/usr/bin/mono(mono_object_new+0x18) [0x8113938]
/usr/bin/mono(mono_thread_attach+0x67) [0x8151077]
/usr/bin/mono(mono_runtime_init+0x140) [0x815bfe0]
/usr/bin/mono [0x805d041]
/usr/bin/mono(mono_main+0x285) [0x80b0195]
/usr/bin/mono [0x805aba5]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x5b6b56]
/usr/bin/mono [0x805aae1]

Debug info from gdb:

[Thread debugging using libthread_db enabled]
[New Thread 0xea3b70 (LWP 2822)]
0x0015a422 in __kernel_vsyscall ()
2 Thread 0xea3b70 (LWP 2822) 0x0015a422 in __kernel_vsyscall ()
* 1 Thread 0x4859e0 (LWP 2821) 0x0015a422 in __kernel_vsyscall ()

Thread 2 (Thread 0xea3b70 (LWP 2822)):
#0 0x0015a422 in __kernel_vsyscall ()
#1 0x00458466 in nanosleep () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x081a3658 in ?? ()
#3 0x0045080e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#4 0x0066c7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0x4859e0 (LWP 2821)):
#0 0x0015a422 in __kernel_vsyscall ()
#1 0x00457c8b in read () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x080c89be in ?? ()
#3 <signal handler called>
#4 0x0015a422 in __kernel_vsyscall ()
#5 0x005ca4d1 in raise () from /lib/tls/i686/cmov/libc.so.6
#6 0x005cd932 in abort () from /lib/tls/i686/cmov/libc.so.6
#7 0x001baddc in g_assertion_message () from /lib/libglib-2.0.so.0
#8 0x001bb43d in g_assertion_message_expr () from /lib/libglib-2.0.so.0
#9 0x08175d06 in mono_metadata_decode_row ()
#10 0x0817a4e3 in mono_type_create_from_typespec ()
#11 0x081985b6 in ?? ()
#12 0x081987f0 in mono_class_get_full ()
#13 0x08198840 in mono_class_get ()
#14 0x0817a19e in ?? ()
#15 0x08179446 in mono_metadata_parse_type_full ()
#16 0x08197bcc in ?? ()
#17 0x08194ba4 in mono_class_init ()
#18 0x08110445 in mono_class_vtable ()
#19 0x08113938 in mono_object_new ()
#20 0x08151077 in mono_thread_attach ()
#21 0x0815bfe0 in mono_runtime_init ()
#22 0x0805d041 in ?? ()
#23 0x080b0195 in mono_main ()
#24 0x0805aba5 in ?? ()
#25 0x005b6b56 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#26 0x0805aae1 in ?? ()

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted (core dumped)
Use of uninitialized value $_ in scalar chomp at /usr/share/cli-common/runtimes.d/mono line 144.
Use of uninitialized value $fullname in concatenation (.) or string at /usr/share/cli-common/runtimes.d/mono line 113.
**
ERROR:metadata.c:1003:mono_metadata_decode_row: assertion failed: (idx < t->rows)

** (/usr/lib/mono/2.0/gacutil.exe:2829): WARNING **: Thread (nil) may have been prematurely finalized
Stacktrace:


** (/usr/lib/mono/2.0/gacutil.exe:2829): WARNING **: Thread (nil) may have been prematurely finalized

** (/usr/lib/mono/2.0/gacutil.exe:2829): WARNING **: Thread (nil) may have been prematurely finalized

Native stacktrace:

/usr/bin/mono [0x80c8824]
[0xa3c410]
[0xa3c422]
/lib/tls/i686/cmov/libc.so.6(gsignal+0x51) [0x1f54d1]
/lib/tls/i686/cmov/libc.so.6(abort+0x182) [0x1f8932]
/lib/libglib-2.0.so.0(g_assertion_message+0x13c) [0xad7ddc]
/lib/libglib-2.0.so.0 [0xad843d]
/usr/bin/mono(mono_metadata_decode_row+0x106) [0x8175d06]
/usr/bin/mono(mono_type_create_from_typespec+0x73) [0x817a4e3]
/usr/bin/mono [0x81985b6]
/usr/bin/mono(mono_class_get_full+0x160) [0x81987f0]
/usr/bin/mono(mono_class_get+0x20) [0x8198840]
/usr/bin/mono [0x817a19e]
/usr/bin/mono(mono_metadata_parse_type_full+0xe6) [0x8179446]
/usr/bin/mono [0x8197bcc]
/usr/bin/mono(mono_class_init+0x744) [0x8194ba4]
/usr/bin/mono(mono_class_vtable+0xc5) [0x8110445]
/usr/bin/mono(mono_object_new+0x18) [0x8113938]
/usr/bin/mono(mono_thread_attach+0x67) [0x8151077]
/usr/bin/mono(mono_runtime_init+0x140) [0x815bfe0]
/usr/bin/mono [0x805d041]
/usr/bin/mono(mono_main+0x285) [0x80b0195]
/usr/bin/mono [0x805aba5]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x1e1b56]
/usr/bin/mono [0x805aae1]

Debug info from gdb:

[Thread debugging using libthread_db enabled]
[New Thread 0x4beb70 (LWP 2832)]
0x00a3c422 in __kernel_vsyscall ()
2 Thread 0x4beb70 (LWP 2832) 0x00a3c422 in __kernel_vsyscall ()
* 1 Thread 0x9d39e0 (LWP 2829) 0x00a3c422 in __kernel_vsyscall ()

Thread 2 (Thread 0x4beb70 (LWP 2832)):
#0 0x00a3c422 in __kernel_vsyscall ()
#1 0x00fdd466 in nanosleep () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x081a3658 in ?? ()
#3 0x00fd580e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#4 0x002977ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0x9d39e0 (LWP 2829)):
#0 0x00a3c422 in __kernel_vsyscall ()
#1 0x00fdcc8b in read () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x080c89be in ?? ()
#3 <signal handler called>
#4 0x00a3c422 in __kernel_vsyscall ()
#5 0x001f54d1 in raise () from /lib/tls/i686/cmov/libc.so.6
#6 0x001f8932 in abort () from /lib/tls/i686/cmov/libc.so.6
#7 0x00ad7ddc in g_assertion_message () from /lib/libglib-2.0.so.0
#8 0x00ad843d in g_assertion_message_expr () from /lib/libglib-2.0.so.0
#9 0x08175d06 in mono_metadata_decode_row ()
#10 0x0817a4e3 in mono_type_create_from_typespec ()
#11 0x081985b6 in ?? ()
#12 0x081987f0 in mono_class_get_full ()
#13 0x08198840 in mono_class_get ()
#14 0x0817a19e in ?? ()
#15 0x08179446 in mono_metadata_parse_type_full ()
#16 0x08197bcc in ?? ()
#17 0x08194ba4 in mono_class_init ()
#18 0x08110445 in mono_class_vtable ()
#19 0x08113938 in mono_object_new ()
#20 0x08151077 in mono_thread_attach ()
#21 0x0815bfe0 in mono_runtime_init ()
#22 0x0805d041 in ?? ()
#23 0x080b0195 in mono_main ()
#24 0x0805aba5 in ?? ()
#25 0x001e1b56 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#26 0x0805aae1 in ?? ()

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Aborted (core dumped)
E: installing Assembly /usr/share/cli-common/policies.d/libflickrnet2.1.5-cil/policy.2.1.FlickrNet.dll failed
E: Installation of policy.2.1.FlickrNet with /usr/share/cli-common/runtimes.d/mono failed
dpkg:处理 mono-gac (--configure)时出错:
子进程 已安装的 post-installation 脚本 返回了错误号 9
dpkg:依赖关系问题使得 mono-runtime 的配置工作不能继续:
mono-runtime 依赖于 mono-gac (= 2.4.2.3+dfsg-2);然而:
软件包 mono-gac 还没有被配置。
dpkg:处理 mono-runtime (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono2.0-cil 的配置工作不能继续:
libmono2.0-cil 依赖于 mono-runtime (>= 1.1.8.1);然而:
软件包 mono-runtime 还没有被配置。
dpkg:处理 libmono2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-posix2.0-cil 的配置工作不能继续:
libmono-posix2.0-cil 依赖于 mono-runtime (>= 2.4);然而:
软件包 mono-runtime 还没有被配置。
dpkg:处理 libmono-posix2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libndesk-dbus1.0-cil 的配置工作不能继续:
libndesk-dbus1.0-cil 依赖于 libmono-posix2.0-cil (>= 2.4);然而:
软件包 libmono-posix2.0-cil 还没有被配置。
dpkg:处理 libndesk-dbus1.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libgconf2.0-cil 的配置工作不能继续:
libgconf2.0-cil 依赖于 mono-runtime (>= 1.1.8.1);然而:
软件包 mono-runtime 还没有被配置。
dpkg:处理 libgconf2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-addins-gui0.2-cil 的配置工作不能继续:
libmono-addins-gui0.2-cil 依赖于 libmono-posix2.0-cil (>= 2.4);然而:
软件包 libmono-posix2.0-cil 还没有被配置。
dpkg:处理 libmono-addins-gui0.2-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libgnome-keyring1.0-cil 的配置工作不能继续:
libgnome-keyring1.0-cil 依赖于 libmono-posix2.0-cil (>= 1.0);然而:
软件包 libmono-posix2.0-cil 还没有被配置。
libgnome-keyring1.0-cil 依赖于 libndesk-dbus1.0-cil (>= 0.6.0);然而:
软件包 libndesk-dbus1.0-cil 还没有被配置。
dpkg:处理 libgnome-keyring1.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libndesk-dbus-glib1.0-cil 的配置工作不能继续:
libndesk-dbus-glib1.0-cil 依赖于 libndesk-dbus1.0-cil (>= 0.6.0);然而:
软件包 libndesk-dbus1.0-cil 还没有被配置。
dpkg:处理 libndesk-dbus-glib1.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-addins0.2-cil 的配置工作不能继续:
libmono-addins0.2-cil 依赖于 mono-runtime (>= 1.1.8.1);然而:
软件包 mono-runtime 还没有被配置。
dpkg:处理 libmono-addins0.2-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 tomboy 的配置工作不能继续:
tomboy 依赖于 mono-runtime (>= 1.1.8.1);然而:
软件包 mono-runtime 还没有被配置。
tomboy 依赖于 libgconf2.0-cil (>= 2.24.0);然而:
软件包 libgconf2.0-cil 还没有被配置。
tomboy 依赖于 libmono-addins-gui0.2-cil (>= 0.4);然而:
软件包 libmono-addins-gui0.2-cil 还没有被配置。
tomboy 依赖于 libmono-addins0.2-cil (>= 0.4);然而:
软件包 libmono-addins0.2-cil 还没有被配置。
tomboy 依赖于 libmono-posix2.0-cil (>= 2.4);然而:
软件包 libmono-posix2.0-cil 还没有被配置。
tomboy 依赖于 libndesk-dbus-glib1.0-cil (>= 0.4.0);然而:
软件包 libndesk-dbus-glib1.0-cil 还没有被配置。
tomboy 依赖于 libndesk-dbus1.0-cil (>= 0.6.0);然而:
软件包 libndesk-dbus1.0-cil 还没有被配置。
dpkg:处理 tomboy (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libgnome2.24-cil 的配置工作不能继续:
libgnome2.24-cil 依赖于 libgconf2.0-cil (>= 2.24.0);然而:
软件包 libgconf2.0-cil 还没有被配置。
dpkg:处理 libgnome2.24-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-system-web2.0-cil 的配置工作不能继续:
libmono-system-web2.0-cil 依赖于 libmono2.0-cil (>= 2.0);然而:
软件包 libmono2.0-cil 还没有被配置。
libmono-system-web2.0-cil 依赖于 mono-runtime (>= 2.4.2.3);然而:
软件包 mono-runtime 还没有被配置。
libmono-system-web2.0-cil 依赖于 mono-runtime (<< 2.4.2.4);然而:
软件包 mono-runtime 还没有被配置。
dpkg:处理 libmono-system-web2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 f-spot 的配置工作不能继续:
f-spot 依赖于 mono-runtime (>= 1.1.8.1);然而:
软件包 mono-runtime 还没有被配置。
f-spot 依赖于 libgconf2.0-cil (>= 2.24.0);然而:
软件包 libgconf2.0-cil 还没有被配置。
f-spot 依赖于 libgnome-keyring1.0-cil (>= 1.0.0);然而:
软件包 libgnome-keyring1.0-cil 还没有被配置。
f-spot 依赖于 libgnome2.24-cil (>= 2.24.0);然而:
软件包 libgnome2.24-cil 还没有被配置。
f-spot 依赖于 libmono-addins-gui0.2-cil (>= 0.4);然而:
软件包 libmono-addins-gui0.2-cil 还没有被配置。
f-spot 依赖于 libmono-addins0.2-cil (>= 0.4);然而:
软件包 libmono-addins0.2-cil 还没有被配置。
f-spot 依赖于 libmono-posix2.0-cil (>= 2.4);然而:
软件包 libmono-posix2.0-cil 还没有被配置。
f-spot 依赖于 libmono-system-web2.0-cil (>= 1.9.1);然而:
软件包 libmono-system-web2.0-cil 还没有被配置。
f-spot 依赖于 libndesk-dbus-glib1.0-cil (>= 0.4.0);然而:
软件包 libndesk-dbus-glib1.0-cil 还没有被配置。
f-spot 依赖于 libndesk-dbus1.0-cil (>= 0.6.0);然而:
软件包 libndesk-dbus1.0-cil 还没有被配置。
dpkg:处理 f-spot (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-system2.0-cil 的配置工作不能继续:
libmono-system2.0-cil 依赖于 mono-runtime (>= 2.4.2.3);然而:
软件包 mono-runtime 还没有被配置。
libmono-system2.0-cil 依赖于 mono-runtime (<< 2.4.2.4);然而:
软件包 mono-runtime 还没有被配置。
dpkg:处理 libmono-system2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-sqlite2.0-cil 的配置工作不能继续:
libmono-sqlite2.0-cil 依赖于 libmono-system2.0-cil (>= 2.4);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libmono-sqlite2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-data2.0-cil 的配置工作不能继续:
libmono-data2.0-cil 依赖于 libmono-system2.0-cil (>= 2.4);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libmono-data2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-system-data2.0-cil 的配置工作不能继续:
libmono-system-data2.0-cil 依赖于 libmono-system2.0-cil (>= 2.4);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libmono-system-data2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libgtk2.0-cil 的配置工作不能继续:
libgtk2.0-cil 依赖于 libmono-system2.0-cil (>= 2.0);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libgtk2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libgnomepanel2.24-cil 的配置工作不能继续:
libgnomepanel2.24-cil 依赖于 libgnome2.24-cil (>= 2.24.0);然而:
软件包 libgnome2.24-cil 还没有被配置。
libgnomepanel2.24-cil 依赖于 libgtk2.0-cil (>= 2.12.9);然而:
软件包 libgtk2.0-cil 还没有被配置。
dpkg:处理 libgnomepanel2.24-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-data-tds2.0-cil 的配置工作不能继续:
libmono-data-tds2.0-cil 依赖于 libmono-system2.0-cil (>= 2.4);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libmono-data-tds2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libflickrnet2.2-cil 的配置工作不能继续:
libflickrnet2.2-cil 依赖于 libmono-system-web2.0-cil (>= 1.9.1);然而:
软件包 libmono-system-web2.0-cil 还没有被配置。
libflickrnet2.2-cil 依赖于 libmono-system2.0-cil (>= 2.4);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libflickrnet2.2-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-getoptions2.0-cil 的配置工作不能继续:
libmono-getoptions2.0-cil 依赖于 libmono-system2.0-cil (>= 2.4);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libmono-getoptions2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libglade2.0-cil 的配置工作不能继续:
libglade2.0-cil 依赖于 libgtk2.0-cil (>= 2.12.9);然而:
软件包 libgtk2.0-cil 还没有被配置。
dpkg:处理 libglade2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libglib2.0-cil 的配置工作不能继续:
libglib2.0-cil 依赖于 libmono-system2.0-cil (>= 2.0);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libglib2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libmono-sharpzip2.84-cil 的配置工作不能继续:
libmono-sharpzip2.84-cil 依赖于 libmono-system2.0-cil (>= 2.4);然而:
软件包 libmono-system2.0-cil 还没有被配置。
dpkg:处理 libmono-sharpzip2.84-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libart2.0-cil 的配置工作不能继续:
libart2.0-cil 依赖于 libglib2.0-cil (>= 2.12.7);然而:
软件包 libglib2.0-cil 还没有被配置。
dpkg:处理 libart2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libgmime2.2a-cil 的配置工作不能继续:
libgmime2.2a-cil 依赖于 libglib2.0-cil (>= 2.12.7);然而:
软件包 libglib2.0-cil 还没有被配置。
dpkg:处理 libgmime2.2a-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libgnome-vfs2.0-cil 的配置工作不能继续:
libgnome-vfs2.0-cil 依赖于 libglib2.0-cil (>= 2.12.7);然而:
软件包 libglib2.0-cil 还没有被配置。
dpkg:处理 libgnome-vfs2.0-cil (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
mono-gac
mono-runtime
libmono2.0-cil
libmono-posix2.0-cil
libndesk-dbus1.0-cil
libgconf2.0-cil
libmono-addins-gui0.2-cil
libgnome-keyring1.0-cil
libndesk-dbus-glib1.0-cil
libmono-addins0.2-cil
tomboy
libgnome2.24-cil
libmono-system-web2.0-cil
f-spot
libmono-system2.0-cil
libmono-sqlite2.0-cil
libmono-data2.0-cil
libmono-system-data2.0-cil
libgtk2.0-cil
libgnomepanel2.24-cil
libmono-data-tds2.0-cil
libflickrnet2.2-cil
libmono-getoptions2.0-cil
libglade2.0-cil
libglib2.0-cil
libmono-sharpzip2.84-cil
libart2.0-cil
libgmime2.2a-cil
libgnome-vfs2.0-cil
xhxiang@ubt:~$


请问怎么解决?
还要mplayer播放rmvb时会有个错误提示框...但可以正常播放视频和声音...
其他问题还在测试中....


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 9.04升级到9.10 不完整,系统有问题...寻求解决
帖子发表于 : 2009-10-31 12:02 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
问题未解决,谁能帮忙??


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 9.04升级到9.10 不完整,系统有问题...寻求解决
帖子发表于 : 2009-10-31 12:06 
头像

注册: 2009-09-10 9:28
帖子: 30
送出感谢: 0 次
接收感谢: 0 次
关于没有声音的问题,我以前也遇到过,
我是这样解决问题的:
系统-》系统管理-》硬件驱动-》找到调制解调器,然后移除,
重启就好了,
原因不明~~~希望对大家有帮助 :em06


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 9.04升级到9.10 不完整,系统有问题...寻求解决
帖子发表于 : 2009-10-31 23:44 

注册: 2008-05-18 22:49
帖子: 70
送出感谢: 0 次
接收感谢: 0 次
mono的问题已经找到解决办法了,
在新立得管理器里面
将mono-gac,mono-runtime彻底卸载掉,然后重新安装,就没有问题了.

但是还遗留其他一些小问题:
firefox的图标全部没有了,包括桌面图标,主菜单里面的图标,和ff菜单的图标全部没有.但不影响使用,
还有ff几乎每次关闭都提示崩溃报告....
还有mplayer播放rmvb还提示一个错误.Error: Could not open required directshow codec drvc.bundle/contents/macos/drvc.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译