当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 升级求助,彻底崩溃。请高手看下
帖子发表于 : 2009-11-01 13:47 

注册: 2008-11-26 22:09
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
8.10升级到9,04然后安装不了软件包 总是提示有新立德在工作需要停止 然后提示在终端输入 sudo dpkg --congfiure -a 来解决问题 输入后
x@x-laptop:~$ sudo dpkg --configure initramfs-tools
正在设置 initramfs-tools (0.92bubuntu29) ...
update-initramfs: deferring update (trigger activated)

正在处理用于 initramfs-tools 的触发器...
update-initramfs: Generating /boot/initrd.img-2.6.27-14-generic
Cannot find /lib/modules/2.6.27-14-generic
update-initramfs: failed for /boot/initrd.img-2.6.27-14-generic
dpkg: 子进程 post-installation script 返回了错误号 1

然后用sudo dpkg --audit
x@x-laptop:~$ sudo dpkg --audit
下列软件包只是被不全面的配置了,这也许要归咎于
第一次配置它们时出的问题。您最好能重新配置它们。
借助 dpkg --configure <软件包名> 或者用 dselect
菜单中的 configure 选项就能重新配置软件包:
initramfs-tools tools for generating an initramfs

最后实在是没有办法了 用 sudo dpkg --remove -a 然后才可以安装软件包,也就是说现在每次安装软件包都要必须先执行这样一个命令
请问高手该怎么办?是不是内核的原因?

谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级求助,彻底崩溃。请高手看下
帖子发表于 : 2009-11-01 15:41 

注册: 2008-11-26 22:09
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
解决了

可以使用sudo dpkg --configure -a

看到底是那个包的问题

然后dpkg --configure [some random package] 这个包就是你有问题的包

然后需要做一个 mkdir

然后dpkg --configure -****(有问题的包)

最后sudo dpkg --configure -a


详细情况看http://ubuntuforums.org/showthread.php?t=1147434&page=2

第19楼


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译