当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-01 17:02 

注册: 2009-11-01 16:07
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
下载文件为:antivir_workstation-pers.tar.gz
版本:antivir-workstation-pers-3.0.5-11

sudo ./install
提示:It is not possible to install AVIRA AntiVir Workstation (UNIX), because your system platform is not supported.

:em20


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-01 17:26 

注册: 2007-08-02 20:29
帖子: 21288
系统: 窓辺とうこ
送出感谢: 0 次
接收感谢: 22
装那干嘛,又不会中毒


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-04 21:32 
头像

注册: 2009-05-31 20:52
帖子: 389
送出感谢: 0 次
接收感谢: 1
你看过这2篇文章吗?http://www.5dlinux.com/article/1/2008/linux_12552.html

http://www.chineselinuxuniversity.net/a ... /320.shtml
还有avira readme里面的内容:
AntiVir Workstation Install-Package Directory


install <- install script
LICENSE <- Avira GmbH Software License Agreement

doc/ <- documentation (handbook, manual, changelog)
bin/ <- executable files
vdf/ <- virus definition files
legal/ <- 3rd-party licenses
contrib/ <- 3rd-party software (dazuko, gnome-applet)

etc/ <- configuration files
script/ <- shell scripts
smcpkg/ <- SMC-specific files

所以现在有一个选择,你需要GUI那么你必须采取下文的设置使ubuntu在一段时间内成为英文环境,同时你要有jre。你需要AvGurad这个守护进程,那么你必须安装gcc-4.4、基本编译工具、debhelper、Module-Assistant以及最重要的dazuko。

我发现dazuko的版本目前是3.1.1可是我安装会有问题。


_________________
The root of bioengineering is the desire to control the organic long enough to improve it. Domesticated plants and animals are examples of technos -- logic applied to life.


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-04 21:37 
头像

注册: 2007-05-06 8:19
帖子: 7433
送出感谢: 0 次
接收感谢: 4
JiangHui 写道:
装那干嘛,又不会中毒

说话又不负责~~~ :em06


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-04 21:37 
头像

注册: 2009-05-31 20:52
帖子: 389
送出感谢: 0 次
接收感谢: 1
yus253@ubuntu:~/dazukofs-3.1.1$
yus253@ubuntu:~/dazukofs-3.1.1$ make
make -C /lib/modules/`uname -r`/build SUBDIRS="`pwd`" modules
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.31-14-generic'
Building modules, stage 2.
MODPOST 1 modules
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.31-14-generic'
yus253@ubuntu:~/dazukofs-3.1.1$ make dazukofs_install
make -C /lib/modules/`uname -r`/build SUBDIRS="`pwd`" modules
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.31-14-generic'
Building modules, stage 2.
MODPOST 1 modules
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.31-14-generic'
mkdir -p /lib/modules/`uname -r`/kernel/fs/dazukofs
cp dazukofs.ko /lib/modules/`uname -r`/kernel/fs/dazukofs
cp: 无法创建普通文件“/lib/modules/2.6.31-14-generic/kernel/fs/dazukofs/dazukofs.ko”: Permission denied
make: *** [dazukofs_install] 错误 1
yus253@ubuntu:~/dazukofs-3.1.1$


_________________
The root of bioengineering is the desire to control the organic long enough to improve it. Domesticated plants and animals are examples of technos -- logic applied to life.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-04 21:39 
头像

注册: 2009-05-31 20:52
帖子: 389
送出感谢: 0 次
接收感谢: 1
ABOUT DAZUKOFS
================

DazukoFS is a stackable filesystem to allow userspace applications to
perform online file access control. It was originally developed to
support online virus scanners, but could be useful for any application
that wishes to perform online file access control.

NOTE: DazukoFS is completely separate from Dazuko. DazukoFS uses a
different interface and different devices than Dazuko. It is
possible to use Dazuko and DazukoFS at the same time since
they do not share any code or resources. However, DazukoFS
is meant to replace Dazuko as an online file access control
solution.



=================
BUILD / INSTALL
=================

Below are brief instructions to get DazukoFS compiled and running on a
system with a Linux 2.6.31 kernel. You may need to manually adjust the
Makefile if you kernel sources are not in the default location.
(Patches are provided for various other kernels. See the section below
titled "PATCHING" for more information.)

compile the kernel module
# make

install the kernel module
# make dazukofs_install

load the kernel module
# modprobe dazukofs

verify that the module is loaded
# dmesg | grep dazukofs

create a playground to test DazukoFS
# mkdir /tmp/dazukofs_test

mount DazukoFS over the playground
# mount -t dazukofs /tmp/dazukofs_test /tmp/dazukofs_test

verify that DazukoFS is mounted
# mount | grep dazukofs

unmount DazukoFS
# umount /tmp/dazukofs_test



==========
PATCHING
==========

In the "patches" directory there are patches available to modify the
DazukoFS code to fit various other kernels. For example, if you are
running openSUSE 11.1 you can patch the code with the following
command:

$ patch -p1 < patches/patch-opensuse-11.1

There should not be any errors. If there are errors, then the patch
is broken and should be reported on the dazuko-devel mailing list.

Once the code has been patched you can build the kernel module as
described in the section "BUILD / INSTALL" above.

这个是dazukofs 的部分
README


_________________
The root of bioengineering is the desire to control the organic long enough to improve it. Domesticated plants and animals are examples of technos -- logic applied to life.


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-04 21:43 
头像

注册: 2009-05-31 20:52
帖子: 389
送出感谢: 0 次
接收感谢: 1
yus253@ubuntu:~/dazukofs-3.1.1$ modprobe dazukofs
WARNING: All config files need .conf: /etc/modprobe.d/dazuko, it will be ignored in a future release.
FATAL: Error inserting dazukofs (/lib/modules/2.6.31-14-generic/kernel/fs/dazukofs/dazukofs.ko): Operation not permitted
yus253@ubuntu:~/dazukofs-3.1.1$

到第三个就肯定错误了,所有我哪里没安装好,还是之前安装那个2.3.4有残余造成的?那个怎么删除呢?


_________________
The root of bioengineering is the desire to control the organic long enough to improve it. Domesticated plants and animals are examples of technos -- logic applied to life.


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-04 22:46 
头像

注册: 2009-05-31 20:52
帖子: 389
送出感谢: 0 次
接收感谢: 1
终于明白为什么avira for linux不能安装了。打开你下载的../ariva/antivir-workstation-pers-3.0.5-11/contrib/dazuko,你可以找到这个文件 supported_distros中文翻译过来叫做支持版本:
dazukofs-3.0.0-rc4_2.6.16_SLES10SP1:
SLES10 SP 1 with kernel 2.6.16
vanilla kernel 2.6.16

dazukofs-3.0.0-rc4_2.6.16_SLES10SP2:
SLES10 SP2 with kernel 2.6.16

dazukofs-3.0.0-rc4_2.6.18:
Debian 4 (etch)
vanilla kernel 2.6.18

dazukofs-3.0.0-rc4_2.6.20:
Redhat 5.x with kernel 2.6.18.x
vanilla kernel 2.6.20

dazukofs-3.0.0-rc4_2.6.22:
vanilla kernel 2.6.22

dazukofs-3.0.0-rc4_2.6.22_Ubuntu7.10:
Ubuntu 7.10 with kernel 2.6.22

dazukofs-3.0.0-rc4_2.6.24:
vanilla kernel 2.6.24

dazukofs-3.0.0-rc4_2.6.25:
vanilla kernel 2.6.25

dazukofs-3.0.0-rc4_2.6.26:
Debian 5 (lenny)
vanilla kernel 2.6.26

dazukofs-3.0.0-rc4_2.6.27:
vanilla kernel 2.6.27

dazukofs-3.0.0-rc4_2.6.27_ub_os11.1:
Ubuntu 8.10
OpenSuse 11.1
Ubuntu 9.04
SLES11 with kernel 2.6.27.19

最后,我们清除的看到了UBUNTU 9.04而我的第2张图也告诉你了这个文件夹里有哪些包;我的思路是正确的安装上dazukofs-3.1.1---这东西支持2.6.31,但还是没研究透如何连接上。我们只有等待AVIRA对起UNIX支持版本的更新了。


附件:
Screenshot-1.png
Screenshot-1.png [ 224.48 KiB | 被浏览 848 次 ]

Screenshot.png
Screenshot.png [ 140.69 KiB | 被浏览 848 次 ]



_________________
The root of bioengineering is the desire to control the organic long enough to improve it. Domesticated plants and animals are examples of technos -- logic applied to life.
页首
 用户资料  
 
9 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-04 22:47 
头像

注册: 2009-05-31 20:52
帖子: 389
送出感谢: 0 次
接收感谢: 1
此问题已经被我解决了!!!!


_________________
The root of bioengineering is the desire to control the organic long enough to improve it. Domesticated plants and animals are examples of technos -- logic applied to life.


页首
 用户资料  
 
10 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-04 22:48 
头像

注册: 2009-05-31 20:52
帖子: 389
送出感谢: 0 次
接收感谢: 1
此问题已经被我解决了!!!!


_________________
The root of bioengineering is the desire to control the organic long enough to improve it. Domesticated plants and animals are examples of technos -- logic applied to life.


页首
 用户资料  
 
11 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-05 9:40 
头像

注册: 2008-06-30 22:32
帖子: 2869
送出感谢: 0 次
接收感谢: 10
yus253 写道:
此问题已经被我解决了!!!!

LZ也写个教程噻~


页首
 用户资料  
 
12 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-05 9:45 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
windows下装antivir,linux下裸奔


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
13 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-05 9:45 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
好的上网习惯可以代替防火墙


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
14 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-05 9:51 
头像

注册: 2005-08-22 14:05
帖子: 1743
地址: 离开北京
送出感谢: 1
接收感谢: 3
冲浪板 写道:
JiangHui 写道:
装那干嘛,又不会中毒

说话又不负责~~~ :em06

windows 都不装杀毒软件,何况linux。
win下只要打满补丁+操作的当(u盘那些),不要乱下不明来历的软件。基本不会中毒。
linux apt的软件都是gpg校验过的绝对安全。
下的tar gz都是自己编译。根本不可能中毒。
如果那天来了 操作系统0day漏洞攻击病毒。那装了杀毒软件也没用。

所以。目前的linux杀毒软件就是没用的东东


_________________
错过好多好贴,没占到广告位后悔啊


页首
 用户资料  
 
15 楼 
 文章标题 : Re: ubuntu 9.10安转红伞,提示平台不支持
帖子发表于 : 2009-11-05 10:02 

注册: 2007-08-02 20:29
帖子: 21288
系统: 窓辺とうこ
送出感谢: 0 次
接收感谢: 22
冲浪板 写道:
JiangHui 写道:
装那干嘛,又不会中毒

说话又不负责~~~ :em06



有本事你去中一个给我看看


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译