当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 诡异的9.10安装问题
帖子发表于 : 2009-11-08 23:51 
头像

注册: 2007-05-14 16:17
帖子: 89
地址: http://www.sglab.cn
送出感谢: 0 次
接收感谢: 0 次
本人raid0上装有 win7 以及 XP,通过easyBCD(基于grub4dos 0.4.4)实现完美双启动。

现在想安装9.10实现三启动。

通过之前的潜心研究,发现由于是在raid0上安装,所以无法直接装上grub(不知道为什么,可能跟dmraid有冲突?),遂决定直接用easyBCD来实现,这样整个启动过程也是最简化的。

于是在easyBCD中,增加了9.10的进入项,同时对应部分的menu.lst书写如下:
default 0
timeout 3
title Ubuntu9.10
root (hd0,5)
kernel (hd0,5)/boot/vmlinuz-2.6.31-14-generic root=/dev/mapper/nvidia_biabiaca6 ro quiet splash
initrd (hd0,5)/boot/initrd.img-2.6.31-14-generic

由于之前做过多次摸索(在grub命令行下,在liveCD下,以及命令行进入所装系统下,如上盘符相关的数据应该没有错误),但是选择linux启动项后,系统成功进入 grub4dos界面,然后开始启动9.10,屏幕出现如下信息:
booting command-list
Filesystem type is ext2fs, partition type 0x83
之后就没反应了,所谓无反应是 所有键盘无效 系统不读硬盘 屏幕无任何变化,唯一能进行的操作是按电源 关机……

请高手们帮忙看看这是咋回事啊~~~


_________________
SGlab在中国的推广离不开开源……
http://www.sglab.cn


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-08 23:55 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
raid

搜fakeraid,wiki有叙述

比较麻烦


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-09 0:08 
头像

注册: 2008-03-25 15:49
帖子: 25876
地址: 谁知道?
送出感谢: 8
接收感谢: 10
2# 说麻烦 肯定麻烦 :em06


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-09 10:51 
头像

注册: 2007-05-14 16:17
帖子: 89
地址: http://www.sglab.cn
送出感谢: 0 次
接收感谢: 0 次
按照楼上兄弟的说法 查阅了 grub4dos应用fakeraid的网上案例,但是没发现什么问题?

我觉得不是raid的事情,因为grub能够引导内核,只是接下来没动作了……

是不是9.10只能通过grub2.0引导?


_________________
SGlab在中国的推广离不开开源……
http://www.sglab.cn


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-09 10:55 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
引用:
由于之前做过多次摸索(在grub命令行下,在liveCD下,以及命令行进入所装系统下,如上盘符相关的数据应该没有错误),但是选择linux启动项后,系统成功进入 grub4dos界面,然后开始启动9.10,屏幕出现如下信息:
booting command-list
Filesystem type is ext2fs, partition type 0x83
之后就没反应了,所谓无反应是 所有键盘无效 系统不读硬盘 屏幕无任何变化,唯一能进行的操作是按电源 关机……

这个反应根本没有加载内核,把内核拷到 xp分区,修改下 menu.lst,用xp分区中的内核试试能不能引导。


_________________
Grub2 基础教程


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-14 0:01 
头像

注册: 2007-05-14 16:17
帖子: 89
地址: http://www.sglab.cn
送出感谢: 0 次
接收感谢: 0 次
多谢 小苹果,按照你说的思路搞定了

不过还是无法理解,为什么不能直接用ubuntu的Linux内核引导?难道grub4dos不支持ext4格式?


_________________
SGlab在中国的推广离不开开源……
http://www.sglab.cn


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-14 9:07 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
grub4dos肯定可以支持ext4,但是目前似乎有些含有linux分区的分区表grub不能识别,什么原因搞不明白。 :em06


_________________
Grub2 基础教程


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-14 14:58 
头像

注册: 2007-05-14 16:17
帖子: 89
地址: http://www.sglab.cn
送出感谢: 0 次
接收感谢: 0 次
原来是这样 学习了!

接下来就是折腾的过程了……

顺便问下 中文支持 在哪里安装 我在adminstrtor里面的 laungage support下面 只发现 德语 法语 英语 还有其他几个语种的支持 没有汉语啊,所以我没办法 找到 汉语项 然后再后面打勾,……

但是他倒是问我是否选择 登录界面 菜单用的语言 那个下面有汉语 但是选择了也没用……这怎么回事呢?


_________________
SGlab在中国的推广离不开开源……
http://www.sglab.cn


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-14 15:11 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
先换个源,再sudo apt-get update,再看语言支持。。。


_________________
Grub2 基础教程


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-16 7:59 
头像

注册: 2007-05-14 16:17
帖子: 89
地址: http://www.sglab.cn
送出感谢: 0 次
接收感谢: 0 次
果然 是 这样 我 现在已经在ubuntu下了

不过自带的 输入法似乎不 太 好 用 有 何建議?


_________________
SGlab在中国的推广离不开开源……
http://www.sglab.cn


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-16 8:08 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
PinYin
而不是拼音
不喜欢了还有scim和fcitx做备选


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-21 11:24 
头像

注册: 2007-05-14 16:17
帖子: 89
地址: http://www.sglab.cn
送出感谢: 0 次
接收感谢: 0 次
不知道为什么,自动更新了,结果就有了 PinYin输入法,真的不错,可以跟google输入法媲美@!


_________________
SGlab在中国的推广离不开开源……
http://www.sglab.cn


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-11-21 11:26 
头像

注册: 2007-05-14 16:17
帖子: 89
地址: http://www.sglab.cn
送出感谢: 0 次
接收感谢: 0 次
所以说啊,装好ubuntu后要更新,更新!呵呵 我的显卡现在也出来,希望一会激活后,能够自动设置好宽屏的分辨率,不必像7.04那个时候,还得自己去添加分辨率


_________________
SGlab在中国的推广离不开开源……
http://www.sglab.cn


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-12-06 21:24 
头像

注册: 2007-05-14 16:17
帖子: 89
地址: http://www.sglab.cn
送出感谢: 0 次
接收感谢: 0 次
硝烟再起啊 ……

话说我按照小苹果的思路,搞定了这个启动,但是我后来升级了内核,到2.6.32 (为了应用开源的3D显卡加速)。

我发现以这个方法(将安装盘的内核拷贝到XP系统下,然后用grub4dos引导这个内核,最终启动安装到硬盘上的linux),我升级了内核是没有用的,因为一开始加载的是我从安装光盘上拷贝的内核文件(2.6.14)

我后来将linux安装盘下的 boot文件夹下的 2.6.32内核文件 vmlinuz.2.6.32 和 initird 2.6.32 拷贝到XP盘下,替代原来的 VMlinuz和initird文件。并修改相关的menu.lst

结果是能够启动,但是到了 wait for root disk(启动比较后面的阶段了)的时候,长时间等待,最后进入busybox,提示找不到 nvidia—biabiaca6盘,(我是NV raid, 9.10安装在 biabiaca6分区)。

用ls查看,/dev/mapper 下面只有 control

难道新内核 无法支持 raid?


_________________
SGlab在中国的推广离不开开源……
http://www.sglab.cn


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 诡异的9.10安装问题
帖子发表于 : 2009-12-06 21:32 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
2.6.32还是 RC 的不支持是很正常的,你这个比较特殊的硬件还是用正式版的内核。


_________________
Grub2 基础教程


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译