当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu9.1更新flashplugin-nonfree不成功,删除报错?
帖子发表于 : 2009-11-09 9:44 
头像

注册: 2009-11-09 9:35
帖子: 196
送出感谢: 0 次
接收感谢: 0 次
天下午安装Flashplayer插件出错了,卸载也出错。

图片

sudo aptitude purge flashplugin-nonfree
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
下列软件包将被“删除”:
flashplugin-nonfree{ap}
0 个软件包被升级,新安装 0 个, 1 个将被删除, 同时 0 个将不升级。
需要获取 0B 的存档。 解包后将释放 168kB。
您要继续吗?[Y/n/?] Y
正在编辑扩展状态信息... 完成
(正在读取数据库 ... 系统当前总共安装有 120187 个文件和目录。)
正在删除 flashplugin-nonfree ...
update-alternatives: error: 无 iceape-flashplugin 的替换项。
update-alternatives: error: 无 iceape-flashplugin 的替换项。
dpkg:处理 flashplugin-nonfree (--purge)时出错:
子进程 已安装的 pre-removal 脚本 返回了错误号 2
postinst called with argument `abort-remove'
dpkg: 作下列清理工作时发生错误:
子进程 已安装的 post-installation 脚本 返回了错误号 1
在处理时有错误发生:
flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)
软件包安装失败。正在试图恢复:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成


继续执行命令依然报错


sudo apt-get remove
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 1 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
正在设置 flashplugin-nonfree (10.0.1.218+10.0.0.525ubuntu1~hardy1+really9.0.246.0ubuntu1) ...
cd: 132: can't cd to /var/cache/flashplugin-nonfree
dpkg:处理 flashplugin-nonfree (--configure)时出错:
子进程 已安装的 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

高手们出出注意啊。我都搞了一个下午,还没有解决。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu9.1更新flashplugin-nonfree不成功,删除报错?
帖子发表于 : 2009-11-09 9:49 
头像

注册: 2008-03-25 15:49
帖子: 25876
地址: 谁知道?
送出感谢: 8
接收感谢: 10
[code]apt-get -f install/code]
不是高手 :em06
引用:
我都搞了一个下午

:em20 :em20 :em20


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu9.1更新flashplugin-nonfree不成功,删除报错?
帖子发表于 : 2009-11-09 13:36 

注册: 2005-06-23 22:43
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get remove flashplugin-nonfree

试一下

安装flash插件直接用firefox进入有视频的网站,比如:土豆,会有提示的,按照提示安装即可,注意选择deb包


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu9.1更新flashplugin-nonfree不成功,删除报错?
帖子发表于 : 2009-11-09 16:56 
头像

注册: 2009-11-09 9:35
帖子: 196
送出感谢: 0 次
接收感谢: 0 次
xibeiren 写道:
代码:
sudo apt-get remove flashplugin-nonfree

试一下

安装flash插件直接用firefox进入有视频的网站,比如:土豆,会有提示的,按照提示安装即可,注意选择deb包

谢谢,效果是一样的,我还是重装了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu9.1更新flashplugin-nonfree不成功,删除报错?
帖子发表于 : 2009-12-10 22:31 

注册: 2009-12-10 22:18
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
尝试一下这个办法:
http://forum.ubuntu.org.cn/viewtopic.php?f=48&t=247899


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译