今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

系统安装、升级讨论
回复
bbcbbcbbc
帖子: 7
注册时间: 2009-08-08 19:42
送出感谢: 0
接收感谢: 0

今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#1

帖子 bbcbbcbbc » 2010-02-05 20:26

今天上午更新系统,从2.6.31-18升级到2.6.31-19。。
然后启动后进入了grub控制台界面。

然后我:ls,发现有(loop0) (hd0,1) (hd0,2)------
然后我执行下面命令:
linux /boot/vmlinuz-2.6.31-19 root=/dev/sda2 loop=/ubuntu/disks/root.disk
initrd /boot/initrd.img-2.6.31-19
boot

开始引导,最后提示"kernel panic - not syncing:VFS:unable to mount root fs on unknow-block(8,2)"
搞了半天没解决。
后来没办法只能用原来的kernel进系统。。
也是用的上面的命令。
是不是下载过程中内核文件受损还是新内核不只是旧的文件系统啊?
还有,我现在的电脑里面有4个版本的内核了 14 17 18 19

发个帖通报以下情况,如果有人遇到相同的问题可以一起讨论。。
也可以用上面的命令来使用旧版本的内核。
头像
wangdu2002
帖子: 13284
注册时间: 2008-12-13 19:39
来自: 物华天宝人杰地灵
送出感谢: 1 次
接收感谢: 6 次

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#2

帖子 wangdu2002 » 2010-02-05 20:48

换个源试试,也许是升级没有完全。。。另外如果安装了受限驱动,可以考虑先删除之,内核更新完成后再重新安装之。
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!
头像
huabinwu
帖子: 68
注册时间: 2008-08-15 14:38
送出感谢: 0
接收感谢: 0

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#3

帖子 huabinwu » 2010-02-06 6:07

搬个板凳表示同情 :em02 ,我遇到的问题跟lz不大一样,升了几次都没成功,/boot/下找不到新内核。。。现在还在用15。。。 :em20
头像
hasee.wu
帖子: 2089
注册时间: 2009-10-20 21:13
来自: Pacific Western University
送出感谢: 0
接收感谢: 7 次

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#4

帖子 hasee.wu » 2010-02-06 6:24

proposed 源最好不要用。
zhanghg
帖子: 131
注册时间: 2009-11-15 20:29
来自: Ningpo,Chekiang
送出感谢: 0
接收感谢: 0

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#5

帖子 zhanghg » 2010-02-06 10:27

Mount of root filesystem failed.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and reboot the system.
Give root password for maintenance
(or type CONTROL-D to continue):
=================================
高人快来解答呀!
lanmeibanban
帖子: 4
注册时间: 2008-11-02 21:56
送出感谢: 0
接收感谢: 0

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#6

帖子 lanmeibanban » 2010-02-06 13:58

LZ不是用wubi装的吧。。。。?

我的是用wubi装的,自打升到2.6.31-17就出现同样的问题了。郁闷死。

我记得在你给出的提示上面还有一句提示,大致意思是说“分区格式需要ext2,ext3....”但是貌似没有ntfs格式。所以不知道是不是wubi安装的通常是在ntsf格式分区导致的无法识别。到现在我还在用-14的内核。已经不能用郁闷来表达我的感觉了。

难道跟grub的升级有关?
头像
heshuaikun
帖子: 550
注册时间: 2008-09-07 23:44
送出感谢: 0
接收感谢: 1 次

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#7

帖子 heshuaikun » 2010-02-06 17:08

2.6.31-19 这个有问题。而且和nvidia的驱动似乎有点关系。
bbcbbcbbc
帖子: 7
注册时间: 2009-08-08 19:42
送出感谢: 0
接收感谢: 0

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#8

帖子 bbcbbcbbc » 2010-02-08 18:36

heshuaikun 写了:2.6.31-19 这个有问题。而且和nvidia的驱动似乎有点关系。
我也是这么觉得的·······
不然为什么偏偏只有2.6.31-19有问题嘞··
问题还没解决,继续使用2.6.31-18
Hu_Luo_Xiao
帖子: 6
注册时间: 2009-11-15 15:34
送出感谢: 0
接收感谢: 0

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#9

帖子 Hu_Luo_Xiao » 2010-02-08 18:48

:em06 升19以后发现启动死读硬盘,还特慢.不知为啥
always17
帖子: 4
注册时间: 2009-08-31 21:27
送出感谢: 0
接收感谢: 0

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#10

帖子 always17 » 2010-02-10 0:47

我脚的好杯具,更新到19后显卡驱动就不正常T T
bbcbbcbbc
帖子: 7
注册时间: 2009-08-08 19:42
送出感谢: 0
接收感谢: 0

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#12

帖子 bbcbbcbbc » 2010-02-11 9:48

嗯嗯····
试一下20的说···
头像
monk
帖子: 19507
注册时间: 2010-01-28 10:45
送出感谢: 6 次
接收感谢: 33 次

Re: 今天更新内核从2.6.31-18到2.6.31-19后新内核不能启动

#13

帖子 monk » 2010-02-11 14:37

nvidia的驱动就好还是用系统推荐的那个 我之前也试过一升级进入桌面就是一个黑屏

*********宁静致远*********
如果我说的有什么不对,请看签名第一行
回复

回到 “系统安装和升级”