当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : linux-image-2.6.24-27-generic 装不上。
帖子发表于 : 2010-02-24 4:05 

注册: 2008-07-21 10:00
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
我用的是8.04 64位。今天更新后,linux-image-2.6.24-27-generic装不上。
update manager 报错:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

在终端输入:
sudo dpkg --configure -a

返回:
Setting up initramfs-tools (0.85eubuntu39.3) ...
update-initramfs: deferring update (trigger activated)

dpkg: dependency problems prevent configuration of linux-ubuntu-modules-2.6.24-27-generic:
linux-ubuntu-modules-2.6.24-27-generic depends on linux-image-2.6.24-27-generic; however:
Package linux-image-2.6.24-27-generic is not installed.
dpkg: error processing linux-ubuntu-modules-2.6.24-27-generic (--configure):
dependency problems - leaving unconfigured
Setting up linux-ubuntu-modules-2.6.24-26-generic (2.6.24-26.44) ...
update-initramfs: Generating /boot/initrd.img-2.6.24-26-generic

gzip: stdout: No space left on device
update-initramfs: failed for /boot/initrd.img-2.6.24-26-generic
dpkg: error processing linux-ubuntu-modules-2.6.24-26-generic (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-generic:
linux-image-generic depends on linux-image-2.6.24-27-generic; however:
Package linux-image-2.6.24-27-generic is not installed.
linux-image-generic depends on linux-ubuntu-modules-2.6.24-27-generic; however:
Package linux-ubuntu-modules-2.6.24-27-generic is not configured yet.
dpkg: error processing linux-image-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-image-generic (= 2.6.24.27.29); however:
Package linux-image-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-restricted-modules-2.6.24-27-generic:
linux-restricted-modules-2.6.24-27-generic depends on linux-image-2.6.24-27-generic; however:
Package linux-image-2.6.24-27-generic is not installed.
dpkg: error processing linux-restricted-modules-2.6.24-27-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-restricted-modules-generic:
linux-restricted-modules-generic depends on linux-restricted-modules-2.6.24-27-generic; however:
Package linux-restricted-modules-2.6.24-27-generic is not configured yet.
dpkg: error processing linux-restricted-modules-generic (--configure):
dependency problems - leaving unconfigured
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.24-26-generic

gzip: stdout: No space left on device
update-initramfs: failed for /boot/initrd.img-2.6.24-26-generic
dpkg: subprocess post-installation script returned error exit status 1

我觉得是linux-image-2.6.24-27-generic没装上,依赖性的问题,于是上官网下载了它的deb 包。
但是双击deb包,提示因为broken dependency,需要试sudo synaptic 或apt-get install -f.
synatic打不开,报同样的:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

sudo apt-get install -f 报错:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

sudo apt-get install 也装不上linux-image-2.6.24-27-generic。
看起来就像死循环,linux-image-2.6.24-27-generic装不上,依赖性就解决不了;依赖性解决不了就不能安装软件;不能安装软件就不能装linux-image-2.6.24-27-generic。
暂时束手无策了,大家有什么建议吗?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译