当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : apt-get 安装vim不成功
帖子发表于 : 2010-05-01 12:06 

注册: 2009-04-05 1:41
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
刚装 ubuntu 10.04发现 没有 vim 只有 vi ,于是

panyh@panyh-laptop:~$ sudo apt-get install vim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
现在没有可用的软件包 vim,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 vim 还没有可供安装的候选者
panyh@panyh-laptop:~$


panyh@panyh-laptop:~$ sudo aptitude install vim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
Reading extended state information
Initializing package states... 完成
No candidate version found for vim
No candidate version found for vim
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
Reading extended state information
Initializing package states... 完成

panyh@panyh-laptop:~$

都不成功,怎么 会 事?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: apt-get 安装vim不成功
帖子发表于 : 2010-05-01 12:10 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
引用:
No candidate version found for vim
换源

该不是已经安装了吧@
代码:
vim hello


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
3 楼 
 文章标题 : Re: apt-get 安装vim不成功
帖子发表于 : 2010-05-01 12:13 

注册: 2009-04-05 1:41
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
panyh@panyh-laptop:~$ vim hello
The program 'vim' can be found in the following packages:
* vim
* vim-gnome
* vim-tiny
* vim-gtk
* vim-nox
Try: sudo apt-get install <selected package>
panyh@panyh-laptop:~$

没有 装 ,任何包都 转 不 上 .


页首
 用户资料  
 
4 楼 
 文章标题 : Re: apt-get 安装vim不成功
帖子发表于 : 2010-05-01 12:17 

注册: 2009-04-05 1:41
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
这 是 我 的 源,我 换 了 .

1 ### Ubuntu China Official Mirror, maintained by Shanghai Linux User Group
2
3 deb http://cn.archive.ubuntu.com/ubuntu gutsy main restricted universe multiverse
4 deb http://cn.archive.ubuntu.com/ubuntu gutsy-security main restricted universe multiverse
5 deb http://cn.archive.ubuntu.com/ubuntu gutsy-updates main restricted universe multiverse
6 deb http://cn.archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse
7 deb http://cn.archive.ubuntu.com/ubuntu gutsy-proposed main restricted universe multiverse
8 deb-src http://cn.archive.ubuntu.com/ubuntu gutsy main restricted universe multiverse
9 deb-src http://cn.archive.ubuntu.com/ubuntu gutsy-security main restricted universe multiverse
10 deb-src http://cn.archive.ubuntu.com/ubuntu gutsy-updates main restricted universe multiverse
11 deb-src http://cn.archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse
12 deb-src http://cn.archive.ubuntu.com/ubuntu gutsy-proposed main restricted universe multiverse
13
14 ### shanghai jiaotong university mirror
15
16 deb http://ftp.sjtu.edu.cn/ubuntu/ gutsy main multiverse restricted universe
17 deb http://ftp.sjtu.edu.cn/ubuntu/ gutsy-backports main multiverse restricted universe
18 deb http://ftp.sjtu.edu.cn/ubuntu/ gutsy-proposed main multiverse restricted universe
19 deb http://ftp.sjtu.edu.cn/ubuntu/ gutsy-security main multiverse restricted universe
20 deb http://ftp.sjtu.edu.cn/ubuntu/ gutsy-updates main multiverse restricted universe
21 deb-src http://ftp.sjtu.edu.cn/ubuntu/ gutsy main multiverse restricted universe
22 deb-src http://ftp.sjtu.edu.cn/ubuntu/ gutsy-backports main multiverse restricted universe
23 deb-src http://ftp.sjtu.edu.cn/ubuntu/ gutsy-proposed main multiverse restricted universe
24 deb-src http://ftp.sjtu.edu.cn/ubuntu/ gutsy-security main multiverse restricted universe
25 deb-src http://ftp.sjtu.edu.cn/ubuntu/ gutsy-updates main multiverse restricted universe
26
27 ### china telcom
28
29 deb http://mirror.vmmatrix.net/ubuntu/ gutsy main restricted universe multiverse
30 deb-src http://mirror.vmmatrix.net/ubuntu/ gutsy main restricted universe multiverse
31 deb http://mirror.vmmatrix.net/ubuntu/ gutsy-updates main restricted universe multiverse
32 deb-src http://mirror.vmmatrix.net/ubuntu/ gutsy-updates main restricted universe multiverse
33 deb http://mirror.vmmatrix.net/ubuntu/ gutsy-backports main restricted universe multiverse
34 deb-src http://mirror.vmmatrix.net/ubuntu/ gutsy-backports main restricted universe multiverse
35 deb http://mirror.vmmatrix.net/ubuntu/ gutsy-security main restricted universe multiverse
36 deb-src http://mirror.vmmatrix.net/ubuntu/ gutsy-security main restricted universe multiverse
37 deb http://mirror.vmmatrix.net/ubuntu/ gutsy-proposed main multiverse restricted universe
38 deb-src http://mirror.vmmatrix.net/ubuntu/ gutsy-proposed main restricted universe multiverse
39
40 ### taiwan official mirror
41
42 deb http://tw.archive.ubuntu.com/ubuntu gutsy main restricted universe multiverse
43 deb http://tw.archive.ubuntu.com/ubuntu gutsy-security main restricted universe multiverse
44 deb http://tw.archive.ubuntu.com/ubuntu gutsy-updates main restricted universe multiverse
45 deb http://tw.archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse
46 deb http://tw.archive.ubuntu.com/ubuntu gutsy-proposed main restricted universe multiverse
47 deb-src http://tw.archive.ubuntu.com/ubuntu gutsy main restricted universe multiverse
48 deb-src http://tw.archive.ubuntu.com/ubuntu gutsy-security main restricted universe multiverse
49 deb-src http://tw.archive.ubuntu.com/ubuntu gutsy-updates main restricted universe multiverse
50 deb-src http://tw.archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse
51 deb-src http://tw.archive.ubuntu.com/ubuntu gutsy-proposed main restricted universe multiverse
52


页首
 用户资料  
 
5 楼 
 文章标题 : Re: apt-get 安装vim不成功
帖子发表于 : 2010-05-01 12:26 
头像

注册: 2010-01-11 20:15
帖子: 331
送出感谢: 0 次
接收感谢: 0 次
为什么大家都要用Vim。。。
抛弃它把,用Kate。。。


_________________
代码:
Art is always explosion~~

http://allenalan.wordpress.com/
====Allen Alan=====


页首
 用户资料  
 
6 楼 
 文章标题 : Re: apt-get 安装vim不成功
帖子发表于 : 2010-05-16 18:02 
头像

注册: 2007-10-26 12:47
帖子: 109
送出感谢: 0 次
接收感谢: 0 次
我使用apt-get没法找到vim-full,但是找到了vim,但是安装后功能不全。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: apt-get 安装vim不成功
帖子发表于 : 2010-06-11 13:48 

注册: 2010-06-11 13:46
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
安装 vim-gnome 试试看


页首
 用户资料  
 
8 楼 
 文章标题 : Re: apt-get 安装vim不成功
帖子发表于 : 2010-06-11 13:57 
头像

注册: 2008-03-25 15:49
帖子: 25878
地址: 谁知道?
送出感谢: 8
接收感谢: 10
代码:
pocoyo@debian:~$ dpkg -l| grep vim
ii  vim                                  2:7.2.330-1                    Vi IMproved - enhanced vi editor
ii  vim-common                           2:7.2.330-1                    Vi IMproved - Common files
ii  vim-runtime                          2:7.2.330-1                    Vi IMproved - Runtime files
ii  vim-tiny                             2:7.2.330-1                    Vi IMproved - enhanced vi editor - compact v

debian的有 :em06


页首
 用户资料  
 
9 楼 
 文章标题 : Re: apt-get 安装vim不成功
帖子发表于 : 2010-06-11 14:01 

注册: 2008-11-19 14:48
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
楼主用的7.10版本的源?
没看到lucid字样,倒是gutsy字样不断。

Ubuntu 7.10 代号:Gutsy Gibbon
Ubuntu 10.04 代号:Lucid Lynx


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译