当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 9.1服务器版能否通过升级命令升级到ubuntu10.04?
帖子发表于 : 2010-06-02 12:42 

注册: 2009-12-10 15:27
帖子: 98
送出感谢: 3
接收感谢: 0 次
我的ubuntu 9.1不能通过以下命令升级到ubuntu10.04
sudo apt-get update
sudo apt-get dist-upgrade

有其他命令或办法从9.1版升级到ubuntu10.04吗?

恳请各位大侠帮忙!

终于解决了,见下文:
用sudo apt-get dist-upgrade 把服务器升级到Ubuntu Server 10.04版时,遇到了麻烦, 出现了:“Could not perform immediate configuration on 'util-linux'...”之类的错误,用 apt-get -f install 等都没有办法解决这个错误,后来,用下面几步解决了错误:
1.先换ubuntu10.04的源,参考http://sharking7320.blog.163.com/blog/static/2101924201033022252121/
2.重启服务器,进入安全模式
3.apt-get install dpkg
4.aptitude full-upgrade
重启


最后由 szfhx 编辑于 2010-06-03 9:53,总共编辑了 6 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 9.1能否通过升级命令升级到ubuntu10.04?
帖子发表于 : 2010-06-02 13:09 

注册: 2009-03-26 16:26
帖子: 55
送出感谢: 0 次
接收感谢: 1
sudo update-manager -d


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 9.1能否通过升级命令升级到ubuntu10.04?
帖子发表于 : 2010-06-02 13:30 

注册: 2009-12-10 15:27
帖子: 98
送出感谢: 3
接收感谢: 0 次
不行啊 我的是服务器版,没装update-manager


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu 9.1能否通过升级命令升级到ubuntu10.04?
帖子发表于 : 2010-06-02 14:13 
头像

注册: 2007-06-13 15:57
帖子: 12646
地址: 在他乡
送出感谢: 54
接收感谢: 90
全部换成10.04的源,且保证有一个是官方的。

代码:
sudo apt-get update
sudo apt-get dist-upgrade

重复直到所有的软件安装完毕

以前记得这样升级过一次


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu 9.1能否通过升级命令升级到ubuntu10.04?
帖子发表于 : 2010-06-02 14:51 

注册: 2009-10-30 22:54
帖子: 98
送出感谢: 0 次
接收感谢: 0 次
会有些小后遗症。。。 当心 因为新老版本交替所包含的软件不尽相同 :em20


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu 9.1能否通过升级命令升级到ubuntu10.04?
帖子发表于 : 2010-06-02 14:53 
头像

注册: 2007-08-22 15:55
帖子: 2837
地址: 新加坡
系统: Archlinux
送出感谢: 0 次
接收感谢: 9
先换源,关第三方源


_________________
Entschuldigung. Ich habe keine ahnung.
Secure with PGP: gpg --recv-keys 0x68b6e3d8
Fingerprint: 5556 517C F52F E402 DDF5 5400 6D30 F13E 68B6 E3D8
Towards A Sustainable Earth: Print Only When Necessary


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu 9.1服务器版能否通过升级命令升级到ubuntu10.04?
帖子发表于 : 2010-06-03 9:51 

注册: 2009-12-10 15:27
帖子: 98
送出感谢: 3
接收感谢: 0 次
终于解决了,见下文:
用sudo apt-get dist-upgrade 把服务器升级到Ubuntu Server 10.04版时,遇到了麻烦, 出现了:“Could not perform immediate configuration on 'util-linux'...”之类的错误,用 apt-get -f install 等都没有办法解决这个错误,后来,用下面几步解决了错误:
1.先换ubuntu10.04的源,参考http://sharking7320.blog.163.com/blog/static/2101924201033022252121/
2.重启服务器,进入安全模式
3.apt-get install dpkg
4.aptitude full-upgrade

重启


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译