当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 紧急求助:apt升级了linux 内核但是新内核默认不能用!
帖子发表于 : 2010-06-23 12:12 

注册: 2008-08-29 10:58
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
#uname -a

Linux wbs-laptop 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux

但是我通过atp-get 已经升级到了新的内核:

# dpkg -l|grep linux

ii libselinux1 2.0.89-4 SELinux runtime shared libraries
ii libv4l-0 0.6.4-1ubuntu1 Collection of video4linux support libraries
ii linux-firmware 1.36 Firmware for Linux kernel drivers
ii linux-headers-2.6.32-21 2.6.32-21.32 Header files related to Linux kernel version 2.6
ii linux-headers-2.6.32-21-generic 2.6.32-21.32 Linux kernel headers for version 2.6.32 on x86/x
ii linux-headers-2.6.32-23 2.6.32-23.37 Header files related to Linux kernel version 2.6
ii linux-headers-2.6.32-23-generic 2.6.32-23.37 Linux kernel headers for version 2.6.32 on x86/x
ii linux-headers-generic 2.6.32.23.24 Generic Linux kernel headers
ii linux-image-2.6.32-21-generic 2.6.32-21.32 Linux kernel image for version 2.6.32 on x86/x86
ii linux-libc-dev 2.6.35-5.6 Linux Kernel Headers for development
ii linux-sound-base 1.0.22.1+dfsg-0ubuntu3 base package for ALSA and OSS sound systems
ii pptp-linux 1.7.2-4 Point-to-Point Tunneling Protocol (PPTP) Client
ii syslinux 2:3.63+dfsg-2ubuntu3 Bootloader for Linux/i386 using MS-DOS floppies
ii util-linux 2.17.2-0ubuntu1 Miscellaneous system utilities

请问,为什么系统启动的时候一直用旧内核却不用新内核呢?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 紧急求助:apt升级了linux 内核但是新内核默认不能用!
帖子发表于 : 2010-06-23 14:06 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
试试
代码:
sudo update-grub


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 紧急求助:apt升级了linux 内核但是新内核默认不能用!
帖子发表于 : 2010-06-23 18:23 

注册: 2008-08-29 10:58
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
试过了,不行的,所以我直接编译安装了 kernel 2.6.34手动创建了vimluz-2.6.34


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 紧急求助:apt升级了linux 内核但是新内核默认不能用!
帖子发表于 : 2010-06-26 19:12 

注册: 2010-06-23 11:38
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
论坛的短消息有bug想私下交流的朋友,请发Email jhswx84@gmail.com欢迎访问我的Eden博客My Angel,Miss you forever


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 紧急求助:apt升级了linux 内核但是新内核默认不能用!
帖子发表于 : 2010-06-26 19:23 
头像

注册: 2008-03-25 15:49
帖子: 25877
地址: 谁知道?
送出感谢: 8
接收感谢: 10
引用:
论坛的短消息有bug想私下交流的朋友

啥bug :em20


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 紧急求助:apt升级了linux 内核但是新内核默认不能用!
帖子发表于 : 2010-07-03 9:11 
头像

注册: 2010-06-04 1:06
帖子: 1791
送出感谢: 3
接收感谢: 5
monk 写道:
试试
代码:
sudo update-grub

:em11 恩,好了!!谢谢!!


_________________
1. GIMP入门教程(1~7)——比Photoshop更棒的图像处理软件!
2. Ubuntu桌面培训——初级,新手入门必看


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译