当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 急救:9.10升级10.04失败,无法恢复,如何是好?在线等。。。
帖子发表于 : 2010-07-12 5:40 

注册: 2007-12-28 21:20
帖子: 220
送出感谢: 0 次
接收感谢: 0 次
昨天试图从9.10 X86-64升级到10.04 X86-64,结果升级失败,我按照提示用dpkg --configure -a恢复原系统,结果提示了下面的一堆信息,很多软件包都破坏了。。。而且系统只有一个根分区,所有资料都没有备份,现在改回了9.10的source.list,但是升级管理器不能用。有法子避免损失吗?在线等。。。谢谢!


dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-keyring:
gnome-keyring depends on libgtk2.0-0 (>= 2.20.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing gnome-keyring (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of compiz-plugins:
compiz-plugins depends on libgtk2.0-0 (>= 2.8.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing compiz-plugins (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indicator-session:
indicator-session depends on libgtk2.0-0 (>= 2.16.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing indicator-session (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libindicate-gtk2:
libindicate-gtk2 depends on libgtk2.0-0 (>= 2.14.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libindicate-gtk2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gnomecanvas:
python-gnomecanvas depends on libgtk2.0-0 (>= 2.8.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing python-gnomecanvas (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-sexy:
python-sexy depends on libgtk2.0-0 (>= 2.8.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing python-sexy (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libavahi-ui0:
libavahi-ui0 depends on libgtk2.0-0 (>= 2.8.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libavahi-ui0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of policykit-1-gnome:
policykit-1-gnome depends on libgtk2.0-0 (>= 2.17.1); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing policykit-1-gnome (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-games-common:
gnome-games-common depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing gnome-games-common (--configure):
dependency problems - leaving unconfigured
Setting up bluez-gstreamer (4.60-0ubuntu8) ...
dpkg: dependency problems prevent configuration of gnotravex:
gnotravex depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
gnotravex depends on gnome-games-common (>= 1:2.30.0-0ubuntu6); however:
Package gnome-games-common is not configured yet.
dpkg: error processing gnotravex (--configure):
dependency problems - leaving unconfigured
Setting up system-config-printer-udev (1.2.0+20100408-0ubuntu5.2) ...
Setting up libasound2-plugins (1.0.22-0ubuntu6) ...
dpkg: dependency problems prevent configuration of libappindicator0:
libappindicator0 depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libappindicator0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgksu2-0:
libgksu2-0 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgksu2-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-appindicator:
python-appindicator depends on libappindicator0 (= 0.0.19-0ubuntu4); however:
Package libappindicator0 is not configured yet.
python-appindicator depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing python-appindicator (--configure):
dependency problems - leaving unconfigured
Setting up ppp (2.4.5~git20081126t100229-0ubuntu3) ...

Setting up libgcj10 (4.4.3-1ubuntu2) ...

dpkg: dependency problems prevent configuration of simple-scan:
simple-scan depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing simple-scan (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of synaptic:
synaptic depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing synaptic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openoffice.org-core:
openoffice.org-core depends on libgtk2.0-0 (>= 2.10); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing openoffice.org-core (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openoffice.org-draw:
openoffice.org-draw depends on openoffice.org-core (= 1:3.2.0-7ubuntu4.1); however:
Package openoffice.org-core is not configured yet.
dpkg: error processing openoffice.org-draw (--configure):
dependency problems - leaving unconfigured
Setting up xinit (1.2.0-1) ...
Installing new version of config file /etc/X11/xinit/xinitrc ...
Installing new version of config file /etc/X11/xinit/xserverrc ...
dpkg: dependency problems prevent configuration of gtk2-engines-pixbuf:
gtk2-engines-pixbuf depends on gtk2.0-binver-2.10.0; however:
Package gtk2.0-binver-2.10.0 is not installed.
Package libgtk2.0-0 which provides gtk2.0-binver-2.10.0 is not configured yet.
gtk2-engines-pixbuf depends on libgtk2.0-0 (= 2.20.1-0ubuntu2); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing gtk2-engines-pixbuf (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-vte:
python-vte depends on libgtk2.0-0 (>= 2.14.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing python-vte (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openoffice.org-gtk:
openoffice.org-gtk depends on openoffice.org-core (= 1:3.2.0-7ubuntu4.1); however:
Package openoffice.org-core is not configured yet.
openoffice.org-gtk depends on libgtk2.0-0 (>= 2.14.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing openoffice.org-gtk (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libclutter-gtk-0.10-0:
libclutter-gtk-0.10-0 depends on libgtk2.0-0 (>= 2.20.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libclutter-gtk-0.10-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtkhtml-editor0:
libgtkhtml-editor0 depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgtkhtml-editor0 (--configure):
dependency problems - leaving unconfigured
Setting up ia32-libs (2.7ubuntu25) ...

dpkg: dependency problems prevent configuration of librsvg2-2:
librsvg2-2 depends on libgtk2.0-0 (>= 2.16); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing librsvg2-2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libedataserverui1.2-8:
libedataserverui1.2-8 depends on libgtk2.0-0 (>= 2.14.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libedataserverui1.2-8 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgail18:
libgail18 depends on libgtk2.0-0 (= 2.20.1-0ubuntu2); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgail18 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-glade2:
python-glade2 depends on libgtk2.0-0 (>= 2.19.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing python-glade2 (--configure):
dependency problems - leaving unconfigured
Setting up myspell-en-za (1:3.2.0-3ubuntu3) ...

dpkg: dependency problems prevent configuration of yelp:
yelp depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing yelp (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of glchess:
glchess depends on gnome-games-common (>= 1:2.30.0-0ubuntu6); however:
Package gnome-games-common is not configured yet.
dpkg: error processing glchess (--configure):
dependency problems - leaving unconfigured
Setting up libcwidget3 (0.5.13-1ubuntu1) ...

dpkg: dependency problems prevent configuration of python-webkit:
python-webkit depends on libgtk2.0-0 (>= 2.10.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing python-webkit (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librsvg2-common:
librsvg2-common depends on gtk2.0-binver-2.10.0; however:
Package gtk2.0-binver-2.10.0 is not installed.
Package libgtk2.0-0 which provides gtk2.0-binver-2.10.0 is not configured yet.
librsvg2-common depends on libgtk2.0-0 (>= 2.16); however:
Package libgtk2.0-0 is not configured yet.
librsvg2-common depends on librsvg2-2 (= 2.26.3-0ubuntu1); however:
Package librsvg2-2 is not configured yet.
dpkg: error processing librsvg2-common (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gtksourceview2:
python-gtksourceview2 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing python-gtksourceview2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-disk-utility:
gnome-disk-utility depends on libavahi-ui0 (>= 0.6.21); however:
Package libavahi-ui0 is not configured yet.
gnome-disk-utility depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing gnome-disk-utility (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-rsvg:
python-rsvg depends on libgtk2.0-0 (>= 2.8.0); however:
Package libgtk2.0-0 is not configured yet.
python-rsvg depends on librsvg2-2 (>= 2.26.0); however:
Package librsvg2-2 is not configured yet.
python-rsvg depends on librsvg2-common; however:
Package librsvg2-common is not configured yet.
dpkg: error processing python-rsvg (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gucharmap:
gucharmap depends on libgtk2.0-0 (>= 2.14.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing gucharmap (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libunique-1.0-0:
libunique-1.0-0 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libunique-1.0-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtksourceview2.0-0:
libgtksourceview2.0-0 depends on libgtk2.0-0 (>= 2.16.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgtksourceview2.0-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of at-spi:
at-spi depends on libgtk2.0-0 (>= 2.10.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing at-spi (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgail-common:
libgail-common depends on libgail18 (= 2.20.1-0ubuntu2); however:
Package libgail18 is not configured yet.
dpkg: error processing libgail-common (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnomevfs2-0:
libgnomevfs2-0 depends on libgnomevfs2-common (>= 1:2.24); however:
Package libgnomevfs2-common is not installed.
libgnomevfs2-0 depends on libgnomevfs2-common (<< 1:2.25); however:
Package libgnomevfs2-common is not installed.
dpkg: error processing libgnomevfs2-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gtk2:
python-gtk2 depends on libgtk2.0-0 (>= 2.19.1); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing python-gtk2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gvfs:
gvfs depends on policykit-1-gnome; however:
Package policykit-1-gnome is not configured yet.
dpkg: error processing gvfs (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtkhtml3.14-19:
libgtkhtml3.14-19 depends on libgail18 (>= 1.18.0); however:
Package libgail18 is not configured yet.
libgtkhtml3.14-19 depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgtkhtml3.14-19 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnomine:
gnomine depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
gnomine depends on librsvg2-2 (>= 2.26.0); however:
Package librsvg2-2 is not configured yet.
gnomine depends on gnome-games-common (>= 1:2.30.0-0ubuntu6); however:
Package gnome-games-common is not configured yet.
dpkg: error processing gnomine (--configure):
dependency problems - leaving unconfigured
Setting up aptitude (0.4.11.11-1ubuntu10) ...

dpkg: dependency problems prevent configuration of gnome-mahjongg:
gnome-mahjongg depends on libgtk2.0-0 (>= 2.18.0); however:
Package libgtk2.0-0 is not configured yet.
gnome-mahjongg depends on librsvg2-2 (>= 2.26.0); however:
Package librsvg2-2 is not configured yet.
gnome-mahjongg depends on gnome-games-common (>= 1:2.30.0-0ubuntu6); however:
Package gnome-games-common is not configured yet.
dpkg: error processing gnome-mahjongg (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwebkit-1.0-2:
libwebkit-1.0-2 depends on libgail18 (>= 1.18.0); however:
Package libgail18 is not configured yet.
libwebkit-1.0-2 depends on libgtk2.0-0 (>= 2.20.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libwebkit-1.0-2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcanberra-gtk0:
libcanberra-gtk0 depends on libgtk2.0-0 (>= 2.14.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libcanberra-gtk0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gtkglext1:
python-gtkglext1 depends on libgtk2.0-0 (>= 2.8.0); however:
Package libgtk2.0-0 is not configured yet.
python-gtkglext1 depends on libgtkglext1; however:
Package libgtkglext1 is not installed.
dpkg: error processing python-gtkglext1 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vino:
vino depends on libgtk2.0-0 (>= 2.16.0); however:
Package libgtk2.0-0 is not configured yet.
vino depends on libunique-1.0-0 (>= 1.0.0); however:
Package libunique-1.0-0 is not configured yet.
dpkg: error processing vino (--configure):
dependency problems - leaving unconfigured
dpkg: too many errors, stopping
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for python-central ...
Processing triggers for python-support ...
Errors were encountered while processing:
shared-mime-info
libgtk2.0-0
evolution-data-server
gnome-keyring
compiz-plugins
indicator-session
libindicate-gtk2
python-gnomecanvas
python-sexy
libavahi-ui0
policykit-1-gnome
gnome-games-common
gnotravex
libappindicator0
libgksu2-0
python-appindicator
simple-scan
synaptic
openoffice.org-core
openoffice.org-draw
gtk2-engines-pixbuf
python-vte
openoffice.org-gtk
libclutter-gtk-0.10-0
libgtkhtml-editor0
librsvg2-2
libedataserverui1.2-8
libgail18
python-glade2
yelp
glchess
python-webkit
librsvg2-common
python-gtksourceview2
gnome-disk-utility
python-rsvg
gucharmap
libunique-1.0-0
libgtksourceview2.0-0
at-spi
libgail-common
libgnomevfs2-0
python-gtk2
gvfs
libgtkhtml3.14-19
gnomine
gnome-mahjongg
libwebkit-1.0-2
libcanberra-gtk0
python-gtkglext1
vino
Processing was halted because there were too many errors.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 急救:9.10升级10.04失败,无法恢复,如何是好?在线等。。。
帖子发表于 : 2010-07-12 10:07 
头像

注册: 2008-12-20 15:43
帖子: 9349
地址: 心靈深處
系统: 家14.04,公司14.04
送出感谢: 13
接收感谢: 37
:em20 ...升級前沒做備份...很多前輩不是都說過...升級有風險的嗎?暈...


_________________
[论坛版主行为规定]+[PITIVI簡易教程]+[CAD裝draftsight]+[酷我音乐裝kwplayer]+[ubuntu裝迅雷]
[releases.ubuntu.com]+[cdimage.ubuntu.com]+[old-releases.ubuntu.com]
[學ubuntu必須拜讀懶蝸牛"笨兔兔的故事"=viewtopic.php?f=112&t=162040][Linux明日的希望在中國]


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译