当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:安装ubuntu10.04时遇到的问题
帖子发表于 : 2010-07-17 20:05 
头像

注册: 2010-04-29 20:04
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
:em20 我是拿u盘制作的livecd,安装到移动硬盘上,先前移动硬盘已经分了3个区,最后还有50G,就装了ubuntu
安装完成后,重启,结果进不了ubuntu,也进不了电脑上原来的xp了.
提示错误:
no such device .................
grub>_
进livecd试用修改grub.cfg(注释了所有的search),还是提示上面的错误.

急!!!!!在线等!!!!!高手来帮帮小弟!!!!!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:安装ubuntu10.04时遇到的问题
帖子发表于 : 2010-07-17 21:39 

注册: 2008-01-11 17:02
帖子: 12127
送出感谢: 1
接收感谢: 6
传说最好要装在移动硬盘的前8G的分区

LZ确定grub是装在移动硬盘么?


_________________
你往幸福的方向挥挥手,从此我便追随你永不回头。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:安装ubuntu10.04时遇到的问题
帖子发表于 : 2010-07-17 21:55 
头像

注册: 2010-04-29 20:04
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
嗯,装到/boot/grub下了。 :em20
有的帖子说分区表有问题,移动硬盘的分区表如下
附件:
Screenshot.png
Screenshot.png [ 93.72 KiB | 被浏览 302 次 ]


还有说拿PQ魔法师重新定位下mbr。
现在都不知道该咋办了。

电脑还不是自己的 :em20


:em06 是不是我把swap分区和/分区建成逻辑分区的原因?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助:安装ubuntu10.04时遇到的问题
帖子发表于 : 2010-07-17 22:20 
头像

注册: 2008-04-07 17:36
帖子: 4010
地址: 泰安人在阜新
送出感谢: 0 次
接收感谢: 0 次
可能是 map 的问题。

grub要装在 移动硬盘 上,这样就可以相互不影响了


_________________
宇宙数学物理 sssssssss Ubuntu 桌面培训 sssssssss 问打包的问题之前先看
和我一样的新手请看,我看过了,腰不酸了,腿不疼了,上楼也有劲了
想去IRC的点这里——一个比QQ群好N多的东西


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助:安装ubuntu10.04时遇到的问题
帖子发表于 : 2010-07-17 22:38 
头像

注册: 2010-04-29 20:04
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
:em11 重新分了下区,重装了下解决了。

:em06 不过还是不知道原因出在哪。

不过又出新问题了,把移动硬盘拔了,就又出现:
error:no such device .......................
grub rescus:_

:em06 这又咋解决啊


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助:安装ubuntu10.04时遇到的问题
帖子发表于 : 2010-07-17 23:26 
头像

注册: 2010-06-04 1:06
帖子: 1791
送出感谢: 3
接收感谢: 5
sephiroth21 写道:
:em11 重新分了下区,重装了下解决了。

:em06 不过还是不知道原因出在哪。

不过又出新问题了,把移动硬盘拔了,就又出现:
error:no such device .......................
grub rescus:_

:em06 这又咋解决啊


grub一定要装在移动硬盘上;
你可能安装在主机硬盘上了,破坏了win的引导,需要修复,具体办法google之 :em11


_________________
1. GIMP入门教程(1~7)——比Photoshop更棒的图像处理软件!
2. Ubuntu桌面培训——初级,新手入门必看


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助:安装ubuntu10.04时遇到的问题
帖子发表于 : 2010-07-18 10:02 
头像

注册: 2010-04-29 20:04
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
:em01 Grub确实装在了移动硬盘上了,在/boot/grub下。

:em06 在网上找了句"sudo dd if=/usr/lib/syslinux/mbr.bin of=/dev/sda"在Ubuntu下执行了下,开机直接就进XP了(此时插着移动硬盘),可却进不了Grub了。

:em06 是不是要拿Ubuntu10.04的livecd修复下?是不是进不了xp的时候,不能在装好的Ubuntu上执行"sudo dd if=/usr/lib/syslinux/mbr.bin of=/dev/sda"修复,而是拿xp的系统盘修复啊?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助:安装ubuntu10.04时遇到的问题
帖子发表于 : 2010-07-24 21:42 
头像

注册: 2010-04-29 20:04
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
:em11 折腾两天,搞定了。

:em11 开始学习在不支持USB-HDD的电脑上启动移动硬盘中ubuntu的方法。



ps:原来最后一步的时候要点“高级”--“安装引导程序”的时候选移动硬盘分区,安装完后拔了移动硬盘和livecd(移动硬盘一定要拔,否则重启以后选启动项的时候找不到USB deveice)。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译