当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于添加PPA源报错,无法更新的问题。实在没辙了!
帖子发表于 : 2010-07-24 17:59 
头像

注册: 2009-12-15 21:30
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
前几天想升级KDE到4.5,于是便去添加了PPA源。但是报错了,折腾了几天都没搞定。网上也没有好的解决办法。有人说是apt的bug。现在是不知该怎么办了。

代码:
kdeghost@Ghost-dearest:~$ sudo add-apt-repository ppa:kubuntu-ppa/backports
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 59, in run
    self.add_ppa_signing_key(self.ppa_path)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 88, in add_ppa_signing_key
    print "Error reading %s: %s" % (lp_url, e)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe8 in position 27: ordinal not in range(128)

kdeghost@Ghost-dearest:~$ sudo add-apt-repository ppa:kubuntu-ppa/ppa
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 59, in run
    self.add_ppa_signing_key(self.ppa_path)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 88, in add_ppa_signing_key
    print "Error reading %s: %s" % (lp_url, e)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe8 in position 27: ordinal not in range(128)

kdeghost@Ghost-dearest:~$ sudo apt-get update
命中 http://ubuntu.srt.cn lucid Release.gpg
命中 http://ubuntu.srt.cn/ubuntu/ lucid/main Translation-zh_CN
命中 http://ubuntu.srt.cn/ubuntu/ lucid/restricted Translation-zh_CN
命中 http://ubuntu.srt.cn/ubuntu/ lucid/universe Translation-zh_CN
命中 http://ubuntu.srt.cn/ubuntu/ lucid/multiverse Translation-zh_CN
命中 http://ubuntu.srt.cn lucid-security Release.gpg
忽略 http://ubuntu.srt.cn/ubuntu/ lucid-security/main Translation-zh_CN
忽略 http://ubuntu.srt.cn/ubuntu/ lucid-security/restricted Translation-zh_CN
忽略 http://ubuntu.srt.cn/ubuntu/ lucid-security/universe Translation-zh_CN
忽略 http://ubuntu.srt.cn/ubuntu/ lucid-security/multiverse Translation-zh_CN
命中 http://ubuntu.srt.cn lucid-updates Release.gpg
忽略 http://ubuntu.srt.cn/ubuntu/ lucid-updates/main Translation-zh_CN
忽略 http://ubuntu.srt.cn/ubuntu/ lucid-updates/restricted Translation-zh_CN
忽略 http://ubuntu.srt.cn/ubuntu/ lucid-updates/universe Translation-zh_CN
忽略 http://ubuntu.srt.cn/ubuntu/ lucid-updates/multiverse Translation-zh_CN
命中 http://ubuntu.srt.cn lucid Release                                 
命中 http://ubuntu.srt.cn lucid-security Release                         
命中 http://ubuntu.srt.cn lucid-updates Release                                 
命中 http://ubuntu.srt.cn lucid/main Packages                                   
命中 http://ubuntu.srt.cn lucid/restricted Packages                     
命中 http://ubuntu.srt.cn lucid/universe Packages                       
命中 http://ubuntu.srt.cn lucid/multiverse Packages                     
命中 http://ubuntu.srt.cn lucid/main Sources                             
命中 http://ubuntu.srt.cn lucid/restricted Sources 
命中 http://ubuntu.srt.cn lucid/universe Sources                         
命中 http://ubuntu.srt.cn lucid/multiverse Sources                       
命中 http://ubuntu.srt.cn lucid-security/main Packages                   
命中 http://ubuntu.srt.cn lucid-security/restricted Packages             
命中 http://ubuntu.srt.cn lucid-security/universe Packages               
命中 http://ubuntu.srt.cn lucid-security/multiverse Packages             
命中 http://ubuntu.srt.cn lucid-security/main Sources                   
命中 http://ubuntu.srt.cn lucid-security/restricted Sources             
命中 http://ubuntu.srt.cn lucid-security/universe Sources               
命中 http://ubuntu.srt.cn lucid-security/multiverse Sources             
命中 http://ubuntu.srt.cn lucid-updates/main Packages                   
命中 http://ubuntu.srt.cn lucid-updates/restricted Packages             
命中 http://ubuntu.srt.cn lucid-updates/universe Packages               
命中 http://ubuntu.srt.cn lucid-updates/multiverse Packages             
命中 http://ubuntu.srt.cn lucid-updates/main Sources                     
命中 http://ubuntu.srt.cn lucid-updates/restricted Sources               
命中 http://ubuntu.srt.cn lucid-updates/universe Sources                 
命中 http://ubuntu.srt.cn lucid-updates/multiverse Sources               
错误 http://ppa.launchpad.net lucid Release.gpg                         
  无法连接上 ppa.launchpad.net:80 (91.189.90.217)。 - connect (110: 连接超时)
错误 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/ lucid/main Translation-zh_CN
  不能连接到 ppa.launchpad.net:http:
错误 http://ppa.launchpad.net lucid Release.gpg     
  不能连接到 ppa.launchpad.net:http:
错误 http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu/ lucid/main Translation-zh_CN
  不能连接到 ppa.launchpad.net:http:
错误 http://ppa.launchpad.net lucid Release.gpg
  不能连接到 ppa.launchpad.net:http:
错误 http://ppa.launchpad.net/tualatrix/ppa/ubuntu/ lucid/main Translation-zh_CN
  不能连接到 ppa.launchpad.net:http:
忽略 http://ppa.launchpad.net lucid Release
忽略 http://ppa.launchpad.net lucid Release
忽略 http://ppa.launchpad.net lucid Release
忽略 http://ppa.launchpad.net lucid/main Packages
忽略 http://ppa.launchpad.net lucid/main Packages
忽略 http://ppa.launchpad.net lucid/main Packages
忽略 http://ppa.launchpad.net lucid/main Packages
忽略 http://ppa.launchpad.net lucid/main Packages
忽略 http://ppa.launchpad.net lucid/main Packages
错误 http://ppa.launchpad.net lucid/main Packages
  不能连接到 ppa.launchpad.net:http:
错误 http://ppa.launchpad.net lucid/main Packages
  不能连接到 ppa.launchpad.net:http:
错误 http://ppa.launchpad.net lucid/main Packages
  不能连接到 ppa.launchpad.net:http:
W: 无法下载 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/dists/lucid/Release.gpg  无法连接上 ppa.launchpad.net:80 (91.189.90.217)。 - connect (110: 连接超时)

W: 无法下载 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/dists/lucid/main/i18n/Translation-zh_CN.bz2  不能连接到 ppa.launchpad.net:http:

W: 无法下载 http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu/dists/lucid/Release.gpg  不能连接到 ppa.launchpad.net:http:

W: 无法下载 http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu/dists/lucid/main/i18n/Translation-zh_CN.bz2  不能连接到 ppa.launchpad.net:http:

W: 无法下载 http://ppa.launchpad.net/tualatrix/ppa/ubuntu/dists/lucid/Release.gpg  不能连接到 ppa.launchpad.net:http:

W: 无法下载 http://ppa.launchpad.net/tualatrix/ppa/ubuntu/dists/lucid/main/i18n/Translation-zh_CN.bz2  不能连接到 ppa.launchpad.net:http:

W: 无法下载 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/dists/lucid/main/binary-i386/Packages.gz  不能连接到 ppa.launchpad.net:http:

W: 无法下载 http://ppa.launchpad.net/kubuntu-ppa/ppa/ubuntu/dists/lucid/main/binary-i386/Packages.gz  不能连接到 ppa.launchpad.net:http:

W: 无法下载 http://ppa.launchpad.net/tualatrix/ppa/ubuntu/dists/lucid/main/binary-i386/Packages.gz  不能连接到 ppa.launchpad.net:http:

E: 有一些索引文件不能下载,它们可能被忽略了,也可能转而使用了旧的索引文件。



我试过重建sources.list,并把其他第三方PPA都给删了。还是无法更新KDE。软件源里的其他软件列表里已经显示添加进去了。但sources.list未变。

deb http://ubuntu.srt.cn/ubuntu/ lucid main restricted universe multiverse
deb http://ubuntu.srt.cn/ubuntu/ lucid-security main restricted universe multiverse
deb http://ubuntu.srt.cn/ubuntu/ lucid-updates main restricted universe multiverse
deb-src http://ubuntu.srt.cn/ubuntu/ lucid main restricted universe multiverse
deb-src http://ubuntu.srt.cn/ubuntu/ lucid-security main restricted universe multiverse
deb-src http://ubuntu.srt.cn/ubuntu/ lucid-updates main restricted universe multiverse

看报错信息,可能是python的问题。我同时安装了2.6和3.1,不知道这样有没有影响。update时说:不能连接到ppa.launchpad.net
于是我ping了下,没问题。
添加其他PPA也是一样的错误。所有自己添加的PPA都无法使用。

现在不知道该怎么办了才来求助的。有人知道解决办法不?
谢谢。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 关于添加PPA源报错,无法更新的问题。实在没辙了!
帖子发表于 : 2010-07-24 18:06 
头像

注册: 2007-08-05 17:40
帖子: 4980
送出感谢: 0 次
接收感谢: 6
apt是有BUG但被他们无视了。


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 关于添加PPA源报错,无法更新的问题。实在没辙了!
帖子发表于 : 2010-07-24 18:13 
头像

注册: 2009-12-15 21:30
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
cnkilior 写道:
apt是有BUG但被他们无视了。

:em34

不能用第三方的PPA真是太不方便了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 关于添加PPA源报错,无法更新的问题。实在没辙了!
帖子发表于 : 2010-07-24 19:39 
头像

注册: 2010-03-06 20:18
帖子: 115
送出感谢: 0 次
接收感谢: 0 次
试过几次 是网站暂时性维护或被墙吧 过一会就没事了..


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 关于添加PPA源报错,无法更新的问题。实在没辙了!
帖子发表于 : 2010-07-24 20:35 
头像

注册: 2009-12-15 21:30
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
viceman 写道:
试过几次 是网站暂时性维护或被墙吧 过一会就没事了..



一个多星期前就是这种情况了。当时没怎么注意。应该不是维护吧。能ping通,那应该没被墙。 我翻下墙试试。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 关于添加PPA源报错,无法更新的问题。实在没辙了!
帖子发表于 : 2010-07-25 0:27 
头像

注册: 2009-12-15 21:30
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
哭笑不得。折磨了我这么久的问题,竟然真的是被墙了!!!!难怪怎么搞都不行啊!现在在用tsocks 代理apt。还有5分钟就可以将更新下完了。

launchpad居然被墙了!

再次感慨下天朝的强大!我朝威武!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 关于添加PPA源报错,无法更新的问题。实在没辙了!
帖子发表于 : 2011-10-01 20:04 

注册: 2008-10-20 13:02
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
这里有个办法:
http://efreedom.com/Question/6-35223/Sy ... xy-Aptconf

$ sudo -s
# 囗囗囗囗囗囗 -on
# apt-get update
# apt-get dist-upgrade
# 囗囗囗囗囗囗 -off # not really necessary, given the exit
# exit
$


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译