当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 构建ARM平台ubuntu镜像时遇到的问题,大家指教一二
帖子发表于 : 2010-08-11 17:42 
头像

注册: 2009-04-23 9:50
帖子: 73
地址: CN
系统: ubuntu
送出感谢: 0 次
接收感谢: 0 次
打算在milestone上跑ubuntu kmaric
构建ubuntu kmaric镜像文件成功,但是在安装lxde和lightvncserver时,出现了一下错误,排查了半天都没搞定! 大家看看了,指导一二! :em06

安装lxde时的log:
代码:
root@diux:/# apt-get install lxde
Reading package lists... Done
Building dependency tree... Done
lxde is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Can not write log, openpty() failed (/dev/pts not mounted?)
Setting up pulseaudio (1:0.9.19-0ubuntu4) ...
invoke-rc.d: initscript pulseaudio, action "start" failed.
dpkg: error processing pulseaudio (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of pulseaudio-esound-compat:
 pulseaudio-esound-compat depends on pulseaudio (= 1:0.9.19-0ubuntu4); however:
  Package pulseaudio is not configured yet.
dpkg: error processing pulseaudio-esound-compat (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio-module-x11:
 pulseaudio-module-x11 depends on pulseaudio (= 1:0.9.19-0ubuntu4); however:
  Package pulseaudio is not configured yet.
dpkg: error processing pulseaudio-module-x11 (--configure):
 dependency problems - leaving unconfigured
Setting up xserver-xorg (1:7.4+3ubuntu7) ...
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
start: Unknown job: hal
invoke-rc.d: initscript hal, action "restart" failed.
dpkg: error processing xserver-xorg (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 pulseaudio
 pulseaudio-esound-compat
 pulseaudio-module-x11
 xserver-xorg
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@diux:/#


安装lightvncserver时的log:
代码:
root@diux:/# apt-get install tightvncserver
Reading package lists... Done
Building dependency tree... Done
tightvncserver is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Can not write log, openpty() failed (/dev/pts not mounted?)
Setting up pulseaudio (1:0.9.19-0ubuntu4) ...
invoke-rc.d: initscript pulseaudio, action "start" failed.
dpkg: error processing pulseaudio (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of pulseaudio-esound-compat:
 pulseaudio-esound-compat depends on pulseaudio (= 1:0.9.19-0ubuntu4); however:
  Package pulseaudio is not configured yet.
dpkg: error processing pulseaudio-esound-compat (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio-module-x11:
 pulseaudio-module-x11 depends on pulseaudio (= 1:0.9.19-0ubuntu4); however:
  Package pulseaudio is not configured yet.
dpkg: error processing pulseaudio-module-x11 (--configure):
 dependency problems - leaving unconfigured
Setting up xserver-xorg (1:7.4+3ubuntu7) ...
No apport report written because the error message indicates its a followup error from a previous failure.
No apport report written because the error message indicates its a followup error from a previous failure.
start: Unknown job: hal
invoke-rc.d: initscript hal, action "restart" failed.
dpkg: error processing xserver-xorg (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 pulseaudio
 pulseaudio-esound-compat
 pulseaudio-module-x11
 xserver-xorg
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@diux:/#


附件:
error_install_vncserver.png
error_install_vncserver.png [ 107.71 KiB | 被浏览 419 次 ]

error_install_lxde.png
error_install_lxde.png [ 93.51 KiB | 被浏览 419 次 ]



_________________
代码:
Think Pad Edge40
Ubuntu+Archlinux
http://aotee.com
QQ:361428088

我的“阿泉博客”,大家多多交流哦!
页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译