当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : UTUNTU 10.04下网络设置
帖子发表于 : 2010-08-18 9:48 

注册: 2010-08-18 9:33
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
在VM7下刚装了UBUNTU 10.04和FEDORA 13,不知道如何配置网络了,原来8.04时,XP下将VM设置成桥接,然后进入UBUNTU后找到网络连接选项,设置静态IP就可以了,现在10.04和FEDORA的网络选项是一样的都分有线,无线,PPP和IPV4等,不知道怎么配置了,SSID是什么?
我的环境是:XP 和 VM7
网络无线网卡可以上网,还有电信的无线网卡适配器装有SIM卡上网
目的:通过设置VM和UBUNTU等的网络设置,可以让UBUNTU和FEDORA能上外网,即使电信的那种无线网卡适配器加SIM卡方式不能允许2个机子(XP和VM)同时上网,至少可以通过物理的无线网卡通过无线局域网上外网

另2个问题:
1、FEDORA下安装VMTOOLS总是找不到GCC和LINUX的头路径等,导致安装失败,可以看到/MNT/HGFS目录,却看不到XP和VM共享的文件,而UBUNTU则很顺利HGFS驱动的很好
2、SSH问题,由于UBUNTU现在不能上网,无法安装SSH 和OPENSSH-SERVER,无法CRT访问,这可以理解,但FEDORA不是说已经包含了很多套件在内吗?怎么也无法SSH啊,CRT需要输入用户名和LINUX的IP,我不知道如我上述说的网络情况怎么能让CRT访问FEDORA。
我是菜鸟,请大家多指教!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: UTUNTU 10.04下网络设置
帖子发表于 : 2010-08-18 9:56 
头像

注册: 2008-07-06 20:04
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
这个一般将虚拟机的网卡设置为NAT方式就可以了 你要确定你xp系统的vmware nat 和 dhcp 这两个服务是启动的

至于ssh的问题 默认情况下fedora应该是启动的 登录不上去 应该是你ip地址不对 关键是你的机器要可以和fedora ping通就可以了 也就是你虚拟机的网卡的连接方式不对


_________________
OS:MoonOS
Browser: FF 3.6.17
微博:http://weibo.com/hackmyd


页首
 用户资料  
 
3 楼 
 文章标题 : Re: UTUNTU 10.04下网络设置
帖子发表于 : 2010-08-18 10:24 

注册: 2010-08-18 9:33
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
谢谢,我现在是打开VM后不管是运行UBUNTU还是FEDORA都提示ETH0有问题,但我不知道VM安装了之后不就可以驱动网卡了吗?还需要什么驱动?我试验了NAT方式也不行,还有在UBUNTU里我重新设置安装了宽带无线连接,也不行。
另外NAT方式的话,VM和XP是2个同一网段的独立IP吗?如果不是怎么PING通。大哥,能否告知你的QQ,小女子先谢谢!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: UTUNTU 10.04下网络设置
帖子发表于 : 2010-08-18 10:29 
头像

注册: 2008-07-06 20:04
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
我在linux下已经很少用qq了
看一下你的虚拟机的配置里面 网卡是不是连接了 然后在ubuntu 下手动启动试试看
ifup eth0
NAT的话 会和vmnet8这个网卡桥接的
你的vmware workstation 7 最好不要安装绿色版本的 :em02


_________________
OS:MoonOS
Browser: FF 3.6.17
微博:http://weibo.com/hackmyd


页首
 用户资料  
 
5 楼 
 文章标题 : Re: UTUNTU 10.04下网络设置
帖子发表于 : 2010-08-18 10:45 

注册: 2010-08-18 9:33
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我快晕死了,VM装的不是绿色版而是完全安装版,VM下设置网络适配器上电就连接,UBUNTU下手动IFUP ETH0结果说IGNORING UNKNOWN INTERFACE ETH0=ETH0,UBUNTU启动时就老提示EHT0不对,而且UBUNTU下IFCONFIG看不到IP地址。现在知道为什么很多人放弃LINUX了,这东西真的不好学,问题又多多


页首
 用户资料  
 
6 楼 
 文章标题 : Re: UTUNTU 10.04下网络设置
帖子发表于 : 2010-08-18 10:50 
头像

注册: 2008-07-06 20:04
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
我也无能为力了 你在虚拟机的配置里面将这个网卡删了 重新建立一个试试


_________________
OS:MoonOS
Browser: FF 3.6.17
微博:http://weibo.com/hackmyd


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译