当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我的电脑不能升级了!
帖子发表于 : 2010-09-02 13:04 
头像

注册: 2010-05-02 20:25
帖子: 330
地址: 柯伊伯带外奥尔特云内轨道与黄道错开的空间站里
送出感谢: 0 次
接收感谢: 0 次
引用:
不能够初始化软件包信息

初始化包信息时遇到无法解决的问题。

请汇报这个“update-manager”软件包的错误,并且将如下信息包含在报告中:

'E:动态 MMap 没有空间了。请增大 APT::Cache-Limit 的大小。当前值:25165824。(man 5 apt.conf), E:处理 minbif (NewVersion1)时出错, E:Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages, E:无法解析或打开软件包的列表或是状态文件。'

怎么办??
:em21 :em19 :em18 :em34 :em48 :em49 :em43


_________________
愿他们残酷,但是永远正义
愿恐惧永远不会主宰他们的行动并愿民族的荣誉在他们心中高于一切
最后,愿他们最终可以理解,为完成我们建立民族社会主义国家的任务,需要数百年时间并需要每一个人永远将共同的利益置于个人利益之上。
----希特勒绝笔
讨厌我的人可以试着点一下
讨厌我的人可以试着点一下2.0bate


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2010-09-02 13:10 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
换源试试?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2010-09-02 13:29 
头像

注册: 2010-05-02 20:25
帖子: 330
地址: 柯伊伯带外奥尔特云内轨道与黄道错开的空间站里
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
换源试试?

它说“空间不够“……


_________________
愿他们残酷,但是永远正义
愿恐惧永远不会主宰他们的行动并愿民族的荣誉在他们心中高于一切
最后,愿他们最终可以理解,为完成我们建立民族社会主义国家的任务,需要数百年时间并需要每一个人永远将共同的利益置于个人利益之上。
----希特勒绝笔
讨厌我的人可以试着点一下
讨厌我的人可以试着点一下2.0bate


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2010-09-02 14:06 
头像

注册: 2010-05-02 20:25
帖子: 330
地址: 柯伊伯带外奥尔特云内轨道与黄道错开的空间站里
送出感谢: 0 次
接收感谢: 0 次
搞定了 :em01 险些重装 :em02
引用:
装完ubuntu 10.04后就无法更新了,出现如下问题

E: 动态 MMap 没有空间了。请增大 APT::Cache-Limit 的大小。当前值:25165824。(man 5 apt.conf)

E: 处理 linux-headers-2.6.24-25 (NewVersion1)时出错

E: Problem with MergeList /var/lib/apt/lists/debian.ustc.edu.cn_ubuntu_dists_hardy-updates_main_binary-i386_Packages

E: 无法解析或打开软件包列表或状态文件。

E: _cache->open() failed, please report.



W: Unable to munmap



解决



系统里一般没有

apt.conf




文件,,,这个要新建,,,,,,
编辑 sudo gedit /etc/apt/apt.conf(如果没有apt.conf这个文件就新建一个)

在里面增加或者修改以下参数,把后面的数字尽量的调大即可,如果调大后重复出现该问题,继续增加数字即可



APT::Cache-Limit 99999999;


_________________
愿他们残酷,但是永远正义
愿恐惧永远不会主宰他们的行动并愿民族的荣誉在他们心中高于一切
最后,愿他们最终可以理解,为完成我们建立民族社会主义国家的任务,需要数百年时间并需要每一个人永远将共同的利益置于个人利益之上。
----希特勒绝笔
讨厌我的人可以试着点一下
讨厌我的人可以试着点一下2.0bate


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2010-09-02 14:09 
头像

注册: 2009-01-06 15:18
帖子: 13005
地址: 人间
送出感谢: 1
接收感谢: 24
apt 缓存。。?有嘛关系?给解释呗。


_________________
“有一种被人抛诸脑后的过去,包含一些不该遗忘的点点滴滴。欢笑之余,我将故旧拾起,才刹见自己的薄情。人世间似乎存在着某种公平,每个人都曾被抛掷在他人的遗忘中;而今你所有哽咽难宣的话语,也正是你曾为人所期盼,却永远听不见的字句。” —赫曼 赫塞


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2010-09-02 18:23 
头像

注册: 2010-05-02 20:25
帖子: 330
地址: 柯伊伯带外奥尔特云内轨道与黄道错开的空间站里
送出感谢: 0 次
接收感谢: 0 次
remeber Jiraiya 写道:
apt 缓存。。?有嘛关系?给解释呗。

不知道,只是照着做就可以了……


_________________
愿他们残酷,但是永远正义
愿恐惧永远不会主宰他们的行动并愿民族的荣誉在他们心中高于一切
最后,愿他们最终可以理解,为完成我们建立民族社会主义国家的任务,需要数百年时间并需要每一个人永远将共同的利益置于个人利益之上。
----希特勒绝笔
讨厌我的人可以试着点一下
讨厌我的人可以试着点一下2.0bate


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2010-09-02 18:28 

注册: 2010-08-30 10:26
帖子: 384
送出感谢: 0 次
接收感谢: 0 次
可能是指/var/cache/apt/archives的


_________________
我想死


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2010-09-02 21:33 

注册: 2008-10-08 22:01
帖子: 660
送出感谢: 0 次
接收感谢: 2
下多少东西呀?
把cache的limit都超过了
是你之前的东西没有clean掉的缘故吧


_________________
代码:
其实我是个Debian GNU/Linux用户

Octave script :http://forum.ubuntu.org.cn/viewtopic.php?f=35&t=254511
Octave中文:http://forum.ubuntu.org.cn/viewtopic.php?f=35&t=318969


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2010-09-03 7:59 

注册: 2010-09-03 7:57
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
sudo aptitude clean 就能清理缓存。
可以看看 aptitude help 或 man 5 apt.conf


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2011-09-18 20:45 

注册: 2010-04-28 14:17
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
一个比较好的方法就是将 /etc/apt/source.list 里面的东西全部给干掉,或者干脆就将里面的东西全部删了,如果你以前做过它的备份,那就用备份覆盖原来的 source.list ,要不然就从网上找一些源,手动加入到 source.list 中去,不过你得把以前的那些源给删了才行,那样一般能解决问题。。。。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2011-09-18 20:50 
头像

注册: 2009-10-16 22:46
帖子: 18958
地址: finland
送出感谢: 28
接收感谢: 48
ls啊
那是坟啊


_________________
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2011-09-18 20:54 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
我觉得10L和LZ说的完全没关系


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 我的电脑不能升级了!
帖子发表于 : 2011-09-19 16:50 

注册: 2010-04-28 14:17
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
昨天我没事的时候到网上找了一些主题,其中就找到一个有点像主题包的东西(该主题的地址在这:http://www.ubuntuhome.com/ubuntu-10-04-install-themes.html),里面有很多主题的那种,不过得加入了一个源。在这之前我用过 apt-spy 让系统自己到网上找最快的源(先备份了一下之前的163的源)。在下载这个主题包的时候由于网速太慢了,中断了一次,也不知道如果不中断会是什么情况,当再次启动,重新下载时,过一会儿就出现了:动态 MMap 没有空间了。请增大 APT::Cache-Limit 的大小。当前值:25165824。(man 5 apt.conf) 。。。。之类的错误,运行 sudo aptitude clean 没问题,运行 sudo aptitude autoclean 就又会出现前面的问题。后来到网上查找,然后试着将以前的备份的源恢复一下就没事了。。。。现在反正LZ也没什么好的方法,也没给出结论,也不妨试试看能不能解决问题。。。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Baidu [Spider] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译