当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]两个包互相依赖,无法删除,无法重装,无法升级!
帖子发表于 : 2010-09-04 12:31 
头像

注册: 2008-09-19 17:59
帖子: 172
送出感谢: 0 次
接收感谢: 0 次
升级的时候提示
代码:
meck@meck-laptop:/$ sudo apt-get dist-upgrade
[sudo] password for meck:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
您也许需要运行“apt-get -f install”来修正上面的错误。
下列软件包有未满足的依赖关系:
  language-pack-en: 依赖: language-pack-en-base (>= 1:10.04+20100422) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。

根据提示运行sudo apt-get -f install
代码:
meck@meck-laptop:/$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
正在更正依赖关系... 完成
下列软件包是自动安装的并且现在不需要了:
  lib32nss-mdns ttf-symbol-replacement winbind language-pack-en-base language-pack-en
使用'apt-get autoremove'来删除它们
将会安装下列额外的软件包:
  language-pack-en language-pack-en-base
建议安装的软件包:
  language-support-en
下列【新】软件包将被安装:
  language-pack-en-base
下列软件包将被升级:
  language-pack-en
升级了 1 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 87 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 898kB 的软件包。
解压缩后会消耗掉 5,218kB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://archive.ubuntu.com/ubuntu/ lucid-updates/main language-pack-en-base 1:10.04+20100714 [896kB]
获取:2 http://archive.ubuntu.com/ubuntu/ lucid-updates/main language-pack-en 1:10.04+20100714 [2,046B]
下载 898kB,耗时 3分 43秒 (4,016B/s)                                                               
dpkg:处理 language-pack-en (--remove)时出错:
 该软件包现在的状态极为不妥 - 您最好能
在删除它之前再重新安装一次。
在处理时有错误发生:
 language-pack-en
E: Sub-process /usr/bin/dpkg returned an error code (1)

OK,尝试把这两个包删掉,又出错,还是一样的提示.然后打开新立得想把这两个包的钩去掉不做升级,可是怎么也去不掉,现在搞得什么软件都装不了..实在太郁闷了,如果不能解决就打算重装系统了.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]两个包互相依赖,无法删除,无法重装,无法升级!
帖子发表于 : 2010-09-04 15:10 

注册: 2007-03-24 17:43
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
可怜的人啊 我当时是因为mplayer出现这个问题了 然后无奈 重装


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [求助]两个包互相依赖,无法删除,无法重装,无法升级!
帖子发表于 : 2010-09-04 20:16 
头像

注册: 2007-11-25 13:29
帖子: 7236
地址: 新疆博乐
系统: 14.04/16.04/Fedroa22
送出感谢: 37
接收感谢: 101
看看这篇能否有所帮助: viewtopic.php?f=77&t=213816


_________________
===新手请看===
Ubuntu 安装 | Ubuntu12.04/14.04/16.04 桌面操作指南
··Ubuntu16.04 安装图文教程(超简单)
····有时间就静下心来——折腾:)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [求助]两个包互相依赖,无法删除,无法重装,无法升级!
帖子发表于 : 2010-09-04 23:34 
头像

注册: 2008-09-19 17:59
帖子: 172
送出感谢: 0 次
接收感谢: 0 次
成功了!感谢楼上!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [求助]两个包互相依赖,无法删除,无法重装,无法升级!
帖子发表于 : 2010-09-04 23:36 
头像

注册: 2007-08-05 17:40
帖子: 4979
送出感谢: 0 次
接收感谢: 6
我感动的哭了。


_________________
free VPN
YouKuDownLoader
代码:
pip3 install ykdl

install YouKuDownLoader, have fun in downloading.
YouKuDownLoader所支持网站列表


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译