当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2010-09-20 18:48 

注册: 2009-12-07 22:46
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
打算安装ubuntu到一个ibm的服务器上,
目前服务器上有2块一样的scsi硬盘,2块一样的sata硬盘,各自组成raid 1
raid卡是ServeRAID M1015 SAS/SATA Controller
但是安装ubuntu时认不出硬盘来
应该是ubuntu没有相应的驱动
网上有人提供了一个驱动文件megaraid_sas.ko,见http://ubuntuforums.org/showthread.php?t=1507344
请问在安装ubuntu时怎么加载这个驱动文件呢?

另外有其他的解决办法吗?

谢谢先


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2010-09-20 18:52 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
不清楚...换个server版本试试看?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2010-09-20 19:05 

注册: 2009-12-07 22:46
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
不清楚...换个server版本试试看?

用的就是ubuntu的server版


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2010-09-20 22:02 

注册: 2009-12-07 22:46
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
安装过程中怎么才能加载raid驱动程序呢?
在线等


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2010-09-20 22:53 
头像

注册: 2009-09-22 17:00
帖子: 282
系统: arch , win10
送出感谢: 1
接收感谢: 0 次
google search 你的标题。。 :em06


_________________
目前已經全面轉移 至 洗发水神教


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2010-09-20 23:30 
头像

注册: 2006-09-10 22:36
帖子: 10669
地址: 北京
送出感谢: 1
接收感谢: 16
还是软raid好配一些,硬raid驱动就是恶梦


_________________
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2010-09-21 0:39 

注册: 2009-12-07 22:46
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
一个叫lechien73的人回答了在安装时加载驱动的方法,转贴如下(稍作了修改)
原文见我在ubuntuforums问的帖子 http://ubuntuforums.org/showthread.php?t=1578282

First you will need to copy the driver to a floppy disk or USB stick. During the text-based part of the installer, but before it starts to probe for hardware drivers, do the following:

* Press Ctrl-Alt-F2 to switch to a BusyBox prompt
* Insert the floppy that contains your driver file
* Type:

代码:
      mkdir /mnt/floppy
      mount /dev/fd0 /mnt/floppy
      cp /mnt/floppy/megaraid.ko  /lib/modules/2.6.32-24-generic/kernel/drivers/scsi/

**因为我是用usb disk的,所以我用的是如下代码(毕竟软盘很少了)
代码:
      mkdir /mnt/usb
      mount -t vfat /dev/sda1 /mnt/usb
      cp /mnt/usb/megaraid.ko  /lib/modules/2.6.32-24-generic/kernel/drivers/scsi/

**如果目录/lib/modules/2.6.32-24-generic/kernel/drivers/scsi/不存在,需要mkdir ...

* Press Ctrl-Alt-F1 to switch back to the installation, and allow the install to go ahead.

Note that the kernel version I have supplied in the 'cp' command (2.6.32-24-generic) may be different for your install. I have taken this from a stock Ubuntu Server 10.04.1 installation CD. To see what version you have, type:

代码:
uname -r


at the BusyBox prompt.

附带说明一下,以上的方法还没有测试是否有效,因为在安装ubuntu server时必须上网update,偏偏要装的这台机器还没法接入网络,崩溃


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2010-10-24 18:29 

注册: 2009-12-07 22:46
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
webappl 写道:
一个叫lechien73的人回答了在安装时加载驱动的方法,转贴如下(稍作了修改)
原文见我在ubuntuforums问的帖子 http://ubuntuforums.org/showthread.php?t=1578282

First you will need to copy the driver to a floppy disk or USB stick. During the text-based part of the installer, but before it starts to probe for hardware drivers, do the following:

* Press Ctrl-Alt-F2 to switch to a BusyBox prompt
* Insert the floppy that contains your driver file
* Type:

代码:
      mkdir /mnt/floppy
      mount /dev/fd0 /mnt/floppy
      cp /mnt/floppy/megaraid.ko  /lib/modules/2.6.32-24-generic/kernel/drivers/scsi/

**因为我是用usb disk的,所以我用的是如下代码(毕竟软盘很少了)
代码:
      mkdir /mnt/usb
      mount -t vfat /dev/sda1 /mnt/usb
      cp /mnt/usb/megaraid.ko  /lib/modules/2.6.32-24-generic/kernel/drivers/scsi/

**如果目录/lib/modules/2.6.32-24-generic/kernel/drivers/scsi/不存在,需要mkdir ...

* Press Ctrl-Alt-F1 to switch back to the installation, and allow the install to go ahead.

Note that the kernel version I have supplied in the 'cp' command (2.6.32-24-generic) may be different for your install. I have taken this from a stock Ubuntu Server 10.04.1 installation CD. To see what version you have, type:

代码:
uname -r


at the BusyBox prompt.

附带说明一下,以上的方法还没有测试是否有效,因为在安装ubuntu server时必须上网update,偏偏要装的这台机器还没法接入网络,崩溃


因为有人问我如何安装成功没有,因此特地说明一下
1. 如果要安装Ubuntu 10.04 LTS,必须要下载版本为10.04的ubuntu,而不是10.04.1
2. 到LSI的官方网站下载 MegaRAID SAS 9240-4i / 9240-8i针对ubuntu 10.04的驱动
3. 按照下载的驱动文件包里的readme进行安装(其实就是上面写的步骤)

另外,现在的10.10版本已经支持ibm ServeRAID m1015了


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 求助,Ubuntu 10.04安装时不识别raid1硬盘
帖子发表于 : 2014-08-25 19:49 

注册: 2014-08-22 19:32
帖子: 12
系统: ubuntu 14.04 LTS
送出感谢: 1
接收感谢: 0 次
Ubuntu 14.04 LTS 的LSI的版本针对的是哪个型号,谢谢!急需要用。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译