求助:终端不能update 不能apt-get install 用新立得软件包管理就行

系统安装、升级讨论
回复
zcy.85
帖子: 6
注册时间: 2010-09-28 9:16
送出感谢: 0
接收感谢: 0

求助:终端不能update 不能apt-get install 用新立得软件包管理就行

#1

帖子 zcy.85 » 2010-09-28 11:13

我用vmware 虚拟的ubuntu,终端sudo apt-get update 就出现
W: 无法下载 http://run.hit.edu.cn/ubuntu/dists/jaun ... Sources.gz 不能连接到 run.hit.edu.cn:http:
用sudo apt-get install gfortran 也是 无法下载。
但是用新立得软件包管理 搜索 gfortran 然后标记 应用 安装 就可以下载安装
这是为什么呢
头像
billzt
帖子: 1666
注册时间: 2010-05-23 20:44
系统: Ubuntu
送出感谢: 8 次
接收感谢: 22 次
联系:

Re: 求助:终端不能update 不能apt-get install 用新立得软件包管理就行

#2

帖子 billzt » 2010-09-30 9:28

你是不是添加了错误的软件源了?不到万不得已不要随便添加
师大生信者:http://bnuzhutao.cn
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 求助:终端不能update 不能apt-get install 用新立得软件包管理就行

#3

帖子 lainme » 2010-09-30 10:28

除了这个warming还有别的么?另外,有无任何代理设置。试一下别的源或者切换到ftp看看

莫非apt-get和synaptic手段有些不同……
zcy.85
帖子: 6
注册时间: 2010-09-28 9:16
送出感谢: 0
接收感谢: 0

Re: 求助:终端不能update 不能apt-get install 用新立得软件包管理就行

#4

帖子 zcy.85 » 2010-09-30 10:55

如果添加错软件源的话 新立得软件包管理也下载不了文件的,
除了warning 没有别的了 提示就是无法连接
我这是用代理上的网 在.bashrc 中加入export http_proxy=我们这代理的IP
反正终端是apt-get就不行
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 求助:终端不能update 不能apt-get install 用新立得软件包管理就行

#5

帖子 lainme » 2010-09-30 13:03

代理的问题,apt的话在.bashrc里export http_proxy没用。

方法一:

http://wiki.ubuntu.org.cn/UbuntuHelp:Ap ... 3.E7.90.86

看里面的第二种方法,即修改apt配置文件。

方法二:

代码: 全选

sudo export http_proxy=http://myuname:mypass@myproxy:myport
方法三:

将export http_proxy语句写道/etc/bash.bashrc里
回复

回到 “系统安装和升级”