当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 【已解决】无法安装任何软件,提示 'libgsm1' is missing final newline
帖子发表于 : 2010-10-01 9:36 
头像

注册: 2006-10-29 14:06
帖子: 152
送出感谢: 0 次
接收感谢: 0 次
可能与我一次断电退出有关系,在那之后,用 apt-get 或软件中心安装软件,无论安装什么软件,都出现类似下面的提示,但是都包含 'libgsm1' is missing final newline 。

不知道有哪位朋友可以提示一下,如何解决。谢谢。


具体提示如下
----------------

installArchives() failed: Selecting previously deselected package mc.

(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%dpkg: unrecoverable fatal error, aborting:

files list file for package 'libgsm1' is missing final newline


最后由 jfxwc 编辑于 2010-10-01 10:10,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 【已解决】无法安装任何软件,提示 'libgsm1' is missing final newline
帖子发表于 : 2010-10-01 10:01 
头像

注册: 2006-10-29 14:06
帖子: 152
送出感谢: 0 次
接收感谢: 0 次
自己解决了。记录一下解决方法。

方法
-----

1. 查找损坏的包,并 status 里移除他的信息。
命令行: sudo gedit /var/lib/dpkg/status

2. 重命名,备份原来的 info 目录
命令行: sudo mv /var/lib/dpkg/info /var/lib/dpkg/info_old

3. 建立一个空的 info 目录
命令行: sudo mkdir /var/lib/dpkg/info

4. 用 apt-get 更新
命令行: sudo apt-get update

5. 重新安装一下包
命令行: sudo apt-get -f install


OK , 问题解决。如果更新时出现其他相关的包有问题,按上面的方法逐一解决即可。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译