当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-14 21:29 

注册: 2010-10-04 16:14
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
从10.04升级到10.10后,不能进系统,提示:grub rescue
我用10.04的盘作为引导盘,进入终端,输入命令:
代码:
sudo apt-get install lilo
sudo lilo -M /dev/sda mbr

默认进入tty1,
但用户名和密码是什么啊?

再者:我按CTRL+ALT+F7切换后也停在那里,显示很多英文,但是键盘可以输入。我不知道输入什么才能进入图形界面。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-14 22:33 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
为什么要装lilo呢?
关键词:修复grub2


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-14 23:11 

注册: 2010-10-04 16:14
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
我也不想装,但是没有办法,我在百度试了这个方法可以,就装这个了。。

但现在的问题是进不了图形界面。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-14 23:30 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
不要百度!


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-14 23:32 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
引用:
mm@mm-desktop:~$ sudo -i (获取root权限
[sudo] password for mm:
root@mm-desktop:~# fdisk -l (查看ubuntu所在分区

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd012d012

Device Boot Start End Blocks Id System
/dev/sda1 * 1 510 4096543+ 7 HPFS/NTFS
/dev/sda2 1786 38913 298230629+ f W95 Ext'd (LBA)
/dev/sda3 511 1785 10240000 83 Linux (在这里,sda3。你的可能是2,3,4,5,6.。。自己改下
/dev/sda5 1786 14583 102799892 b W95 FAT32
/dev/sda6 14584 23803 74059600 7 HPFS/NTFS
/dev/sda7 23804 38913 121371043+ 7 HPFS/NTFS

Partition table entries are not in disk order
Note: sector size is 2048 (not 512)

Disk /dev/sdb: 3946 MB, 3946838016 bytes
64 heads, 32 sectors/track, 940 cylinders
Units = cylinders of 2048 * 2048 = 4194304 bytes
Sector size (logical/physical): 2048 bytes / 2048 bytes
I/O size (minimum/optimal): 2048 bytes / 2048 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdb1 1 941 3854326 b W95 FAT32
Partition 1 does not start on physical sector boundary.
root@mm-desktop:~# mount /dev/sda3 /mnt (把sda3挂载到/mnt
root@mm-desktop:~# grub-install --root-directory=/mnt/ /dev/sda (安装grub2到主硬盘


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-14 23:39 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
是用10.04的光盘启动


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 0:26 

注册: 2010-10-04 16:14
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
Thank you!
But it comes "you must specify the filesystem type" when I type :
代码:
mount /dev/sda2  /mnt


Here is more informatio:
代码:
 root@ubuntu:~# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3c97251d

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3825    30724281    c  W95 FAT32 (LBA)
/dev/sda2            3826       19457   125564040    f  W95 Ext'd (LBA)
/dev/sda5            3826        7650    30724281    b  W95 FAT32
/dev/sda6            7651       11474    30716248+   7  HPFS/NTFS
/dev/sda7           11475       15298    30716248+   7  HPFS/NTFS
/dev/sda8           15299       17848    20482843+   7  HPFS/NTFS
/dev/sda9           17849       19457    12924261    7  HPFS/NTFS
root@ubuntu:~# mount /dev/sda2  /mnt
mount: you must specify the filesystem type
root@ubuntu:~#


Could anyone can tell me why?
Ths a lot.


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 0:53 

注册: 2010-10-04 16:14
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
It 's OK.....
代码:
root@ubuntu:~# mount  /dev/sda9 /mnt
root@ubuntu:~# grub-install --root-directory=/mnt/ /dev/sda
Installation finished. No error reported.
root@ubuntu:~#


Problem is that I chose a wrong hdd no..
It should be sda9 on which Linux OP runs.


The following table lists some common 'System' types, which may help this process.
System name English name Linux type
W95 Ext'd (LBA) Microsoft extended partition Not used


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 7:43 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
我只看明白了两点:
1,你不会是wubi安装的吧
2,你的linux分区没有


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 8:14 

注册: 2010-10-04 16:14
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
answer:
1,你不会是wubi安装的吧: NO.
2,你的linux分区没有: 单独装在G盘的。

现在还是不能进啊
SOSO...............


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 8:22 

注册: 2010-10-04 16:14
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
以前好像用光盘装的10.04。
昨天更新10.10后就进不去了。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 8:27 
头像

注册: 2005-10-14 15:56
帖子: 1845
送出感谢: 0 次
接收感谢: 7
jerry200 写道:
answer:
1,你不会是wubi安装的吧: NO.
2,你的linux分区没有: 单独装在G盘的。

现在还是不能进啊
SOSO...............

fdisk -l的结果栗没有看到linux分区。
代码:
/dev/sda8           15299       17848    20482843+   7  HPFS/NTFS

这个?ntfs格式的?


_________________
yunio:又一个支持linux的云存储:链接 (非邀请链接)。
BCM4313驱动正常无法联网的解决:这里
plank:轻巧漂亮的dock 介绍在这里


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 8:36 

注册: 2010-10-04 16:14
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
/dev/sda9 17849 19457 12924261 7 HPFS/NTFS

我是根据12G的大小来判断的。
LINUX盘分了12G。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 11:34 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
能进windows不?
贴个boot.ini看看是不是wubi安装。
从你fdisk来看你没有linux分区
或许你遇到了和我一样的bug, :em06
我从10.04升级到10.10后在10.10里看不到其他分区,只有整个硬盘,
我用10.04光盘进去,能看到xp分区却看不到10.10的位置 :em09
用diskgen?重建分区表,检测10.10的那块分区表混乱,明明只有一个/分区,搞出2.8g,785m,1115g :em20
没办法,只好跳过10.10那块的检测,把剩余的分区都识别出来,重建分区表
重启,插入10.10的livecd安装,分区时检测到有10g的空白位置(其实就是我的10.10的/)


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 升级到10.10后,默认进入tty1,但用户名和密码是什么啊?
帖子发表于 : 2010-10-15 14:24 

注册: 2010-10-04 16:14
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
晕,是wubi安装的。。。这是我的boot.ini内容:

代码:
[boot loader]
timeout=2
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\wubildr.mbr = "Ubuntu"


那要怎么办?是不是要另寻他径?


PS:win XP当然也不能用了。
但是我用lilo后可以进XP了。

然后我选择 "ubuntu "OS,用“恢复模式”点那个failure X,可以进ubuntu,但是显卡驱动装不上。
所以我怀疑还是grub没有设置好。

。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译