ubuntu10.10更新后问题

系统安装、升级讨论
回复
fj2008
帖子: 5
注册时间: 2010-11-28 13:41
送出感谢: 0
接收感谢: 0

ubuntu10.10更新后问题

#1

帖子 fj2008 » 2010-11-28 13:50

今天更新了10.10,版本也更新了,但是更新后点击主文件和系统中的一些软件却(比如更新管理器和系统监控器等)没有反应,桌面上的图标也不见了,右击桌面也没有反应,在终端输入 sudo apt-get update 时提示:[sudo] password for fj:
apt-get: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by apt-get)
apt-get: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by apt-get)
apt-get: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libapt-pkg.so.4.10)
apt-get: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libapt-pkg.so.4.10)

小弟恳请哪位大虾帮帮忙呀。。。。不胜感激啊
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: ubuntu10.10更新后问题

#2

帖子 leeaman » 2010-11-28 13:55

这个悲剧看来不小啊,什么会这样呢,你更新了什么啊
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
fj2008
帖子: 5
注册时间: 2010-11-28 13:41
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10更新后问题

#3

帖子 fj2008 » 2010-11-28 14:02

leeaman 写了:这个悲剧看来不小啊,什么会这样呢,你更新了什么啊
我直接在更新管理器里面检查更新的呀,因为好久没更新了,今天中午下载更新了100多M,系统内核版本也更新了,我想可能就是这个内核版本更新引起的问题,纠结死我了
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: ubuntu10.10更新后问题

#4

帖子 leeaman » 2010-11-28 14:07

这么底层的东西出问题....我也不知道,帮顶了 :em01
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
fj2008
帖子: 5
注册时间: 2010-11-28 13:41
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10更新后问题

#5

帖子 fj2008 » 2010-11-28 14:14

leeaman 写了:这么底层的东西出问题....我也不知道,帮顶了 :em01
呵呵
感谢感谢
fj2008
帖子: 5
注册时间: 2010-11-28 13:41
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10更新后问题

#6

帖子 fj2008 » 2010-11-28 16:53

问题解决了
应给是库的问题
做了几个链接就OK了
有这个问题的朋友可以参考这个网址:http://www.jz123.cn/text/0333917.html
我是新手具体原因我也不是很清楚
fj2008
帖子: 5
注册时间: 2010-11-28 13:41
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10更新后问题

#7

帖子 fj2008 » 2010-11-28 16:57

问题解决了
我觉得应该就是那个库出了问题
有类似问题的朋友可以参考这个网址:http://www.jz123.cn/text/0333917.html
我是新手,具体原因也不是很清楚
希望知道问题的朋友给我解释解释吧
907169993
帖子: 93
注册时间: 2009-06-12 10:02
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10更新后问题

#8

帖子 907169993 » 2010-11-28 17:06

apt-get: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by apt-get)
apt-get: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by apt-get)
apt-get: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libapt-pkg.so.4.10)
apt-get: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libapt-pkg.so.4.10)

由于你更新时,你所选择的文件(可能)用到旧的库文件,函数库没有更新到量新,导致很多库文件没有安装!
楼主:你可以试着把上面那些“GLIBCXX_3.4.9”及11给安装上,sudo apt-get install XXXX, 这样libstdc++.so.6的库文件就能装上了!
装完后,如果桌面出不来,你可以在终端里打入:gconf-editor, 然后把桌面的图标勾选出来了!
回复

回到 “系统安装和升级”