About build-essential install

系统安装、升级讨论
回复
icegirl914
帖子: 19
注册时间: 2010-11-29 9:40
送出感谢: 0
接收感谢: 0

About build-essential install

#1

帖子 icegirl914 » 2010-12-08 14:23

qiulp@qiulp:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
将会安装下列额外的软件包:
dpkg-dev g++ g++-4.3 libstdc++6-4.3-dev patch
建议安装的软件包:
debian-keyring g++-multilib g++-4.3-multilib gcc-4.3-doc libstdc++6-4.3-dbg
libstdc++6-4.3-doc diff-doc
下列【新】软件包将被安装:
build-essential dpkg-dev g++ g++-4.3 libstdc++6-4.3-dev patch
共升级了 0 个软件包,新安装了 6 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 6096kB/6203kB 的软件包。
解压缩后会消耗掉 21.3MB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
libstdc++6-4.3-dev g++-4.3 g++ patch dpkg-dev build-essential
不经验证就安装这些软件包么?[y/N] y
错误 http://archive.ubuntu.com intrepid/main libstdc++6-4.3-dev 4.3.2-1ubuntu11
404 Not Found [IP: 91.189.88.45 80]
错误 http://archive.ubuntu.com intrepid/main g++-4.3 4.3.2-1ubuntu11
404 Not Found [IP: 91.189.88.45 80]
错误 http://archive.ubuntu.com intrepid/main g++ 4:4.3.1-1ubuntu2
404 Not Found [IP: 91.189.88.45 80]
错误 http://archive.ubuntu.com intrepid/main dpkg-dev 1.14.20ubuntu6
404 Not Found [IP: 91.189.88.45 80]
无法下载 http://archive.ubuntu.com/ubuntu/pool/m ... 1_i386.deb 404 Not Found [IP: 91.189.88.45 80]
无法下载 http://archive.ubuntu.com/ubuntu/pool/m ... 1_i386.deb 404 Not Found [IP: 91.189.88.45 80]
无法下载 http://archive.ubuntu.com/ubuntu/pool/m ... 2_i386.deb 404 Not Found [IP: 91.189.88.45 80]
无法下载 http://archive.ubuntu.com/ubuntu/pool/m ... u6_all.deb 404 Not Found [IP: 91.189.88.45 80]
E: 有几个软件包无法下载,您可以运行 apt-get update 或者加上 --fix-missing 的选项再试试?


請問 怎么会這樣? :em20
icegirl914
帖子: 19
注册时间: 2010-11-29 9:40
送出感谢: 0
接收感谢: 0

Re: About build-essential install

#2

帖子 icegirl914 » 2010-12-08 14:28

我试了sudo apt-get update,一大堆的忽略he错误 :em20
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: About build-essential install

#3

帖子 tenzu » 2010-12-08 14:40

换源
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: About build-essential install

#4

帖子 leeaman » 2010-12-08 15:42

你的是什么版本?似乎你的源是8.10的
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
rediscover
帖子: 3173
注册时间: 2010-01-13 23:26
送出感谢: 0
接收感谢: 12 次

Re: About build-essential install

#5

帖子 rediscover » 2010-12-08 19:10

干嘛用 8.10 呢。
Here I am.
Ubuntu 桌面培训 - 全中文官方文档,含汉化截图,提供PDF
icegirl914
帖子: 19
注册时间: 2010-11-29 9:40
送出感谢: 0
接收感谢: 0

Re: About build-essential install

#6

帖子 icegirl914 » 2010-12-09 9:34

是8.10的,因为手持机的厂家说要在他们的机器上二次开发需要用8.10版本的
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: About build-essential install

#7

帖子 leeaman » 2010-12-09 9:37

8.10没有源了,已经过了支持期,沟通看看用8.04或者10.04吧
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: About build-essential install

#8

帖子 tenzu » 2010-12-09 9:45

厂家也不知道选个LTS的
icegirl914
帖子: 19
注册时间: 2010-11-29 9:40
送出感谢: 0
接收感谢: 0

Re: About build-essential install

#9

帖子 icegirl914 » 2010-12-09 9:53

:em01 谢谢
回复

回到 “系统安装和升级”