菜鸟求助:安装xp和ubuntu10.10启动出现问题

系统安装、升级讨论
回复
头像
不肯嫁春风
帖子: 11
注册时间: 2010-12-13 16:32
送出感谢: 0
接收感谢: 0
联系:

菜鸟求助:安装xp和ubuntu10.10启动出现问题

#1

帖子 不肯嫁春风 » 2010-12-13 16:38

看到网上的教程,从ubuntu的iso文件中提取Casper下的vmlinuz和initrd.gz两个文件到某个盘的根目录下。我选择的是D盘,D盘是ntfs格式的。但是我现在下载的是10.10的镜像,Casper文件夹里面的是tinitrd.gz文件,而不是initrd.gz。于是把menu.lst中的代码改成了:
title Install Ubuntu
find --set-root /ubuntu-10.10-dvd-i386.iso
kernel /vmlinuz boot=casper iso-scan/filename=/ubuntu-10.10-dvd-i386.iso locale=zh_CN.UTF-8
initrd /initrd.lz

但是启动时却只有Windows XP和深度一键还原的选项,没有进入grldr4dos界面安装ubuntu的选项,怎么回事??grub4dos的grldr文件已经把放到C盘根目录了啊,难道是放grldr.mbr?grldr.mbr和grldr有何区别?还有boot.ini我已经改成:
[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
c:\grldr="ubuntu"

我已经把ubuntu的iso文件,vmlinuz和initrd.lz也已经在D盘根目录了,到底哪里有问题? :em20
Billyx
帖子: 71
注册时间: 2010-06-08 1:48
送出感谢: 1 次
接收感谢: 1 次

Re: 菜鸟求助:安装xp和ubuntu10.10启动出现问题

#2

帖子 Billyx » 2010-12-13 16:55

:em06 我也是新丁,具体分析一下,你现在是在启动xp的过程中就根本没有进入grub的选项,所以应该选查boot.ini的问题,然后如果在安装过程中出错再考虑menu.lst会不会有错。另外如果把这行
find --set-root /ubuntu-10.10-dvd-i386.iso
直接指定你的iso所在分区不是更快吗?
头像
peteryeh64
论坛版主
帖子: 9349
注册时间: 2008-12-20 15:43
系统: 家14.04,公司14.04
来自: 心靈深處
送出感谢: 12 次
接收感谢: 36 次

Re: 菜鸟求助:安装xp和ubuntu10.10启动出现问题

#3

帖子 peteryeh64 » 2010-12-13 16:57

但是我现在下载的是10.10的镜像,Casper文件夹里面的是tinitrd.gz文件,而不是initrd.gz

title Install Ubuntu
find --set-root /ubuntu-10.10-dvd-i386.iso
kernel /vmlinuz boot=casper iso-scan/filename=/ubuntu-10.10-dvd-i386.iso locale=zh_CN.UTF-8
initrd /initrd.lz
[论坛版主行为规定]+[PITIVI簡易教程]+[CAD裝draftsight]+[酷我音乐裝kwplayer]+[ubuntu裝迅雷]
[releases.ubuntu.com]+[cdimage.ubuntu.com]+[old-releases.ubuntu.com]
[學ubuntu必須拜讀懶蝸牛"笨兔兔的故事"=viewtopic.php?f=112&t=162040][Linux明日的希望在中國]
Billyx
帖子: 71
注册时间: 2010-06-08 1:48
送出感谢: 1 次
接收感谢: 1 次

Re: 菜鸟求助:安装xp和ubuntu10.10启动出现问题

#4

帖子 Billyx » 2010-12-13 17:01

我的也是10.10,CD版的live-CD ISO文件,解压后还是initrd.lz,我是启动到grub 2 loopac 再安装的。目前没有遇到问题,你下载的是哪个版的iso文件?
头像
不肯嫁春风
帖子: 11
注册时间: 2010-12-13 16:32
送出感谢: 0
接收感谢: 0
联系:

Re: 菜鸟求助:安装xp和ubuntu10.10启动出现问题

#5

帖子 不肯嫁春风 » 2010-12-13 17:11

Billyx 写了:我的也是10.10,CD版的live-CD ISO文件,解压后还是initrd.lz,我是启动到grub 2 loopac 再安装的。目前没有遇到问题,你下载的是哪个版的iso文件?
是10.10dvd版的,4G多
头像
不肯嫁春风
帖子: 11
注册时间: 2010-12-13 16:32
送出感谢: 0
接收感谢: 0
联系:

Re: 菜鸟求助:安装xp和ubuntu10.10启动出现问题

#6

帖子 不肯嫁春风 » 2010-12-13 17:41

找到问题啦!!原来是我把boot.ini.backup看成boot.ini了 :em20

但是进入grub4dos怎么乱码啊???
Billyx
帖子: 71
注册时间: 2010-06-08 1:48
送出感谢: 1 次
接收感谢: 1 次

Re: 菜鸟求助:安装xp和ubuntu10.10启动出现问题

#7

帖子 Billyx » 2010-12-13 18:33

SORRRY,我刚才和同事聚会去了,grub4dos乱码,会不会是中文的原因?也可能是utf-8的原因,不过我硬盘安装没有遇到这个情况,你现在可以正常安装吗?
头像
不肯嫁春风
帖子: 11
注册时间: 2010-12-13 16:32
送出感谢: 0
接收感谢: 0
联系:

Re: 菜鸟求助:安装xp和ubuntu10.10启动出现问题

#8

帖子 不肯嫁春风 » 2010-12-15 17:24

Billyx 写了:SORRRY,我刚才和同事聚会去了,grub4dos乱码,会不会是中文的原因?也可能是utf-8的原因,不过我硬盘安装没有遇到这个情况,你现在可以正常安装吗?
这个也找到原因了,我把grub4dos里面的Chinese的grldr放到D盘就好了,应该是版本问题
回复

回到 “系统安装和升级”