当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 急死我了,大家帮帮忙吧
帖子发表于 : 2011-01-12 20:23 

注册: 2011-01-10 20:18
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我在XP下硬盘安装Ubuntu10.4 安到最后已经成功了,,然后提示我重启


但是重启后为什么在启动项里还是只有安装时候的启动项,进这个启动项还是安装的,,为什么没有安装成功之后的启动项啊,,,

附件:
文件注释: C盘根目录放的文件
1.jpg
1.jpg [ 19.1 KiB | 被浏览 398 次 ]




menu.lst代码:
title Install Ubuntu

root (hd0,0)

kernel /vmlinuz boot=casper iso-scan/filename=/ubuntu-10.04.1-desktop-i386.iso quiet splash ro locale=zh_CN.UTF-8 noprompt --

initrd /initrd.lz


boot代码:
[boot loader]
timeout=3
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
c:\grldr="Install Ubuntu"


最后由 chutianruo 编辑于 2011-01-12 20:55,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 急死我了,大家帮帮忙吧
帖子发表于 : 2011-01-12 20:43 

注册: 2008-05-03 23:42
帖子: 3681
送出感谢: 4
接收感谢: 7
grub 装哪儿了


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 急死我了,大家帮帮忙吧
帖子发表于 : 2011-01-12 20:44 
头像

注册: 2010-07-02 21:47
帖子: 476
送出感谢: 0 次
接收感谢: 0 次
wubi?


_________________
对系统:更加了解; 对软件:更强,更新,更有趣

ubuntu--arch--gentoo

vim(latex-suit),tex(xelatex,metapost),zim,chromium,virtualbox,awk......


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 急死我了,大家帮帮忙吧
帖子发表于 : 2011-01-12 20:51 

注册: 2011-01-10 20:18
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
呃,,装grub?? 我只把grldr转到C盘根目录啊


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 急死我了,大家帮帮忙吧
帖子发表于 : 2011-01-12 21:01 

注册: 2006-11-10 0:34
帖子: 127
送出感谢: 0 次
接收感谢: 5
你安装ubuntu时,最后一步有没有安装Boot Loader?


如果没有
开机进入 Install Ubuntu 之后,就是livecd
然后参考这里用方法一,安装grub2
viewtopic.php?f=139&t=289132&start=0


如果有,这样试试,进入xp,修改menu.lst,添加如下4行
代码:
title Ubuntu 10.04 LTS
find --set-root /boot/grub/core.img
kernel /boot/grub/core.img
boot


最后由 cheron 编辑于 2011-01-12 21:34,总共编辑了 2 次

页首
 用户资料  
 
6 楼 
 文章标题 : Re: 急死我了,大家帮帮忙吧
帖子发表于 : 2011-01-12 21:23 
头像

注册: 2009-09-06 5:53
帖子: 4666
送出感谢: 6
接收感谢: 110
没有安装grub应该没有core.img这个文件。
看smallapple启动引导版置顶贴:2)用livecd修复grub


_________________
电子书下载:
鸟哥的Linux私房菜 基础学习篇 第三版 pdf
鸟哥的Linux私房菜 服务器架设篇 第三版 pdf


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 急死我了,大家帮帮忙吧
帖子发表于 : 2011-01-15 15:21 

注册: 2011-01-14 11:45
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
title Ubuntu 10.04 LTS
find --set-root /boot/grub/core.img
kernel /boot/grub/core.img
boot


运行后提示没有core.img.

但是livecd进去后,gurb里面有这个文件。试了很多方法,还是进不到ubuntu。就是wubi方式的能行,可是开机很慢很慢。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 急死我了,大家帮帮忙吧
帖子发表于 : 2011-01-15 21:59 
头像

注册: 2007-12-14 13:40
帖子: 49877
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 413
weric_2004 写道:
title Ubuntu 10.04 LTS
find --set-root /boot/grub/core.img
kernel /boot/grub/core.img
boot


运行后提示没有core.img.

但是livecd进去后,gurb里面有这个文件。试了很多方法,还是进不到ubuntu。就是wubi方式的能行,可是开机很慢很慢。


你的/boot 是不是单独分的?
如果是单独分的,就把5楼代码里的/boot删掉 再试
还有liveCD 里看到的是光盘里的还是你安装ubuntu的分区里的?


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
cron
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译