当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,win7和ubuntu双系统出现奇怪问题???
帖子发表于 : 2011-01-27 16:49 

注册: 2010-12-25 11:19
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
小弟的情况是这样的,联想F31笔记本,原来是win7专业版,有CDEFGHK这几个分区,今天我在K盘上U盘安装了ubuntu10.10,出现以下问题:
1、开机有时能启动,正常进入grub引导菜单并且进入ubuntu,但有时是刚显示开机画面就关机,等上一会再开机,往往一切正常
2、如果幸运地进入grub引导菜单,选择win7,蓝屏
补充一点,装ubuntu的时候引导程序选择了/dev/sda,另外,之前用wubi安装也是这个情况,最奇怪的就是有时能开机,一切正常,有时不行,请教各位大虾,指点下小弟,多谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助,win7和ubuntu双系统出现奇怪问题???
帖子发表于 : 2011-01-27 17:04 
头像

注册: 2009-09-06 5:53
帖子: 4666
送出感谢: 6
接收感谢: 110
试试改CMOS设置

或者退回到grub1试试(启动引导版smapple grub2教程有,如果是wubi就不要试了。)


_________________
电子书下载:
鸟哥的Linux私房菜 基础学习篇 第三版 pdf
鸟哥的Linux私房菜 服务器架设篇 第三版 pdf


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助,win7和ubuntu双系统出现奇怪问题???
帖子发表于 : 2011-01-27 17:16 

注册: 2010-12-25 11:19
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我之前是用wubi装过,就是出现有时正常,有时不正常的情况,我以为是wubi的原因,所以今天就改用U盘安装,问题依旧,而且连win7都进不了了,请问CMOS的设置可以讲具体点吗,我不懂这个,谢谢


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助,win7和ubuntu双系统出现奇怪问题???
帖子发表于 : 2011-01-27 17:44 

注册: 2010-12-25 11:19
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
刚试了一下,BIOS里好像也没啥可设置的,只有一个硬盘模式,原来是兼容模式,我改成了SATA模式,打开了AHCI,不过重启之后还是老样子,启动几次才可能成功一次……


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助,win7和ubuntu双系统出现奇怪问题???
帖子发表于 : 2011-01-27 18:07 
头像

注册: 2009-09-06 5:53
帖子: 4666
送出感谢: 6
接收感谢: 110
我没有安装win7,你在网上google。

一个是你退回到grub1再试试。
另一个是重写ms的mbr,看smallapple置顶贴用grub4dos引导ubuntu。


_________________
电子书下载:
鸟哥的Linux私房菜 基础学习篇 第三版 pdf
鸟哥的Linux私房菜 服务器架设篇 第三版 pdf


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助,win7和ubuntu双系统出现奇怪问题???
帖子发表于 : 2011-01-27 21:57 

注册: 2010-12-25 11:19
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
非常感谢,通过改回grub1解决第一个问题,但是win7还是蓝屏,请问这个怎么解决?


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助,win7和ubuntu双系统出现奇怪问题???
帖子发表于 : 2011-01-27 22:25 
头像

注册: 2009-09-06 5:53
帖子: 4666
送出感谢: 6
接收感谢: 110
http://www.win7china.com/html/10059.html
http://support.microsoft.com/kb/972602/zh-cn
重写ms的mbr,看蓝屏是不是只与win7有关,要在网上搜解决办法。
引用:
插入windows 7安装光盘,从光盘启动电脑,在光盘启动完成后,按下shift+f10键,调出cmd命令提示符。在cmd命令提示符中输入:bootrec /fixmbr回车。


win7没问题了,看smallapple置顶贴用grub4dos引导ubuntu。


_________________
电子书下载:
鸟哥的Linux私房菜 基础学习篇 第三版 pdf
鸟哥的Linux私房菜 服务器架设篇 第三版 pdf


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助,win7和ubuntu双系统出现奇怪问题???
帖子发表于 : 2011-01-28 13:15 
头像

注册: 2010-09-19 23:08
帖子: 256
送出感谢: 0 次
接收感谢: 0 次
关于瘟都死蓝屏,可能你的Windows 7 是在IDE 模式下安装的,BIOS可能会莫名奇妙的因为某些原因把磁盘变成AHCI模式,Windows 系统启动当然蓝屏。(如果在AHCI模式安装的Windows,启动不会蓝屏)。既然你是在插屁(XP)系统下安装的 7 ,很可能是使用了IDE模式。
推荐检查BIOS设置,最好使用光盘安装正版。在AHCI模式下安装,完成后,会发现,使用AHCI会比IDE快20%左右。
关于无法正常引导GRUB启动菜单,可能是你分区太复杂了把。。。 还有,UBUNTU最好安装在主分区里。否则,在瘟都死系统里操作磁盘分区(改变大小,添加删除卷等)会导致彻底无法引导系统和丢失磁盘数据。


_________________
UBUNTU让人感觉很亲切.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译