当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 意外终止升级后,更新管理器出错不能升级怎么办?
帖子发表于 : 2011-02-21 16:39 

注册: 2011-02-20 9:42
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
ubuntu10.04升级到10.10的时候,觉得速度太慢,就终止升级,然后更换了源
再次打开更新管理器升级的时候,发生错误
无法计算更新
在计算升级时遇到一个无法解决的问题。
请汇报这个有关 'update-manager' 的错误,并且将下列错误信息包含在错误报告中:
'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
'

按照网上的方法删掉 lock文件(sudo rm -f /var/lib/apt/lists/lock)
运行了一下,又再次出现了这个问题,并且/var/lib/apt/lists文件夹中再次出现lock文件
多次删除 没有效果。。。
求各位高手帮忙~


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 意外终止升级后,更新管理器出错不能升级怎么办?
帖子发表于 : 2011-02-21 23:07 

注册: 2005-09-27 10:32
帖子: 702
送出感谢: 0 次
接收感谢: 0 次
这个问题很重要,一定要坚持住,把它解决掉!

等你的好消息。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 意外终止升级后,更新管理器出错不能升级怎么办?
帖子发表于 : 2011-02-22 10:00 

注册: 2009-03-26 16:26
帖子: 55
送出感谢: 0 次
接收感谢: 1
試試指令看結果如何,

sudo dpkg --configure -a


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译