mplayer无界面

系统安装、升级讨论
回复
lwqnxq
帖子: 7
注册时间: 2011-02-25 23:51
送出感谢: 0
接收感谢: 0

mplayer无界面

#1

帖子 lwqnxq » 2011-02-25 23:53

系统:Fedora-14_x86_64 桌面 gnome-2.32

在mplayer官网下载了源码和解码器包..编译安装后播放视频有声音,但没界面出来..
在控制台下播放xixi.avi文件
$mplayer xixi.avi 其提示如下:

MPlayer SVN-r32829-4.5.1 (C) 2000-2011 MPlayer Team

Playing xixi.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO: [XVID] 720x400 24bpp 29.970 fps 1916.5 kbps (233.9 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2540/release)
Load subtitles in ./
Can't open /dev/fb0: Permission denied
[fbdev2] Can't open /dev/fb0: Permission denied
VO: [v4l2] No such file or directory
vo_cvidix: No vidix driver name provided, probing available ones (-v option for details)!
[nvidia_vid] Error occurred during pci scan: Operation not permitted
[VO_SUB_VIDIX] Couldn't find working VIDIX driver.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 96.0 kbit/6.80% (ratio: 12000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0xc65200]Invalid and inefficient vfw-avi packed B frames detected
Movie-Aspect is 1.80:1 - prescaling to correct movie aspect.
VO: [null] 720x400 => 720x400 Planar YV12

解码器都是正常的..就是没有图形输出界面..是不是缺少哪个图形库呢..
渴望大家的帮助,谢谢..
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: mplayer无界面

#2

帖子 eexpress » 2011-02-26 0:34

Can't open /dev/fb0: Permission denied
tty下?这文件没权限,或者根本没这文件吧。这是framebuffer的设备文件啊。
确定安装了fb。
另外,id看下,自己在video组不。
● 鸣学
lwqnxq
帖子: 7
注册时间: 2011-02-25 23:51
送出感谢: 0
接收感谢: 0

Re: mplayer无界面

#3

帖子 lwqnxq » 2011-02-26 10:49

eexpress 写了:Can't open /dev/fb0: Permission denied
tty下?这文件没权限,或者根本没这文件吧。这是framebuffer的设备文件啊。
确定安装了fb。
另外,id看下,自己在video组不。
我在配置configure 没有使用--enable-gui 选项, 因为那需要更多的依赖,所以只能在命令行下使用,以前在KDE环境下也成功安装过,并且能正常使用,昨晚折腾了一整晚,后来发现跟权限有一些关系,
当我cd /usr/local/bin 然后sudo ./mplayer XXX.avi 文件的时候,就有画面出来了,但是没有一个小方框跳出来,面是整个桌面都黑屏啦,只是左上角出现视频画面,按F键不能缩放,按Q键也不能退出.只是停止播放.按方向键调整进度的时候画面上也没有进度条显示,虽然可以调整进度,应该是少装了哪个图形开发库,但我不知道是哪个?
还有一个其怪的地方是为什么 sudo mplayer XXX.avi 却提示找不到命令呢?? root的环境变量路径是有/usr/local/bin 这个路径的..
thorne
帖子: 660
注册时间: 2008-10-08 22:01
送出感谢: 0
接收感谢: 2 次

Re: mplayer无界面

#4

帖子 thorne » 2011-02-26 12:31

mplayer -vo fbdev xx.ai

代码: 全选

其实我是个Debian GNU/Linux用户
Octave script :http://forum.ubuntu.org.cn/viewtopic.php?f=35&t=254511
Octave中文:http://forum.ubuntu.org.cn/viewtopic.php?f=35&t=318969
xep007
帖子: 870
注册时间: 2006-01-03 20:44
送出感谢: 0
接收感谢: 6 次

Re: mplayer无界面

#5

帖子 xep007 » 2011-02-26 13:06

mplayer -vo help看看支持什么格式,选一个试试,不行的话,一个个试。
lwqnxq
帖子: 7
注册时间: 2011-02-25 23:51
送出感谢: 0
接收感谢: 0

Re: mplayer无界面

#6

帖子 lwqnxq » 2011-02-26 14:20

现在好啦,确实是少了图形库文件,在yum上面安装gtk+ 和zlib 几个devel包后再编译安装mplayer就正常了..
回复

回到 “系统安装和升级”