postfix bsd-mailx出错

系统安装、升级讨论
回复
darouwan
帖子: 102
注册时间: 2008-03-08 8:45
送出感谢: 0
接收感谢: 0
联系:

postfix bsd-mailx出错

#1

帖子 darouwan » 2011-03-01 9:01

在安装mysql的时候发现的问题,开始以为只是mysql的问题,然后去安装sqlite,结果发现还是相同的错误提示!这时候意识到可能是系统里面的故障。下面是部分代码

代码: 全选

正在设置 postfix (2.7.1-1) ...
update-rc.d: /etc/init.d/postfix: file does not exist
dpkg:处理 postfix (--configure)时出错:
 子进程 已安装 post-installation 脚本 返回了错误号 1
dpkg:依赖关系问题使得 bsd-mailx 的配置工作不能继续:
 bsd-mailx 依赖于 default-mta | mail-transport-agent;然而:
  未安装软件包“default-mta”。
  软件包 postfix 提供了 default-mta,但它尚未被配置。
  未安装软件包“mail-transport-agent”。
  软件包 postfix 提供了 mail-transport-agent,但它尚未被配置。
dpkg:处理 bsd-mailx (--configure)时出错:
 依赖关系问题 - 仍未被配置
因为错误消息指示这是由于上一个问题导致的错误,没有写入 apport 报告。
                                                                    正在处理用于 libc-bin 的触发器...
ldconfig deferred processing now taking place
在处理时有错误发生:
 postfix
 bsd-mailx
E: Sub-process /usr/bin/dpkg returned an error code (1)
我该怎么修复呢?
darouwan
帖子: 102
注册时间: 2008-03-08 8:45
送出感谢: 0
接收感谢: 0
联系:

Re: postfix bsd-mailx出错

#2

帖子 darouwan » 2011-03-09 6:31

没有人~~
回复

回到 “系统安装和升级”