重启后网络不通的问题,急!!!

系统安装、升级讨论
回复
Motorcure
帖子: 13
注册时间: 2011-03-29 14:57
送出感谢: 0
接收感谢: 0

重启后网络不通的问题,急!!!

#1

帖子 Motorcure » 2011-04-01 16:54

10.10的Server版,局域网环境下,重启后网络正常,但是使用静态公网IP后,重启后就不能ping通网关,关机后再开机貌似正常,这个是什么原因

/etc/network/interfaces文件内容如下

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address x.x.x.x
netmask x.x.x.x
gateway x.x.x.x
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 202.101.172.35
dns-search 10
Motorcure
帖子: 13
注册时间: 2011-03-29 14:57
送出感谢: 0
接收感谢: 0

Re: 重启后网络不通的问题,急!!!

#2

帖子 Motorcure » 2011-04-01 18:57

顶上去,大家帮帮忙啊
Motorcure
帖子: 13
注册时间: 2011-03-29 14:57
送出感谢: 0
接收感谢: 0

Re: 重启后网络不通的问题,急!!!

#3

帖子 Motorcure » 2011-04-01 19:46

顶上去,大家帮帮忙啊
nodig
帖子: 122
注册时间: 2010-07-24 23:35
送出感谢: 1 次
接收感谢: 0

Re: 重启后网络不通的问题,急!!!

#4

帖子 nodig » 2011-04-01 19:53

网络联接里把eth0删了试试。
Motorcure
帖子: 13
注册时间: 2011-03-29 14:57
送出感谢: 0
接收感谢: 0

Re: 重启后网络不通的问题,急!!!

#5

帖子 Motorcure » 2011-04-01 20:09

eth0删了还怎么可能联上网???
Motorcure
帖子: 13
注册时间: 2011-03-29 14:57
送出感谢: 0
接收感谢: 0

Re: 重启后网络不通的问题,急!!!

#6

帖子 Motorcure » 2011-04-02 8:18

顶上去,大家帮帮忙啊
youdon
帖子: 2
注册时间: 2007-08-01 16:00
送出感谢: 0
接收感谢: 0

Re: 重启后网络不通的问题,急!!!

#7

帖子 youdon » 2011-04-08 7:05

今天安装Ubuntu 10.10也遇到同样的问题。
把network manager给删了,再设定/etc/network/interfaces就可以
> sudo apt-get purge network-manager network-manager-gnome
sdzzg
帖子: 308
注册时间: 2008-05-30 16:22
送出感谢: 0
接收感谢: 0

Re: 重启后网络不通的问题,急!!!

#8

帖子 sdzzg » 2011-04-08 11:20

nm和那个interface有冲突的啊,不要同时用
回复

回到 “系统安装和升级”