当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我的ubuntu 10.10软件包依赖出问题了,如何修复?
帖子发表于 : 2011-04-20 18:03 
头像

注册: 2010-08-09 15:52
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
软件包依赖错误是deepin-wine-tm2009的软件bug造成的,这个软件我在新立得里删除不掉,结果啥软件也装不了!现想知道除了重装之外,还又没有别的解决之道?





lenovo@hp-pc:~$ sudo apt-get check
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您也许需要运行“apt-get -f install”来修正上面的错误。
下列软件包有未满足的依赖关系:
deepin-wine-tm2009 : 依赖: deepin-wine-lib (>= 1.0) 但无法安装它
依赖: deepin-wine-run (>= 1.0) 但无法安装它
E: 不能满足依赖关系。不妨试一下 -f 选项。


_________________
啥时候ubuntu能装好直接就能使用了,ubuntu就成功了!折腾不是所有人都有时间和兴趣!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 我的ubuntu 10.10软件包依赖出问题了,如何修复?
帖子发表于 : 2011-04-20 18:09 
头像

注册: 2010-08-09 15:52
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
lenovo@hp-pc:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
下列软件包是自动安装的并且现在不需要了:
ttf-umefont wine1.2 libcdt4 icoutils netpbm wine ttf-symbol-replacement
libgvc5 wine1.2-gecko libxdot4 libmagickcore3-extra libmpg123-0 libnetpbm10
imagemagick libgraph4 winbind gnome-exe-thumbnailer libpathplan4
使用'apt-get autoremove'来卸载它们
下列软件包将被【卸载】:
deepin-wine-tm2009
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 68 个软件包未被升级。
解压缩后将会空出 24.5MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 154180 个文件和目录。)
正在卸载 deepin-wine-tm2009 ...
sudo: /usr/share/deepin-wine/TM2009/unreg.sh: command not found
dpkg:处理 deepin-wine-tm2009 (--remove)时出错:
子进程 已安装 pre-removal 脚本 返回了错误号 1
在处理时有错误发生:
deepin-wine-tm2009
E: Sub-process /usr/bin/dpkg returned an error code (1)


_________________
啥时候ubuntu能装好直接就能使用了,ubuntu就成功了!折腾不是所有人都有时间和兴趣!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 我的ubuntu 10.10软件包依赖出问题了,如何修复?
帖子发表于 : 2011-04-20 19:18 
头像

注册: 2010-02-21 16:19
帖子: 434
地址: 大连
送出感谢: 1
接收感谢: 2
不懂。
帮顶。


_________________
大连Linux User Group: http://groups.google.com/group/dalian-lug?hl=zh-CN


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 我的ubuntu 10.10软件包依赖出问题了,如何修复?
帖子发表于 : 2011-05-14 14:02 
头像

注册: 2008-03-09 22:32
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我也碰到了同样的问题,有解决方法吗


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 我的ubuntu 10.10软件包依赖出问题了,如何修复?
帖子发表于 : 2011-05-14 14:38 
头像

注册: 2008-03-09 22:32
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我自己解决了,你可以把deepin-wine-tm2009的deb包解压,然后拷贝里面的目录TM2009拷贝到/usr/share/deepin-wine里面,然后再按正常的方式卸载就可以了。我是用peazip解压的


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 我的ubuntu 10.10软件包依赖出问题了,如何修复?
帖子发表于 : 2011-05-14 14:46 
头像

注册: 2008-04-26 12:41
帖子: 11000
送出感谢: 11
接收感谢: 38
向deepin-wine开发团队报bug :em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译