【求助】关于三系统启动问题 hal.dll丢失

系统安装、升级讨论
回复
jacob2019
帖子: 2
注册时间: 2010-11-03 11:41
送出感谢: 0
接收感谢: 0

【求助】关于三系统启动问题 hal.dll丢失

#1

帖子 jacob2019 » 2011-05-03 15:10

我电脑分盘情况:
C盘:WIN7(第一个安装)
H盘:XP(第二个安装)
接下来通过LIVE CD安装了11.04 ,开机启动grub引导ubuntu11.04 ;win7;win xp。
现状是:win7启动正确,ubuntu也启动正确,XP启动时提示 错误 无法进入
选择win7启动后,里面还有一层选择:win7;winxp,点WIN7启动正常,点XP启动提示HAL.DLL文件丢失。


问题就是这些,希望大家帮我解决这个问题,让三系统都启动正常。
jacob2019
帖子: 2
注册时间: 2010-11-03 11:41
送出感谢: 0
接收感谢: 0

Re: 【求助】关于三系统启动问题 hal.dll丢失

#2

帖子 jacob2019 » 2011-05-03 16:16

没有人帮我吗??? :em20 :em20
头像
gbcwbz
帖子: 297
注册时间: 2009-05-09 14:58
来自: 江苏
送出感谢: 0
接收感谢: 0

Re: 【求助】关于三系统启动问题 hal.dll丢失

#3

帖子 gbcwbz » 2011-05-03 19:24

http://www.it.com.cn/edu/readme/2010/01 ... 26286.html
不知道行不行,这个问题不光在安装Ubuntu时出现
头像
smallapple
论坛版主
帖子: 7867
注册时间: 2009-03-28 15:12
送出感谢: 0
接收感谢: 19 次

Re: 【求助】关于三系统启动问题 hal.dll丢失

#4

帖子 smallapple » 2011-05-03 19:39

代码: 全选

cd ~/桌面 && wget 'http://nchc.dl.sourceforge.net/project/bootinfoscript/bootinfoscript/0.55/boot_info_script055.sh' && sudo bash boot_info_script055.sh
执行后把那个Results贴上来
头像
dotbusy
帖子: 34
注册时间: 2011-05-03 22:15
送出感谢: 0
接收感谢: 0

Re: 【求助】关于三系统启动问题 hal.dll丢失

#5

帖子 dotbusy » 2011-05-03 23:17

建议你进win7,然后找个工具叫 bootice,
然后看看你XP的那个分区,PBR是怎么类型的,
然后看看你XP的boot.ini是否指定的正确的分区,一般boot.ini安装后,win7安装的过程,会把自己当成C盘,XP也是。

至于分区的顺序,跟你的C D E F G H没关系,你要从分区管理软件里面看,如果你会,用win7自带的diskpart也行。
使用方法大概是,用管理员方式打开cmd,然后输入diskpart,之后输入select disk 0,之后输入list partition 就能看到各个分区的序号了。

BTW,你后面装的XP用的是ghost吧?如果是正常安装,你的WIN7就起不来了,个人判断是boot.ini的问题。

安装的顺序应该是 winxp -> win7 -> ubuntu,从低到高,从弱智OS到智能化。

玩多系统启动的,远离ghost。
MacBook Pro 5,5: Snow Leopard + Windows 7 Pro
ThinkPad X200: Windows 7 Pro + Ubuntu 11.04
tusheng
帖子: 739
注册时间: 2007-09-18 8:45
送出感谢: 1 次
接收感谢: 1 次

Re: 【求助】关于三系统启动问题 hal.dll丢失

#7

帖子 tusheng » 2011-05-06 7:05

5楼说的对,估计xp是ghost版本,装完xp后,用win7就进不了xp,再装了ubuntu照样进不去
回复

回到 “系统安装和升级”