【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

系统安装、升级讨论
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#1

帖子 温柔的猪 » 2011-05-04 13:23

笔记本型号是宏碁4745,以前用U盘装过10.04,是按网上搜到的一篇教程装的。
前几天从官网上下好ISO文件,按照官网上写的一步步走,用U盘安装。快安装结束的时候弹出个框,写着安装程序崩溃类似的一大堆话,点击确定后就好像进入了U盘模式(就是那个不能更改系统文件的模式),我以为失败了,就关机重启,谁知到重启后可以进入UBUNTU11.04,此时U盘已拔出,确认是安到硬盘里了。但是在桌面最左边的那行工具条最上边是个按钮写着“安装RELEASE”,点击后又是安装UBUNTU。。。到选择分区那里时给分出来的是其他NTFS格式的盘符,到这里就没敢继续下去了。
请教下,我这UBUNTU算是安装完成了吗?
:em20 :em20 :em20
头像
monk
帖子: 19507
注册时间: 2010-01-28 10:45
送出感谢: 6 次
接收感谢: 33 次

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#2

帖子 monk » 2011-05-04 13:38

确定没有完成安装

*********宁静致远*********
如果我说的有什么不对,请看签名第一行
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#3

帖子 温柔的猪 » 2011-05-04 16:16

为什么这么说呢?我现在可以进入系统,还更新了语言包和显卡驱动。
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#4

帖子 温柔的猪 » 2011-05-05 14:05

顶一下了。 :em06
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#5

帖子 onshoestring » 2011-05-05 14:07

在桌面最左边的那行工具条最上边是个按钮写着“安装RELEASE”,点击后又是安装UBUNTU。。。
没安装上,这是live环境。
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#6

帖子 温柔的猪 » 2011-05-05 14:20

onshoestring 写了:
在桌面最左边的那行工具条最上边是个按钮写着“安装RELEASE”,点击后又是安装UBUNTU。。。
没安装上,这是live环境。
那这位兄台,你知道我的问题出在哪里吗?
刚才搜索了下,用LIVE环境指的是用光盘或USB启动的,不能影响硬盘的。可我虽然是用USB安装的,但是我拔出USB后仍可启动UBUNTU啊。
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#7

帖子 onshoestring » 2011-05-05 14:23

终端运行:

代码: 全选

 cd ~/桌面 && wget 'http://nchc.dl.sourceforge.net/project/bootinfoscript/bootinfoscript/0.55/boot_info_script055.sh' && sudo bash boot_info_script055.sh
把RESULTS.txt文件内容贴上来,看看有没有安装上。
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#8

帖子 温柔的猪 » 2011-05-05 14:43

笔记本在家,晚上再传上来吧,谢谢帮忙。
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#9

帖子 温柔的猪 » 2011-05-05 20:57

Boot Info Script 0.55 dated February 15th, 2010

============================= Boot Info Summary: ==============================

=> Grub 2 is installed in the MBR of /dev/sda and looks for b2d.

sda1: _________________________________________________________________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files/dirs: /BOOTMGR /BOOT/BCD

sda2: _________________________________________________________________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files/dirs: /bootmgr /Boot/BCD

sda3: _________________________________________________________________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: No errors found in the Boot Parameter Block.
Operating System: Windows 7
Boot files/dirs: /Windows/System32/winload.exe

sda4: _________________________________________________________________________

File system: Extended Partition
Boot sector type: Unknown
Boot sector info:

sda5: _________________________________________________________________________

File system: ntfs
Boot sector type: Windows XP
Boot sector info: According to the info in the boot sector, sda5 starts
at sector 63.
Operating System:
Boot files/dirs:

sda6: _________________________________________________________________________

File system: ntfs
Boot sector type: Windows XP
Boot sector info: According to the info in the boot sector, sda6 starts
at sector 63.
Operating System:
Boot files/dirs:

sda7: _________________________________________________________________________

File system: ntfs
Boot sector type: Windows XP
Boot sector info: According to the info in the boot sector, sda7 starts
at sector 63.
Operating System:
Boot files/dirs:

sda8: _________________________________________________________________________

File system: ntfs
Boot sector type: Windows XP
Boot sector info: According to the info in the boot sector, sda8 starts
at sector 63.
Operating System:
Boot files/dirs:

sda9: _________________________________________________________________________

File system: ext4
Boot sector type: -
Boot sector info:
Operating System: Ubuntu 11.04
Boot files/dirs: /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

sda10: _________________________________________________________________________

File system: swap
Boot sector type: -
Boot sector info:

=========================== Drive/Partition Info: =============================

Drive: sda ___________________ _____________________________________________________

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition Boot Start End Size Id System

/dev/sda1 2,048 25,167,871 25,165,824 27 Hidden HPFS/NTFS
/dev/sda2 * 25,167,872 25,372,671 204,800 7 HPFS/NTFS
/dev/sda3 25,372,688 151,203,779 125,831,092 7 HPFS/NTFS
/dev/sda4 151,203,841 625,141,759 473,937,919 5 Extended
/dev/sda5 151,203,843 256,060,034 104,856,192 7 HPFS/NTFS
/dev/sda6 256,060,098 360,932,354 104,872,257 7 HPFS/NTFS
/dev/sda7 360,932,418 465,802,051 104,869,634 7 HPFS/NTFS
/dev/sda8 465,804,738 570,676,994 104,872,257 7 HPFS/NTFS
/dev/sda9 570,677,248 621,223,935 50,546,688 83 Linux
/dev/sda10 621,225,984 625,141,759 3,915,776 82 Linux swap / Solaris


blkid -c /dev/null: ____________________________________________________________

Device UUID TYPE LABEL

/dev/sda10 ee341814-74af-4e1f-8efd-153350dd15c4 swap
/dev/sda1 E0D8A820D8A7F2C8 ntfs PQSERVICE
/dev/sda2 7038A99738A95CBA ntfs SYSTEM RESERVED
/dev/sda3 FA3AABD93AAB90E5 ntfs Win7
/dev/sda4: PTTYPE="dos"
/dev/sda5 242F8E2AA5989DCA ntfs 程序
/dev/sda6 F757A06C7279DEFD ntfs 安远
/dev/sda7 C5CD88AA3A2A2AB6 ntfs 刘佳
/dev/sda8 EC39722F27B73356 ntfs 娱乐
/dev/sda9 8b682323-3bdc-4869-bf3b-106f6c597105 ext4
/dev/sda: PTTYPE="dos"

============================ "mount | grep ^/dev output: ===========================

Device Mount_Point Type Options

/dev/sda9 / ext4 (rw,errors=remount-ro,commit=0)


=========================== sda9/boot/grub/grub.cfg: ===========================

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
set have_grubenv=true
load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
set saved_entry="${prev_saved_entry}"
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z "${boot_once}" ]; then
saved_entry="${chosen}"
save_env saved_entry
fi
}

function recordfail {
set recordfail=1
if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
insmod vbe
insmod vga
insmod video_bochs
insmod video_cirrus
}

insmod part_msdos
insmod ext2
set root='(/dev/sda,msdos9)'
search --no-floppy --fs-uuid --set=root 8b682323-3bdc-4869-bf3b-106f6c597105
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=auto
load_video
insmod gfxterm
fi
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='(/dev/sda,msdos9)'
search --no-floppy --fs-uuid --set=root 8b682323-3bdc-4869-bf3b-106f6c597105
set locale_dir=($root)/boot/grub/locale
set lang=zh_CN
insmod gettext
if [ "${recordfail}" = 1 ]; then
set timeout=-1
else
set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 44,0,30; then
clear
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
if [ ${recordfail} != 1 ]; then
if [ -e ${prefix}/gfxblacklist.txt ]; then
if hwmatch ${prefix}/gfxblacklist.txt 3; then
if [ ${match} = 0 ]; then
set linux_gfx_mode=keep
else
set linux_gfx_mode=text
fi
else
set linux_gfx_mode=text
fi
else
set linux_gfx_mode=keep
fi
else
set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Ubuntu,Linux 2.6.38-8-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
set gfxpayload=$linux_gfx_mode
insmod part_msdos
insmod ext2
set root='(/dev/sda,msdos9)'
search --no-floppy --fs-uuid --set=root 8b682323-3bdc-4869-bf3b-106f6c597105
linux /boot/vmlinuz-2.6.38-8-generic root=UUID=8b682323-3bdc-4869-bf3b-106f6c597105 ro quiet splash vt.handoff=7
initrd /boot/initrd.img-2.6.38-8-generic
}
menuentry 'Ubuntu,Linux 2.6.38-8-generic (恢复模式)' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
set gfxpayload=$linux_gfx_mode
insmod part_msdos
insmod ext2
set root='(/dev/sda,msdos9)'
search --no-floppy --fs-uuid --set=root 8b682323-3bdc-4869-bf3b-106f6c597105
echo 'Loading Linux 2.6.38-8-generic ...'
linux /boot/vmlinuz-2.6.38-8-generic root=UUID=8b682323-3bdc-4869-bf3b-106f6c597105 ro single
echo 'Loading initial ramdisk ...'
initrd /boot/initrd.img-2.6.38-8-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod part_msdos
insmod ext2
set root='(/dev/sda,msdos9)'
search --no-floppy --fs-uuid --set=root 8b682323-3bdc-4869-bf3b-106f6c597105
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod part_msdos
insmod ext2
set root='(/dev/sda,msdos9)'
search --no-floppy --fs-uuid --set=root 8b682323-3bdc-4869-bf3b-106f6c597105
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows Recovery Environment (loader) (on /dev/sda1)" --class windows --class os {
insmod part_msdos
insmod ntfs
set root='(/dev/sda,msdos1)'
search --no-floppy --fs-uuid --set=root E0D8A820D8A7F2C8
drivemap -s (hd0) ${root}
chainloader +1
}
menuentry "Windows 7 (loader) (on /dev/sda2)" --class windows --class os {
insmod part_msdos
insmod ntfs
set root='(/dev/sda,msdos2)'
search --no-floppy --fs-uuid --set=root 7038A99738A95CBA
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f $prefix/custom.cfg ]; then
source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

=============================== sda9/etc/fstab: ===============================

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda9 during installation
UUID=8b682323-3bdc-4869-bf3b-106f6c597105 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda10 during installation
UUID=ee341814-74af-4e1f-8efd-153350dd15c4 none swap sw 0 0

=================== sda9: Location of files loaded by Grub: ===================


307.4GB: boot/grub/core.img
300.9GB: boot/grub/grub.cfg
293.5GB: boot/initrd.img-2.6.38-8-generic
307.4GB: boot/vmlinuz-2.6.38-8-generic
293.5GB: initrd.img
307.4GB: vmlinuz
=========================== Unknown MBRs/Boot Sectors/etc =======================

Unknown BootLoader on sda4

00000000 01 00 00 00 55 55 55 55 00 01 00 00 00 00 00 00 |....UUUU........|
*
00000060 41 00 00 00 55 55 55 a9 00 01 00 00 00 00 00 00 |A...UUU.........|
00000070 41 00 00 00 55 55 f5 82 00 01 00 00 00 00 00 00 |A...UU..........|
00000080 62 08 00 00 55 55 f5 2a 00 01 00 00 00 00 00 00 |b...UU.*........|
00000090 62 08 00 00 55 55 7d a8 00 01 00 00 00 00 00 00 |b...UU}.........|
000000a0 41 00 00 00 55 55 ff aa 00 01 00 00 00 00 00 00 |A...UU..........|
000000b0 41 00 00 00 55 55 ff 0a 00 01 00 00 00 00 00 00 |A...UU..........|
000000c0 41 00 00 00 55 55 ff 80 00 01 00 00 00 00 00 00 |A...UU..........|
000000d0 41 00 00 00 55 55 55 5e 00 01 00 00 00 00 00 00 |A...UUU^........|
000000e0 20 00 00 00 55 55 55 35 00 01 00 00 00 00 00 00 | ...UUU5........|
000000f0 21 00 00 00 55 55 55 02 00 01 00 00 00 00 00 00 |!...UUU.........|
00000100 41 00 00 00 55 55 55 0a 00 01 00 00 00 00 00 00 |A...UUU.........|
00000110 41 00 00 00 55 55 55 08 00 01 00 00 00 00 00 00 |A...UUU.........|
00000120 62 08 00 00 55 55 55 aa 00 01 00 00 00 00 00 00 |b...UUU.........|
00000130 41 00 00 00 55 55 55 7e 00 01 00 00 00 00 00 00 |A...UUU~........|
00000140 01 00 00 00 55 55 55 55 00 01 00 00 00 00 00 00 |....UUUU........|
*
00000170 21 00 00 00 f5 55 55 55 00 01 00 00 00 00 00 00 |!....UUU........|
00000180 21 00 00 00 ef 55 55 55 00 01 00 00 00 00 00 00 |!....UUU........|
00000190 21 00 00 00 ff 75 55 55 00 01 00 00 00 00 00 00 |!....uUU........|
000001a0 21 00 00 00 5d 55 55 55 00 01 00 00 00 00 00 00 |!...]UUU........|
000001b0 01 00 00 00 55 55 55 55 00 01 00 00 00 00 00 01 |....UUUU........|
000001c0 c1 ff 07 fe ff ff 02 00 00 00 80 fa 3f 06 00 fe |............?...|
000001d0 ff ff 05 fe ff ff 82 fa 3f 06 80 39 40 06 00 00 |........?..9@...|
000001e0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000001f0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 55 aa |..............U.|
00000200
头像
onshoestring
论坛版主
帖子: 4666
注册时间: 2009-09-06 5:53
送出感谢: 0
接收感谢: 108 次

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#10

帖子 onshoestring » 2011-05-05 21:12

# / was on /dev/sda9 during installation
# swap was on /dev/sda10 during installation
应该是装上了。
Grub 2 is installed in the MBR of /dev/sda and looks for b2d.
上面这个b2d不清楚什么意思。
正确的应该是这样子:looks on the same drive in partition #9

不清楚出了什么问题,不行就重新安装一下,分区选择自定义,更改,格式化。
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#11

帖子 温柔的猪 » 2011-05-07 10:55

谢谢,放心些了。 :em11
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#12

帖子 温柔的猪 » 2011-05-08 12:06

又重新安了遍,没出现上次那种崩溃提示。
两次安装的区别是,第一次装时联网了,并且将“安装时更新XX”勾上了,而第二次没有联网。不知道是不是由这点差别引起的。
新问题出来了,有线能用,无线灯始终不亮...
安装无线网卡驱动,提示失败,看论坛上有人说从10.10开始已支持这款网卡了。不知道问题在哪。
声卡驱动也不能安装,其实不知道用不用安装,我是参考网上4745装10.04这个帖子做的。
头像
mea
帖子: 109
注册时间: 2008-11-27 18:31
送出感谢: 0
接收感谢: 3 次

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#13

帖子 mea » 2011-05-08 13:46

温柔的猪 写了:又重新安了遍,没出现上次那种崩溃提示。
两次安装的区别是,第一次装时联网了,并且将“安装时更新XX”勾上了,而第二次没有联网。不知道是不是由这点差别引起的。
新问题出来了,有线能用,无线灯始终不亮...
安装无线网卡驱动,提示失败,看论坛上有人说从10.10开始已支持这款网卡了。不知道问题在哪。
声卡驱动也不能安装,其实不知道用不用安装,我是参考网上4745装10.04这个帖子做的。

我与你的情况一样,T400,第一次安装时选择了更新,到最后阶段时提示安装程序出错。第二次虽然联网,但没有更新,就顺利成功。
jtshs256
论坛版主
帖子: 22323
注册时间: 2010-07-19 21:41
系统: OS X
送出感谢: 2 次
接收感谢: 27 次

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#14

帖子 jtshs256 » 2011-05-08 13:51

应该是装上了,看起来u的安装程序的最后一步是卸载不用的软件,如多余语言包,没用到的文件系统工具,gparted等等,lz应该是在这步前崩溃的,没卸掉……
NO DO NO DIE
http://a/%%30%30
温柔的猪
帖子: 39
注册时间: 2010-05-24 10:55
送出感谢: 1 次
接收感谢: 0

Re: 【求助】笔记本用U盘安装11.04遇到的问题,不知道算不算安装完成

#15

帖子 温柔的猪 » 2011-05-08 17:15

jtshs256 写了:应该是装上了,看起来u的安装程序的最后一步是卸载不用的软件,如多余语言包,没用到的文件系统工具,gparted等等,lz应该是在这步前崩溃的,没卸掉……
那无线网络的问题能帮解决下吗?
回复

回到 “系统安装和升级”