Ubuntu10.10中安装低版本g++-3.4,请教!

系统安装、升级讨论
回复
头像
deyong
帖子: 17
注册时间: 2011-03-31 16:46
送出感谢: 0
接收感谢: 0

Ubuntu10.10中安装低版本g++-3.4,请教!

#1

帖子 deyong » 2011-05-16 9:18

我的机器不能上网,只能下载deb包安装。
我下载
g++-3.4_3.4.6-6ubuntu3_i386.deb、
libstdc++6-dev_3.4.6-6ubuntu3_i386.deb
之后安装,发现它们相互依赖。
根据网上的方法利用sudo dpkg --force-depends -i xxx.deb强制安装,
然后ln -sf /usr/bin/gcc-3.4 /usr/bin/gcc设其为默认版本,花的时间很短,一下就搞定了,感觉很不正常
执行:g++ --version后确实是g++-3.4。

这样安装是不是有问题啊,请高手们指点 :em23
回复

回到 “系统安装和升级”