当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : gnome3后无法直接进入桌面
帖子发表于 : 2011-05-23 11:08 

注册: 2008-12-26 13:36
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
ubuntu 11.04升级了gnome3:
sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install gnome-shell
sudo apt-get remove unity*
重启后,无法进入桌面,显示器有信号,但黑屏。
重启选择恢复模式,进入终端,运行startx,可以进入桌面,一切运行正常 :em11 ,但是注销或重启选择正常模式依然黑屏 :em20 ,只能每次都从恢复模式运行startx进入桌面 :em06
不知道各位有什么办法可以配置一下直接从正常模式进入桌面?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: gnome3后无法直接进入桌面
帖子发表于 : 2011-05-23 11:10 
头像

注册: 2007-12-14 13:40
帖子: 49877
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 413
处女帖 :em01

当时装G3时没遇到过,不清楚


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu


页首
 用户资料  
 
3 楼 
 文章标题 : Re: gnome3后无法直接进入桌面
帖子发表于 : 2011-05-23 11:12 

注册: 2008-12-26 13:36
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
呵,是啊,google了许久找不到解决的方法,只好在论坛看看,不知道那个文件配置文件是x-window的,找不到inittab! :em11


页首
 用户资料  
 
4 楼 
 文章标题 : Re: gnome3后无法直接进入桌面
帖子发表于 : 2011-05-23 11:31 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
把这两也装上
代码:
sudo apt-get install gnome gnome-extra


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
5 楼 
 文章标题 : Re: gnome3后无法直接进入桌面
帖子发表于 : 2011-05-23 11:35 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
还有这个
代码:
sudo apt-get install gdm


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
6 楼 
 文章标题 : Re: gnome3后无法直接进入桌面
帖子发表于 : 2011-05-23 12:22 

注册: 2008-12-26 13:36
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
monk 写道:
代码:
sudo apt-get install gnome gnome-extra

monk 写道:
代码:
sudo apt-get install gdm


gnome3要装这两个吗?

sudo apt-get install gnome
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
gnome : 依赖: gnome-desktop-environment (= 1:2.30+7ubuntu3) 但是它将不会被安装
依赖: epiphany-extensions 但是它将不会被安装
依赖: evolution-exchange (>= 2.30) 但是它将不会被安装 或
evolution-mapi (>= 0.30) 但是它将不会被安装
E: 破损的软件包

sudo apt-get install gdm
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
gdm 已经是最新的版本了。
下列软件包是自动安装的并且现在不需要了:
libdbusmenu-qt2 libreoffice-l10n-common libaccess-bridge-java
libqt4-declarative ttf-dejavu-extra libqtgconf1 libqt4-script icedtea-netx
libqt4-network libqt4-dbus java-common icedtea-6-jre-cacao libhsqldb-java
default-jre-headless libqtbamf1 openjdk-6-jre-lib libqtdee2
libqt4-xmlpatterns openjdk-6-jre-headless appmenu-qt
libaccess-bridge-java-jni default-jre libqtcore4 libgif4 icedtea-6-jre-jamvm
tzdata-java libqt4-sql libqt4-svg libservlet2.5-java libqt4-xml libqtgui4
ca-certificates-java libqt4-sql-mysql libreoffice-java-common libaudio2
openjdk-6-jre libnss3-1d libmng1
使用'apt-get autoremove'来卸载它们
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译