当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : you need to load the kernel first
帖子发表于 : 2011-06-17 16:17 

注册: 2011-06-02 10:04
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
请问我升级完内核之后,然后添加完启动项,reboot之后,选择新的内核版本,之后就出现you need to load the kernel first,press any key to continue,这是为什么啊,求解答~~~谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 16:27 
头像

注册: 2009-10-16 22:46
帖子: 18958
地址: finland
送出感谢: 28
接收感谢: 48
怎么添加的启动项?


_________________
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum


页首
 用户资料  
 
3 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 16:34 

注册: 2011-06-02 10:04
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
nmsfan 写道:
怎么添加的启动项?

首先复制grub.cfg中原来系统带的版本的启动命令,然后改成自己升级之后的版本menuentry "ubuntu,linux 2.6.32"{
insmod ntfs
set root=(hd0,5)
search --no-floppy --fs-uuid --set
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/ vmlinuz-2.6.32.2 root=/dev/sda5 loop=/ubuntu/disks/root.disk ro queit splash
initrd /boot/initrd.img-2.6.32.2}


页首
 用户资料  
 
4 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 16:35 
头像

注册: 2009-10-16 22:46
帖子: 18958
地址: finland
送出感谢: 28
接收感谢: 48
wubi啊,不懂..........


_________________
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum


页首
 用户资料  
 
5 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 20:11 
头像

注册: 2008-08-13 8:48
帖子: 26391
地址: 东海硇州,一双管钥。
系统: Fundu i64
送出感谢: 50
接收感谢: 344
更新GRUB2的配置文件看一下行不行,可能是配置文件有问题


_________________
◎当我站在道德的高度上俯视别人的时候,发现自己是多么渺小。
♥执着但不偏激,反对而不排斥,坚决捍卫矛盾体的存在方式。
★★★天气预报★★★
fcitx-yatable一个可以使用的码表输入法
[教程]几个实例攻克软件编译难关
Gentoo Development Guide
字体相关


页首
 用户资料  
 
6 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 20:20 
头像

注册: 2011-02-25 23:23
帖子: 3413
送出感谢: 3
接收感谢: 3
linux /boot/ vmlinuz-2.6.32.2 root=/dev/sda5 loop=/ubuntu/disks/root.disk ro queit splash
是不是vmlinuz前面多了个空格……


_________________
The storm of world shall soon vanish
With the days of darknes gone
The sun shall shine upon the ground
To peace shall the world return


页首
 用户资料  
 
7 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 20:31 

注册: 2011-06-02 10:04
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
YeLee 写道:
更新GRUB2的配置文件看一下行不行,可能是配置文件有问题

我更新过了,还是不行,好像是本身ubuntu9.10的bug貌似


页首
 用户资料  
 
8 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 20:33 

注册: 2011-06-02 10:04
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
pointer指针 写道:
linux /boot/ vmlinuz-2.6.32.2 root=/dev/sda5 loop=/ubuntu/disks/root.disk ro queit splash
是不是vmlinuz前面多了个空格……

那是我QQ上为了避免出现表情头像的方法,其实是没有的,哈哈~~


页首
 用户资料  
 
9 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 20:36 
头像

注册: 2011-02-25 23:23
帖子: 3413
送出感谢: 3
接收感谢: 3
zhangjing711 写道:
pointer指针 写道:
linux /boot/ vmlinuz-2.6.32.2 root=/dev/sda5 loop=/ubuntu/disks/root.disk ro queit splash
是不是vmlinuz前面多了个空格……

那是我QQ上为了避免出现表情头像的方法,其实是没有的,哈哈~~

…………这有不是qq :em05 :em05


_________________
The storm of world shall soon vanish
With the days of darknes gone
The sun shall shine upon the ground
To peace shall the world return


页首
 用户资料  
 
10 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 21:50 
头像

注册: 2008-08-13 8:48
帖子: 26391
地址: 东海硇州,一双管钥。
系统: Fundu i64
送出感谢: 50
接收感谢: 344
试一下手工输入吧,然后用TAB自动列出文件名,看行不行吧


_________________
◎当我站在道德的高度上俯视别人的时候,发现自己是多么渺小。
♥执着但不偏激,反对而不排斥,坚决捍卫矛盾体的存在方式。
★★★天气预报★★★
fcitx-yatable一个可以使用的码表输入法
[教程]几个实例攻克软件编译难关
Gentoo Development Guide
字体相关


页首
 用户资料  
 
11 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 21:53 

注册: 2011-06-02 10:04
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
YeLee 写道:
试一下手工输入吧,然后用TAB自动列出文件名,看行不行吧

那是得出现sh:grub才行吧,不然怎么手工输入啊~


页首
 用户资料  
 
12 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 21:57 

注册: 2005-09-13 4:56
帖子: 1034
系统: Ubuntu QQ
送出感谢: 0 次
接收感谢: 38
zhangjing711 写道:
nmsfan 写道:
怎么添加的启动项?

首先复制grub.cfg中原来系统带的版本的启动命令,然后改成自己升级之后的版本menuentry "ubuntu,linux 2.6.32"{
insmod ntfs
set root=(hd0,5)
search --no-floppy --fs-uuid --set
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/ vmlinuz-2.6.32.2 root=/dev/sda5 loop=/ubuntu/disks/root.disk ro queit splash
initrd /boot/initrd.img-2.6.32.2}


代码:
search --no-floppy --fs-uuid --set


--set后面的UUID被你复制到哪儿去了?


_________________
添加ppa后只更新此ppa:
update-ppa()
{ sudo apt-get update -o Dir::Etc::sourcelist="sources.list.d/$1.list" -o Dir::Etc::sourceparts="-" -o APT::Get::List-Cleanup="0"
}
写入~/.bashrc,source一下,就可以直接用,是不是很方便?觉得方便就按个赞。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 22:00 

注册: 2011-06-02 10:04
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
funicorn 写道:
zhangjing711 写道:
nmsfan 写道:
怎么添加的启动项?

首先复制grub.cfg中原来系统带的版本的启动命令,然后改成自己升级之后的版本menuentry "ubuntu,linux 2.6.32"{
insmod ntfs
set root=(hd0,5)
search --no-floppy --fs-uuid --set
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/ vmlinuz-2.6.32.2 root=/dev/sda5 loop=/ubuntu/disks/root.disk ro queit splash
initrd /boot/initrd.img-2.6.32.2}


代码:
search --no-floppy --fs-uuid --set


--set后面的UUID被你复制到哪儿去了?

UUID我省略了,其实是有的,一大串数据就省略了


页首
 用户资料  
 
14 楼 
 文章标题 : Re: you need to load the kernel first
帖子发表于 : 2011-06-17 22:46 

注册: 2011-06-02 10:04
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
本身ubuntu9.10有这样一个bug,当然可以去下载这个wubi的补丁,然后再装,就能成功,我最后放弃了ubuntu9.10的版本,采用了ubuntu8.04这样一个更稳定的版本,成功打上RTAI-3.8的补丁,谢谢大家~~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot], 药师9528 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译