Mint使用PPA

系统安装、升级讨论
回复
tastypear
帖子: 6
注册时间: 2010-10-26 23:11
送出感谢: 0
接收感谢: 0

Mint使用PPA

#1

帖子 tastypear » 2013-02-01 2:48

今天新装了Mint刚发现的问题,加入ppa后update,404
原因是在源里默认precise都变成了maya,改回来就好了

但每次添加都要改太麻烦,查了下改了lsb-release

代码: 全选

sudo gedit /etc/lsb-release
把mint改成了precise
重新加ppa,发现悲剧

代码: 全选

Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 160, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 96, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 584, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)    
  File "/usr/lib/python2.7/dist-packages/aptsources/distro.py", line 87, in get_sources
    raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template
于是搜啊搜,发现解法是这样
修改:
/usr/share/python-apt/templates/LinuxMint.info
复制一份maya块,然后把Suite: maya改成Suite: precise

其他mint版本依葫芦画瓢~
希望mint童鞋ppa玩得开心
回复

回到 “系统安装和升级”