新手求指导,升级时预见的依赖问题,跪求指导!

系统安装、升级讨论
回复
calvin00544
帖子: 2
注册时间: 2013-04-03 17:54
系统: win
送出感谢: 0
接收感谢: 0

新手求指导,升级时预见的依赖问题,跪求指导!

#1

帖子 calvin00544 » 2013-04-03 18:06

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
下列软件包是自动安装的并且现在不需要了:
gir1.2-launchpad-integration-3.0 libwpg-0.2-2 python-ubuntuone-control-panel
python-piston-mini-client libwps-0.2-2 gir1.2-gmenu-3.0 libwpd-0.9-9
使用'apt-get autoremove'来卸载它们
将会安装下列额外的软件包:
fonts-liberation libreoffice-core
下列软件包将被升级:
fonts-liberation libreoffice-core
升级了 2 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 194 个软件包未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0 B/38.7 MB 的软件包。
解压缩后会消耗掉 62.5 kB 的额外空间。
您希望继续执行吗?[Y/n]Y
(正在读取数据库 ... 系统当前共安装有 268013 个文件和目录。)
正预备替换 libreoffice-core 1:3.5.4-0ubuntu1.1 (使用 .../libreoffice-core_1%3a3.5.7-0ubuntu4_i386.deb) ...
rmdir: 删除 "/var/lib/libreoffice/basis3.4/program/" 失败: 没有那个文件或目录
rmdir: 删除 "/var/lib/libreoffice/basis3.4" 失败: 没有那个文件或目录
正在解压缩将用于更替的包文件 libreoffice-core ...
dpkg:处理 /var/cache/apt/archives/libreoffice-core_1%3a3.5.7-0ubuntu4_i386.deb (--unpack)时出错:
文件系统的 tar 文件已损坏 - 软件包文件已毁损
dpkg-deb: error: subprocess 粘贴 was killed by signal (断开的管道)
dpkg:关于含有 fonts-liberation 的 .../fonts-liberation_1.07.0-2ubuntu0.1_all.deb:
fonts-liberation 冲突于 ttf-liberation (<< 1.07.0-3)
ttf-liberation (版本为 1.07.0-2ubuntu0.1)已存在并且 已安装。
dpkg:处理 /var/cache/apt/archives/fonts-liberation_1.07.0-2ubuntu0.1_all.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 fonts-liberation
正在处理用于 bamfdaemon 的触发器...
Rebuilding /usr/share/applications/bamf.index...
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 gnome-menus 的触发器...
在处理时有错误发生:
/var/cache/apt/archives/libreoffice-core_1%3a3.5.7-0ubuntu4_i386.deb
/var/cache/apt/archives/fonts-liberation_1.07.0-2ubuntu0.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



貌似是libreoffice-core 和 fonts-liberation 跪求解决方法。
我用apt-get move fonts-liberation也卸载不掉是为什么
头像
mraandtux
论坛版主
帖子: 5108
注册时间: 2009-12-12 19:29
系统: Ubuntu + Windows 10
来自: 随便一个地方
送出感谢: 0
接收感谢: 161 次
联系:

Re: 新手求指导,升级时预见的依赖问题,跪求指导!

#2

帖子 mraandtux » 2013-04-03 19:19

看下面的帖子:
viewtopic.php?f=86&t=90547
calvin00544
帖子: 2
注册时间: 2013-04-03 17:54
系统: win
送出感谢: 0
接收感谢: 0

Re: 新手求指导,升级时预见的依赖问题,跪求指导!

#3

帖子 calvin00544 » 2013-04-04 0:08

没有找到解决办法阿,都不行阿。想知道为什么是libreoffice-core 和 fonts-liberation 冲突,我想删除一个怎么办阿
回复

回到 “系统安装和升级”