当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装12.04LTS时已有的windows7没有被认出来!!(不可能是分区表问题)
帖子发表于 : 2013-04-12 18:22 

注册: 2012-01-02 12:53
帖子: 46
送出感谢: 0 次
接收感谢: 2
置顶的帖子老早就看过了,想当年装11.10时的确是自己用第三方软件分区可能导致了分区表错误。这次情形完全不同。我发现安装提示说 This computer currently has no detected operating systems 时,我干脆先不装了,直接重装了window 7,在装win7的时候把已有的分区都删除了,重新分区,格式化,然后装好 win7。也就是说硬盘分区不是第三方软件分的,也不是win7自带工具分的,就是装win7时的安装界面里分的。这个总不可能还搞出分区表错误吧。心想,这下安装ubuntu,该没问题了。因为我上次在另一台电脑上装11.10就是先重装win7,再装ubuntu就解决了问题的。

可惜的是,ubuntu安装界面仍然提示没有发现任何操作系统。怎么回事呢?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装12.04LTS时已有的windows7没有被认出来!!(不可能是分区表问题)
帖子发表于 : 2013-04-12 18:52 
头像

注册: 2010-10-27 20:43
帖子: 370
送出感谢: 2
接收感谢: 15
建议下载我制作的vbuntu.vhd。下载解压以后就是一个安装好的完整ubuntu系统。
ubuntu 12.04.2 LTS 64位
再设置启动引导即可。
接着可以使用UCloner将这个VHD系统克隆到自己准备好的硬盘分区上,就得到物理系统了。


_________________
牛是牛顿的牛 毛是朱毛的毛


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装12.04LTS时已有的windows7没有被认出来!!(不可能是分区表问题)
帖子发表于 : 2013-04-12 20:19 

注册: 2012-01-02 12:53
帖子: 46
送出感谢: 0 次
接收感谢: 2
怕有重合,特地把100M的隐藏分区和win 7的C分区(/dev/sda2)之间先释放了16M,再扩充15M;同样C盘和D盘之间也这么做。
进入ubuntu安装界面后,
sudo fdisk -l
看到如下信息:
Boot start end
sda1 * 2048 204799
sda2 206848 251863039
sda3 251865088 660846591

请问有什么问题么?我没看到有分区之间重叠的情况啊。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装12.04LTS时已有的windows7没有被认出来!!(不可能是分区表问题)
帖子发表于 : 2013-04-12 20:40 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 20
用diskgen看看分区参数是不是正常


_________________
Grub2 基础教程


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装12.04LTS时已有的windows7没有被认出来!!(不可能是分区表问题)
帖子发表于 : 2013-04-12 23:14 

注册: 2012-01-02 12:53
帖子: 46
送出感谢: 0 次
接收感谢: 2
谢谢两位!我已经果断装了XP,可恶的win7隐藏分区再也无法作梗了。牺牲了achi,在bios里把它改成了ata。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装12.04LTS时已有的windows7没有被认出来!!(不可能是分区表问题)
帖子发表于 : 2013-04-12 23:25 
头像

注册: 2012-12-07 23:02
帖子: 26
系统: ubtuntu
送出感谢: 4
接收感谢: 0 次
我好像都是预留一部分磁盘空间装在哪里。我觉得装在我的d,e盘都不是很好。我是个新手我承认。。。。楼上们的回答好.........难上手对于我这么菜的


_________________
我就是一个水。。。水泥匠>.<||
ubuntu skills


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装12.04LTS时已有的windows7没有被认出来!!(不可能是分区表问题)
帖子发表于 : 2013-04-14 18:28 
头像

注册: 2009-12-06 15:04
帖子: 680
送出感谢: 15
接收感谢: 3
我在有win8的电脑上装ubuntu 12.10时,也是没认出已经装了的win8.
不过装完后,用boot-repair修复下就可以了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译