当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安卓ubuntu13.04的曲折经历……装好了但还是有问题求助~~
帖子发表于 : 2013-05-03 17:02 

注册: 2013-05-03 16:01
帖子: 3
系统: win7+ubuntu
送出感谢: 0 次
接收感谢: 0 次
计算机专业大二菜比学生,64bit机器ubuntu-13.04-desktop-amd64.iso镜像……原来ubuntu一直用的虚拟机,前两天心血来潮要怒学好操作系统,决定先装个ubuntu!!!
第一次:
1.在官网上下了个ubuntu13.04的镜像放在空盘Z上
2.把wubi.exe解压了安装就成功了……

第二次:百科了一下发现wubi是类似虚拟机的东西,性能比较差,所以决定用u盘装,直接把Z盘格式化了……
1.下载了UltraISO软件把镜像刻录在我的8g u盘上,
2.重启后安装好了,再重启后选择ubuntu进入后出现
文件:/…/wubildr.mrb
错误:0xc000000f无法加载文件或操作系统,因为应用程序丢失或损坏
(是不是因为之前wubi安装的时候引导没删除,然后u盘装的时候没引导啊……不知道……)
3.进入win7系统把c盘的wubildr.mbr和另一个文件(忘了是什么啦)给怒删了
4.下载了EasyBCD2.2把原来引导删了,把新装的ubuntu引导grub2(百度了说好像其实是grub4dos?)装上
5.重启后进入grub>黑屏画面,小菜比又不知道怎么办了,赶紧百度之
找到两种都试了一下
(1)用livecd修复grub,没效果还是grub>界面
(2)grub>kernel (hd0,8)/boot/vmlinuz-2.6.20-15-generic boot=/dev/sda9 是指定内核文件路径及名字
grub>initrd /boot/initrd.img-2.6.20-15-generic 说明initrd文件的地址
grub>boot
发现/dev目录下没有sda……hda也没有……(还特意用liveCD启动看看安装ubuntu的盘……)

第三次:不行就重装吧,所有东西都给干掉
第四次:……
……

第几次了?:一怒之下,不用u盘了……用硬盘……
1.把iso文件和iso中解压出来的vmlinuz.efi、initrd.lz都放在c盘
2.EasyBCD里添加NeoGrub
安装-> 配置->
配置中写
title Ubuntu 13.04 install
root (hd0,0)
kernel /vmlinuz.efi boot=casper iso-scan/filename=/ubuntu-13.04-desktop-amd64.iso ro quiet splash
initrd /initrd.lz
boot
3.重启选择系统那个界面后选择NeoGrub引导,之后install ubuntu吧
4.分区参照网上的/boot 100M /swap 1G / 10G 其他都给 /home
5.卡在“正在探测文件系统……”,再次发挥有事百度之的优良风格,直接按电源关了,安装前先打开终端输入sudo umount -l /isodevice解决问题
成功安装了~~~ :em06

问题又来了:
1.无法关闭独显,独显一直工作发热严重,百度了几个方法没解决
例如sudo su
echo IGD > /sys/kernel/debug/vgaswitcheroo/switch
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
debug下没找到vgaswitcheroo文件最后直接在bios设置关闭独显,不过关闭后进入win7的时候看着界面有问题,如原来是1366*768结果变成1024*768
2.关机的时候一直卡在关机界面关不了,百度没解决,可以重启~

写的有点长了……先谢谢啦~


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安卓ubuntu13.04的曲折经历……装好了但还是有问题求助~~
帖子发表于 : 2013-05-03 20:54 

注册: 2013-03-27 22:52
帖子: 1
系统: windows8
送出感谢: 0 次
接收感谢: 0 次
我用U盘折腾了数次,没有出现过你说的这些问题,我折腾过几个版本的了,我是装在移动硬盘上的,引导也是用的移动硬盘。 :em04一个让我吐血的问题就是13.04总是出现系统内部出错之类的错误,感觉还是12.04稳定。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安卓ubuntu13.04的曲折经历……装好了但还是有问题求助~~
帖子发表于 : 2013-05-03 22:18 

注册: 2013-05-03 16:01
帖子: 3
系统: win7+ubuntu
送出感谢: 0 次
接收感谢: 0 次
wuguozhou 写道:
我用U盘折腾了数次,没有出现过你说的这些问题,我折腾过几个版本的了,我是装在移动硬盘上的,引导也是用的移动硬盘。 :em04一个让我吐血的问题就是13.04总是出现系统内部出错之类的错误,感觉还是12.04稳定。

之前用的12.04的虚拟机……好吧,其实装上去没怎么用,我在想要不要再把13.04删了装12.04了……


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译