救急啊,安装有问题,是python-dev 引起的。

系统安装、升级讨论
回复
头像
yqq
帖子: 67
注册时间: 2009-04-02 13:35
送出感谢: 0
接收感谢: 0

救急啊,安装有问题,是python-dev 引起的。

#1

帖子 yqq » 2013-05-07 18:30

小弟这更新出了点问题,用不了了。错误是python-dev引起的。情况如下:
test@test-server:~/Downloads$ sudo apt-get install snmpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
python-dev : Depends: python (= 2.7.3-0ubuntu2) but 2.7.3-0ubuntu2.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

不知有没有人也有过这个问题?我用的是ubuntu 12.04.
头像
mraandtux
论坛版主
帖子: 5106
注册时间: 2009-12-12 19:29
系统: Ubuntu + Windows 10
来自: 随便一个地方
送出感谢: 0
接收感谢: 161 次
联系:

Re: 救急啊,安装有问题,是python-dev 引起的。

#2

帖子 mraandtux » 2013-05-07 19:38

有没有试过运行sudo apt-get -f install 或者换源?
头像
yqq
帖子: 67
注册时间: 2009-04-02 13:35
送出感谢: 0
接收感谢: 0

Re: 救急啊,安装有问题,是python-dev 引起的。

#3

帖子 yqq » 2013-05-08 10:02

现在解决了,谢谢。
1, sudo apt-get -f install
2, sudo apt-get automove
3, 换源
4, sudo apt-get update.
回复

回到 “系统安装和升级”