win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

系统安装、升级讨论
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#16

帖子 poloshiao » 2017-11-26 8:33

ACER Spin SP513-51
奇怪,BIOS里 “Secure boot” 默认enable, 而且灰色不可调!
1. https://community.acer.com/en/discussio ... ll-windows
Acer Spin 5 SP513-51 unable to install windows

2. 上一篇 是 Aspire V5-171
裡面描述 需要從 UEFI 設定 supervisor password 才能把 “Secure boot” 改為 disabled
https://community.acer.com/en/discussio ... ire-v5-171
2-1. 如果還是有困難 向 acer 官網 技術客服 諮詢看看
http://www.asus.com.cn/support/
ASUS中国
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#17

帖子 poloshiao » 2017-11-26 8:55

我的Thinkpad自己加了一块128G SSD,把它当win10的安装盘了。我在第二块500G的机械上安装的ubuntu
GRUB安装在第二块机械硬盘上了。我SSD是第一启动磁盘,启动时没有菜单直接进入Win10,如果把第二块机械
硬盘设为第一启动磁盘,就有GRUB菜单了,进win10也没有问题。
1. 這一種安排 適用於 Legacy Bios 開機 對於 UEFI 還需要其它安排
1-1. Legacy Bios 開機導引 一部分程式碼 安裝在硬盤第一分割區前端外面到硬盤的起點 (就是一般所說的 MBR)
1-1-1. 該硬盤 就是你安裝 Ubuntu 時 所選擇的 /dev/sda 或 /dev/sdb
2. UEFI 則把所有的作業系統 開機程式碼 全部儲存在 主機版上的 NVRAM
https://en.wikipedia.org/wiki/Non-volat ... ess_memory
2-1. 跟硬盤上的 MBR 無關 (意思是 選擇 /dev/sda 或 /dev/sdb 結果 都不影響 UEFI 開機行為)
2-1-1. 但是 一般安裝 Ubuntu 的 tutorial 還是習慣性 建議 把 grub 2 安裝在 /dev/sda 或 /dev/sdb ...
2-2. UEFI 的開機程序 大約是
NVRAM --> esp (efi system partition) --> 開機選單 (例如 grub.cfg)
不存取 MBR
头像
男菜鸟
帖子: 1180
注册时间: 2008-12-16 14:01
来自: 漂在江湖
送出感谢: 14 次
接收感谢: 15 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#18

帖子 男菜鸟 » 2017-11-26 10:01

@15楼

此机13.3",只有一个256G SSD,没有打开后盖看过,估计没有地方安装第二个硬盘了。
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#19

帖子 poloshiao » 2017-11-26 12:06

估计没有地方安装第二个硬盘了。
如果你的筆電支援 USB 裝置開機 (就如同 U 盤開機)
有必要的話 可以使用 外接硬盤
fuhuizn
帖子: 740
注册时间: 2006-01-06 22:55
系统: ubuntu
送出感谢: 0
接收感谢: 14 次
联系:

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#20

帖子 fuhuizn » 2017-11-26 14:22

楼主安装时肯定没有把 GRUB 装在默认位置
头像
男菜鸟
帖子: 1180
注册时间: 2008-12-16 14:01
来自: 漂在江湖
送出感谢: 14 次
接收感谢: 15 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#21

帖子 男菜鸟 » 2017-11-26 18:33

@20楼
见6楼图片!GRUB肯定安装在正确位置。我在不同的电脑上安装UBT,不止3,40次,有信心GRUB安装位置不会错!

@poloshiao
1.
需要從 UEFI 設定 supervisor password 才能把 “Secure boot” 改為 disabled
由此设置Secure boot” 改為 disabled成功!再次试验Live USB安装UBT,顺利安装!
但是重启后,还是不见双系统菜单,并直接进入WIN10 :Cry WIN10这么强大吗?
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#22

帖子 poloshiao » 2017-11-26 18:49

由此设置Secure boot” 改為 disabled成功!再次试验Live USB安装UBT,顺利安装!
1. 恭喜你
但是重启后,还是不见双系统菜单,并直接进入WIN10 :Cry WIN10这么强大吗?
2. http://forum.ubuntu.com.cn/viewtopic.ph ... 8#p3199118
登入試用桌面
把下面指令 複製 貼進終端機 執行
2-1. sudo efibootmgr -v
2-2. sudo parted -l print
2-3. sudo ls -al /dev/disk/by-uuid/*
2-4. sudo ls -al /dev/disk/by-partuuid/*
把結果全部直接 選取/複製/貼上來
不要摘錄 以免遺漏重要訊息
不要擷圖 方便回文直接引用你貼上來的資料 方便你閱讀
头像
男菜鸟
帖子: 1180
注册时间: 2008-12-16 14:01
来自: 漂在江湖
送出感谢: 14 次
接收感谢: 15 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#23

帖子 男菜鸟 » 2017-11-26 22:36

恭喜你
1.首先要感谢你的耐心指导!还没有看到双系统菜单,“喜”从何来? :Hehe

2.指令记录:
ubuntu@ubuntu:~$ sudo efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,2001,2002,2003
Boot0000* Unknown Device: HD(1,GPT,fd186b9c-c3dc-4d82-8531-cfc78aaa8d50,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0001* Windows Boot Manager HD(1,GPT,fd186b9c-c3dc-4d82-8531-cfc78aaa8d50,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0002* USB HDD: CBM Flash Disk PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(1,MBR,0x21,0x2de0dc,0x1240)RC
Boot0003* ubuntu HD(1,GPT,fd186b9c-c3dc-4d82-8531-cfc78aaa8d50,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC

ubuntu@ubuntu:~$ sudo parted -l print
Model: ATA Micron_1100_MTFD (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 123MB 16.8MB Microsoft reserved partition msftres
3 123MB 88.3GB 88.2GB ntfs Basic data partition msftdata
4 88.3GB 151GB 62.7GB ntfs Basic data partition msftdata
6 151GB 172GB 20.5GB ext4
8 172GB 247GB 75.0GB ext4
7 247GB 255GB 8470MB linux-swap(v1)
5 255GB 256GB 1074MB ntfs Basic data partition hidden, diag


Warning: The driver descriptor says the physical block size is 2048 bytes, but
Linux says it is 512 bytes.
Ignore/Cancel? i
Model: CBM Flash Disk (scsi)
Disk /dev/sdb: 16.4GB
Sector size (logical/physical): 2048B/512B
Partition Table: mac
Disk Flags:

Number Start End Size File system Name Flags
1 2048B 6143B 4096B Apple
2 1539MB 1542MB 2392kB EFI

ubuntu@ubuntu:~$ sudo ls -al /dev/disk/by-uuid/*
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/0A10809810808C7F -> ../../sda3
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/1979039BE266F3E8 -> ../../sda4
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/2017-08-01-11-51-33-00 -> ../../sdb1
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/2c8c6f31-d96d-47fd-a780-9b50d6f3dc46 -> ../../sda6
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/398E-230F -> ../../sdb2
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/556c4203-adfb-4f82-b01a-f543eb4eb5f2 -> ../../sda7
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/5A7C-741D -> ../../sda1
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/c5411d72-a667-4b33-b86f-a67ebca93d36 -> ../../sda8
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-uuid/FE1081811081421F -> ../../sda5

ubuntu@ubuntu:~$ sudo ls -al /dev/disk/by-partuuid/*
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-partuuid/517568a0-dd4a-4148-8098-f72372ee523f -> ../../sda4
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-partuuid/98fa6240-928e-4f15-8459-da99ba22eee9 -> ../../sda3
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-partuuid/b749a7bf-30bb-4726-8137-edc750df26ab -> ../../sda2
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-partuuid/b8620ff2-f7b6-4042-a86a-27095084dd77 -> ../../sda6
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-partuuid/d7a244fd-13b4-4c1f-aa30-f75c88859320 -> ../../sda8
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-partuuid/e4f1d068-09c3-46e9-874c-4d7eed5e8768 -> ../../sda5
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-partuuid/fbf95d56-c417-4e3b-8e30-1792c4bca557 -> ../../sda7
lrwxrwxrwx 1 root root 10 Nov 26 13:43 /dev/disk/by-partuuid/fd186b9c-c3dc-4d82-8531-cfc78aaa8d50 -> ../../sda1
头像
男菜鸟
帖子: 1180
注册时间: 2008-12-16 14:01
来自: 漂在江湖
送出感谢: 14 次
接收感谢: 15 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#24

帖子 男菜鸟 » 2017-11-26 23:01

1.发现:
ubuntu@ubuntu:~$ sudo efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,2001,2002,2003
于是再次:

代码: 全选

sudo efibootmgr -o [color=#FF0000]0003[/color],0001,2001,2002,2003
重新启动开机时,启动时间拉长,但还是没有双系统菜单,并最后进入WIN10!
从时间变长看,似乎曾经有启动UBT的过程,但是没有成功。
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#25

帖子 poloshiao » 2017-11-27 7:19

sudo efibootmgr -o 0003,0001,2001,2002,2003
終端機下指令時 不必加 [color][/color] 碼
sudo efibootmgr -o 0003,0001,2001,2002,2003
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#26

帖子 poloshiao » 2017-11-27 7:40

Boot0003* ubuntu HD(1,GPT,fd186b9c-c3dc-4d82-8531-cfc78aaa8d50,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
图片

1. 你安裝 Ubuntu 時 把 /dev/sda8 掛載到 / ?
1-1. 因為你沒有把 /boot 掛載到 獨立分割區 所以 安裝時 也會自動掛載到 /dev/sda8

2. 但是 沒有把 /dev/sda1 掛載到 /boot/efi ? 這個掛載是必須的
2-1. 等一下 手動幫你加到 /etc/fstab 看看

3. 登入 試用桌面 把下面指令 複製 貼進終端機 執行
1. sudo mount -t ext4 /dev/sda8 /mnt
2. sudo mount -t vfat /dev/sda1 /mnt/boot/efi
3. sudo ls -Al /mnt/boot/efi/EFI/ubuntu
4. sudo cat -n /mnt/etc/fstab
5. sudo cat -n /mnt/boot/efi/EFI/ubuntu/grub.cfg
6. sudo cat -n /mnt/boot/grub/grub.cfg | grep -i menuentry
把 3,4,5,6 結果直接 選取/複製 貼上來
7. 如果出現錯誤訊息 把錯誤訊息 全部複製貼上來
头像
男菜鸟
帖子: 1180
注册时间: 2008-12-16 14:01
来自: 漂在江湖
送出感谢: 14 次
接收感谢: 15 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#27

帖子 男菜鸟 » 2017-11-27 13:36

你安裝 Ubuntu 時 把 /dev/sda8 掛載到 / ?
我安装UBT,从来不设"/boot".只设置“/”,“/home”.你是说必须设置“/boot”?

本例中 /dev/sda6 掛載到 /;/dev/sda8 掛載到 /home
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#28

帖子 poloshiao » 2017-11-27 14:57

我安装UBT,从来不设"/boot".只设置“/”,“/home”.你是说必须设置“/boot”?
1. 你安裝 Ubuntu 時 把 /dev/sda8 掛載到 / ?
1-1. 因為你沒有把 /boot 掛載到 獨立分割區 所以 安裝時 也會自動掛載到 /dev/sda8
1. 沒有說一定要把 /boot 掛載到 獨立分割區
2. 但是 沒有把 /dev/sda1 掛載到 /boot/efi ? 這個掛載是必須的
2. 但是 UEFI 開機 把 /boot/efi 掛載到 esp (即 /dev/sda1) 是最好的
2-1. 如果忘了 安裝程式 可能會 自動幫你 把 /boot/efi 掛載到 esp
2-1-1. 但是 是否完美完成 就可能要看情況了
头像
男菜鸟
帖子: 1180
注册时间: 2008-12-16 14:01
来自: 漂在江湖
送出感谢: 14 次
接收感谢: 15 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#29

帖子 男菜鸟 » 2017-11-27 16:07

ubuntu@ubuntu:~$ sudo mount -t ext4 /dev/sda8 /mnt
ubuntu@ubuntu:~$ sudo mount -t vfat /dev/sda1 /mnt/boot/efi
mount: mount point /mnt/boot/efi does not exist
ubuntu@ubuntu:~$ sudo ls -Al /mnt/boot/efi/EFI/ubuntu
ls: cannot access '/mnt/boot/efi/EFI/ubuntu': No such file or directory
ubuntu@ubuntu:~$ sudo cat -n /mnt/etc/fstab
cat: /mnt/etc/fstab: No such file or directory
ubuntu@ubuntu:~$ sudo cat -n /mnt/boot/efi/EFI/ubuntu/grub.cfg
cat: /mnt/boot/efi/EFI/ubuntu/grub.cfg: No such file or directory
ubuntu@ubuntu:~$ sudo cat -n /mnt/boot/grub/grub.cfg | grep -i menuentry
cat: /mnt/boot/grub/grub.cfg: No such file or directory
ubuntu@ubuntu:~$
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: win10系统安装双系统ubuntu16.04.3后,没有grub菜单,直接进win

#30

帖子 poloshiao » 2017-11-27 16:19

本例中 /dev/sda6 掛載到 /;/dev/sda8 掛載到 /home
0. 抱歉 疏忽了
sudo cat -n /mnt/etc/fstab
cat: /mnt/etc/fstab: No such file or directory
sudo cat -n /mnt/boot/grub/grub.cfg | grep -i menuentry
cat: /mnt/boot/grub/grub.cfg: No such file or directory
1. 先
sudo umount /dev/sda8
sudo mount -t ext4 /dev/sda6 /mnt

sudo cat -n /mnt/etc/fstab
sudo cat -n /mnt/boot/grub/grub.cfg | grep -i menuentry
sudo mount -t vfat /dev/sda1 /mnt/boot/efi
mount: mount point /mnt/boot/efi does not exist
sudo ls -Al /mnt/boot/efi/EFI/ubuntu
ls: cannot access '/mnt/boot/efi/EFI/ubuntu': No such file or directory
sudo cat -n /mnt/boot/efi/EFI/ubuntu/grub.cfg
cat: /mnt/boot/efi/EFI/ubuntu/grub.cfg: No such file or directory
2. 先
sudo mkdir -p /mnt/boot/efi

sudo mount -t vfat /dev/sda1 /mnt/boot/efi
sudo ls -Al /mnt/boot/efi/EFI/ubuntu
sudo cat -n /mnt/boot/efi/EFI/ubuntu/grub.cfg
回复

回到 “系统安装和升级”